summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-07-22 17:12:53 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-07-22 17:12:53 +0000
commit7f44650e0584759458db9fba738a4a4e292872ef (patch)
treea23ee233bab11719800d23e08ea215d49341c948 /app-sci/qmatplot
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-7f44650e0584759458db9fba738a4a4e292872ef.tar.gz
gentoo-2-7f44650e0584759458db9fba738a4a4e292872ef.tar.bz2
gentoo-2-7f44650e0584759458db9fba738a4a4e292872ef.zip
oops, forgot the patch for gcc-3.4 ;-)
Diffstat (limited to 'app-sci/qmatplot')
-rw-r--r--app-sci/qmatplot/ChangeLog4
-rw-r--r--app-sci/qmatplot/files/qmatplot-0.4.2-gcc34.patch35
-rw-r--r--app-sci/qmatplot/qmatplot-0.4.2-r1.ebuild5
3 files changed, 40 insertions, 4 deletions
diff --git a/app-sci/qmatplot/ChangeLog b/app-sci/qmatplot/ChangeLog
index b0986e157171..53b58a143cbc 100644
--- a/app-sci/qmatplot/ChangeLog
+++ b/app-sci/qmatplot/ChangeLog
@@ -1,9 +1,9 @@
# ChangeLog for app-sci/qmatplot
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/qmatplot/ChangeLog,v 1.6 2004/07/22 17:08:17 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/qmatplot/ChangeLog,v 1.7 2004/07/22 17:12:53 kugelfang Exp $
22 Jul 2004; Danny van Dyk <kugelfang@gentoo.org> qmatplot-0.4.2-r1.ebuild:
- Marked ~amd64.
+ Marked ~amd64. Added gcc-3.4 patch.
19 Apr 2004; Patrick Kursawe <phosphan@gentoo.org> qmatplot-0.4.2-r1.ebuild,
qmatplot-0.4.2.ebuild:
diff --git a/app-sci/qmatplot/files/qmatplot-0.4.2-gcc34.patch b/app-sci/qmatplot/files/qmatplot-0.4.2-gcc34.patch
new file mode 100644
index 000000000000..1aa77b36765d
--- /dev/null
+++ b/app-sci/qmatplot/files/qmatplot-0.4.2-gcc34.patch
@@ -0,0 +1,35 @@
+--- src/ksmatrix.h.orig 2003-03-11 16:16:24.000000000 +0100
++++ src/ksmatrix.h 2004-07-22 18:01:12.064261800 +0200
+@@ -332,8 +332,8 @@
+ class KSMatrixFormula : public QSMatrix
+ {
+ Q_OBJECT
+- Q_PROPERTY( QString formula READ formula WRITE setFormula );
+- Q_PROPERTY( bool transposition READ transposition WRITE setTransposition );
++ Q_PROPERTY( QString formula READ formula WRITE setFormula )
++ Q_PROPERTY( bool transposition READ transposition WRITE setTransposition )
+
+ public:
+ /**
+--- src/qscobjects.h.orig 2003-03-11 13:07:48.000000000 +0100
++++ src/qscobjects.h 2004-07-22 18:31:06.833415416 +0200
+@@ -246,7 +246,7 @@
+ QSGArrow m_end2style;
+ QSGPoint m_end1point;
+ QSGPoint m_end2point;
+- QSGLine m_line;;
++ QSGLine m_line;
+ };
+
+ //-----------------------------------------------------------------------//
+--- src/kspanelmanager.cpp.orig 2004-07-22 18:47:47.262327104 +0200
++++ src/kspanelmanager.cpp 2004-07-22 18:48:03.957789008 +0200
+@@ -47,7 +47,7 @@
+ Qt::Orientation o;
+
+ qmatplotShell *shell;
+- KSWorkbook *workbook;;
++ KSWorkbook *workbook;
+ KSPanel *curr_panel;
+
+ QSplitter *splitter;
diff --git a/app-sci/qmatplot/qmatplot-0.4.2-r1.ebuild b/app-sci/qmatplot/qmatplot-0.4.2-r1.ebuild
index 6efe09d6035e..044a805899db 100644
--- a/app-sci/qmatplot/qmatplot-0.4.2-r1.ebuild
+++ b/app-sci/qmatplot/qmatplot-0.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/qmatplot/qmatplot-0.4.2-r1.ebuild,v 1.4 2004/07/22 17:08:17 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/qmatplot/qmatplot-0.4.2-r1.ebuild,v 1.5 2004/07/22 17:12:53 kugelfang Exp $
inherit eutils
@@ -20,7 +20,8 @@ DEPEND=">=x11-libs/qt-3
src_unpack() {
unpack ${A}
cd ${S}
- epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch ${FILESDIR}/${P}-gentoo.patch
+ epatch ${FILESDIR}/${P}-gcc34.patch
}
src_compile() {