summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2004-01-08 04:29:46 +0000
committerGeorge Shapovalov <george@gentoo.org>2004-01-08 04:29:46 +0000
commitf7ee5506fc857aebade78d7b7297a9de4582325a (patch)
tree96396588192aca1e96034f806b4b0e86df31f575 /app-sci/octave
parentversion bump (diff)
downloadgentoo-2-f7ee5506fc857aebade78d7b7297a9de4582325a.tar.gz
gentoo-2-f7ee5506fc857aebade78d7b7297a9de4582325a.tar.bz2
gentoo-2-f7ee5506fc857aebade78d7b7297a9de4582325a.zip
new version. Added support for hdf5 and mpi
Diffstat (limited to 'app-sci/octave')
-rw-r--r--app-sci/octave/ChangeLog8
-rw-r--r--app-sci/octave/Manifest4
-rw-r--r--app-sci/octave/files/digest-octave-2.1.501
-rw-r--r--app-sci/octave/octave-2.1.50.ebuild75
4 files changed, 86 insertions, 2 deletions
diff --git a/app-sci/octave/ChangeLog b/app-sci/octave/ChangeLog
index 40e2099b935e..ce1cd34d208b 100644
--- a/app-sci/octave/ChangeLog
+++ b/app-sci/octave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-sci/octave
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.19 2003/12/30 17:09:38 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.20 2004/01/08 04:29:40 george Exp $
+
+*octave-2.1.50 (07 Jan 2003)
+
+ 07 Jan 2003; George Shapovalov <george@gentoo.org> octave-2.1.50.ebuild :
+ new version
+ now supports hdf5 for real. Also added mpi use flag.
31 Dec 2003; Mamoru KOMACHI <usata@gentoo.org> octave-2.0.17-r2.ebuild,
octave-2.1.36-r1.ebuild, octave-2.1.49.ebuild:
diff --git a/app-sci/octave/Manifest b/app-sci/octave/Manifest
index b3ca48ca6194..94a6501e4534 100644
--- a/app-sci/octave/Manifest
+++ b/app-sci/octave/Manifest
@@ -1,10 +1,12 @@
MD5 1af277267ad7f6a68d6181e97ec1bb41 octave-2.0.17-r2.ebuild 1161
MD5 8c6b365c27549aa7c0b2c45e7b0fe1e0 octave-2.1.49.ebuild 2002
+MD5 8dc2249d21acec5407f21ae280c241a9 octave-2.1.50.ebuild 2130
MD5 ef92dc3338a78b73df3a2e20acb2cc1f octave-2.1.36-r1.ebuild 1976
-MD5 0dee19c526aba13f1ce77db26b302fdd ChangeLog 3766
+MD5 3ccb13760c72d18c54f075e3757d9596 ChangeLog 3943
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 db65638ec0880bb6bd26be8f6fba1eee files/digest-octave-2.0.17-r2 67
MD5 c93a44a52d46ca6e8fed8c3c23877c0d files/digest-octave-2.1.36-r1 67
MD5 74d376b9c7367fe7b333cbc7e8ca37b3 files/kill-dvips.diff 2448
MD5 045463e5ebb1615d834a8145b27a765d files/filebuf.diff 1275
MD5 894577241eb83e229f66bd98c1fb8ef7 files/digest-octave-2.1.49 67
+MD5 806a54605ad877d62105b2f58819c92d files/digest-octave-2.1.50 67
diff --git a/app-sci/octave/files/digest-octave-2.1.50 b/app-sci/octave/files/digest-octave-2.1.50
new file mode 100644
index 000000000000..28007c673ad8
--- /dev/null
+++ b/app-sci/octave/files/digest-octave-2.1.50
@@ -0,0 +1 @@
+MD5 480d48cd99828fb403ceee53dd1cad2f octave-2.1.50.tar.bz2 3715690
diff --git a/app-sci/octave/octave-2.1.50.ebuild b/app-sci/octave/octave-2.1.50.ebuild
new file mode 100644
index 000000000000..09b1b54ac6cd
--- /dev/null
+++ b/app-sci/octave/octave-2.1.50.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.50.ebuild,v 1.1 2004/01/08 04:29:40 george Exp $
+
+inherit flag-o-matic
+
+IUSE="static readline zlib tetex hdf5 mpi"
+DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations"
+SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2"
+HOMEPAGE="http://www.octave.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~alpha ~sparc"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r3
+ >=media-gfx/gnuplot-3.7.1-r3
+ >=dev-libs/fftw-2.1.3
+ >=dev-util/gperf-2.7.2
+ zlib? ( sys-libs/zlib )
+ hdf5? ( dev-libs/hdf5 )
+ tetex? ( virtual/tetex ) "
+
+# NOTE: octave supports blas/lapack from intel but this is not open
+# source nor is it free (as in beer OR speech) Check out...
+# http://developer.intel.com/software/products/mkl/mkl52/index.htm for
+# more information
+
+src_compile() {
+
+ filter-flags -ffast-math
+
+ local myconf
+
+ use static || myconf="--disable-static --enable-shared --enable-dl"
+ use readline || myconf="${myconf} --disable-readline"
+ use hdf5 || myconf="${myconf} --without-hdf5"
+ use mpi || myconf="${myconf} --without-mpi"
+
+ # NOTE: This version actually works with gcc-3.x
+ ./configure ${myconf} --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/state/octave \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --build=${CHOST} \
+ --target=${CHOST} \
+ --enable-rpath \
+ --enable-lite-kernel \
+ LDFLAGS=-lz || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die "make install failed"
+ use tetex && octave-install-doc
+}
+
+octave-install-doc() {
+ echo "Installing documentation..."
+ insinto /usr/share/doc/${PF}
+ doins doc/faq/Octave-FAQ.dvi
+ doins doc/interpreter/octave.dvi
+ doins doc/liboctave/liboctave.dvi
+ doins doc/refcard/refcard-a4.dvi
+ doins doc/refcard/refcard-legal.dvi
+ doins doc/refcard/refcard-letter.dvi
+}