summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-05-04 02:38:01 +0000
committerJon Portnoy <avenj@gentoo.org>2003-05-04 02:38:01 +0000
commitd822d400a6f7ab25fbb8c822c7f03c064e17f70a (patch)
tree920cef78e423155085b6159340355852b09ecdbd /app-sci/ncbi-tools
parentInitial import (diff)
downloadgentoo-2-d822d400a6f7ab25fbb8c822c7f03c064e17f70a.tar.gz
gentoo-2-d822d400a6f7ab25fbb8c822c7f03c064e17f70a.tar.bz2
gentoo-2-d822d400a6f7ab25fbb8c822c7f03c064e17f70a.zip
Initial import
Diffstat (limited to 'app-sci/ncbi-tools')
-rw-r--r--app-sci/ncbi-tools/ChangeLog9
-rw-r--r--app-sci/ncbi-tools/Manifest3
-rw-r--r--app-sci/ncbi-tools/files/digest-ncbi-tools-042220032
-rw-r--r--app-sci/ncbi-tools/ncbi-tools-04222003.ebuild67
4 files changed, 80 insertions, 1 deletions
diff --git a/app-sci/ncbi-tools/ChangeLog b/app-sci/ncbi-tools/ChangeLog
new file mode 100644
index 000000000000..9f1730a38a8a
--- /dev/null
+++ b/app-sci/ncbi-tools/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-sci/ncbi-tools
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/ncbi-tools/ChangeLog,v 1.1 2003/05/04 02:37:49 avenj Exp $
+
+*ncbi-tools-04222003 (03 May 2003)
+
+ 03 May 2003; Jon Portnoy <avenj@gentoo.org> ncbi-tools-04222003 :
+ Initial important. Ebuild submitted by Steve Diener
+ <sediener@unity.ncsu.edu>.
diff --git a/app-sci/ncbi-tools/Manifest b/app-sci/ncbi-tools/Manifest
index 00863bb87e57..83ac199f0b65 100644
--- a/app-sci/ncbi-tools/Manifest
+++ b/app-sci/ncbi-tools/Manifest
@@ -1,2 +1,3 @@
-MD5 8835be9b59afdfee3068f5236906d4a9 ncbi-tools-04222003.ebuild 2064
+MD5 109833db222386d7b9090a7d74915452 ncbi-tools-04222003.ebuild 2171
+MD5 2f61656115e3b3cd2d8bd6d632b7616e ChangeLog 405
MD5 14127812e393e96ae78632a71f4a9f01 files/digest-ncbi-tools-04222003 114
diff --git a/app-sci/ncbi-tools/files/digest-ncbi-tools-04222003 b/app-sci/ncbi-tools/files/digest-ncbi-tools-04222003
new file mode 100644
index 000000000000..906826ee86d2
--- /dev/null
+++ b/app-sci/ncbi-tools/files/digest-ncbi-tools-04222003
@@ -0,0 +1,2 @@
+MD5 96208e10f92b2163f5dcc3c5cf74dd44 ncbi.tar.gz 10164179
+MD5 8db14fb4c337372c40140b5cff06b9b6 data.tar.gz 988677
diff --git a/app-sci/ncbi-tools/ncbi-tools-04222003.ebuild b/app-sci/ncbi-tools/ncbi-tools-04222003.ebuild
new file mode 100644
index 000000000000..621e1bdda703
--- /dev/null
+++ b/app-sci/ncbi-tools/ncbi-tools-04222003.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/ncbi-tools/ncbi-tools-04222003.ebuild,v 1.1 2003/05/04 02:37:49 avenj Exp $
+
+DESCRIPTION="NCBI toolkit including the BLAST group of programs, entrez, ddv, udv, sequin and others"
+HOMEPAGE="http://www.ncbi.nlm.nih.gov/"
+
+SRC_URI="ftp://ftp.ncbi.nih.gov/toolbox/ncbi_tools/CURRENT/ncbi.tar.gz ftp://ftp.ncbi.nih.gov/toolbox/ncbi_tools/CURRENT/data.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE="X"
+
+DEPEND="X? ( >=xfree-4.3.0
+ >=openmotif-2.2.2 )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ cd ${WORKDIR}
+ # NCBI provides their own compile script where they check for
+ # the existence of X (openmotif and opengl) libs and compile in support
+ # if they exist
+
+ # future ebuilds will allow for -X which will not compile any of the
+ # graphical tools. But for right now you get everything if you have
+ # X installed
+
+ ./ncbi/make/makedis.csh 2>&1 | tee out.makedis.txt
+
+}
+
+src_install() {
+
+ cd ${WORKDIR}/ncbi/bin
+ dobin Nentrez blastclust entrcmd getmesh megablast testobj Psequin blastpgp entrez2 getpub ncbisort testval asn2ff cdscan errhdr getseq netentcf udv asn2gb checksub fa2htgs gil2bin rpsblast vecscreen asn2xml copymat fastacmd idfetch seedtop asndhuff ddv findspl impala seqtest asntool demo_regexp fmerge indexpub tbl2asn blastall demo_regexp_grep formatdb makemat test_regexp blastcl3 dosimple getfeat makeset testcore
+
+
+ cd ${WORKDIR}
+ dodir /usr/var/ncbi
+ insinto /usr/var/ncbi
+ doins data/*
+
+ dodoc README README.htm VERSION checkout.date
+
+ cd ${WORKDIR}/ncbi/doc
+ dodoc *
+}
+
+pkg_postinst() {
+ einfo "--------------------------"
+ einfo "You must create a .ncbirc file "
+ einfo "for the majority of these programs"
+ einfo "to work right"
+ einfo " "
+ einfo "See README.bls for more information"
+ einfo "--------------------------"
+ einfo "The file should contain the two following lines:"
+ einfo "[NCBI]"
+ einfo "Data=/usr/var/ncbi"
+ einfo "--------------------------"
+ einfo " "
+ einfo "It should be placed in the user's home directory"
+}