summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-03-11 07:20:56 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-03-11 07:20:56 +0000
commitf73d668f0710139a218c0ef0e9556f91d52e1a7f (patch)
tree3e5be4a5cb0065b88d2afcbc238eb90b6ea8b789 /app-portage
parentreplaced dvd USE flag with dvdread for transcode-1.1 (diff)
downloadgentoo-2-f73d668f0710139a218c0ef0e9556f91d52e1a7f.tar.gz
gentoo-2-f73d668f0710139a218c0ef0e9556f91d52e1a7f.tar.bz2
gentoo-2-f73d668f0710139a218c0ef0e9556f91d52e1a7f.zip
Version bump with ebuild diff from upstream maintainer
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/portato/ChangeLog7
-rw-r--r--app-portage/portato/portato-0.12.1.ebuild114
2 files changed, 120 insertions, 1 deletions
diff --git a/app-portage/portato/ChangeLog b/app-portage/portato/ChangeLog
index b73ad45995b0..1082e4fa1471 100644
--- a/app-portage/portato/ChangeLog
+++ b/app-portage/portato/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/portato
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/portato/ChangeLog,v 1.15 2009/03/07 20:08:53 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portato/ChangeLog,v 1.16 2009/03/11 07:20:56 jokey Exp $
+
+*portato-0.12.1 (11 Mar 2009)
+
+ 11 Mar 2009; Markus Ullmann <jokey@gentoo.org> +portato-0.12.1.ebuild:
+ Version bump with ebuild diff from upstream maintainer
07 Mar 2009; Petteri Räty <betelgeuse@gentoo.org> portato-0.10.ebuild,
portato-0.11.1.ebuild:
diff --git a/app-portage/portato/portato-0.12.1.ebuild b/app-portage/portato/portato-0.12.1.ebuild
new file mode 100644
index 000000000000..c286c359bfe5
--- /dev/null
+++ b/app-portage/portato/portato-0.12.1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portato/portato-0.12.1.ebuild,v 1.1 2009/03/11 07:20:56 jokey Exp $
+
+EAPI="2"
+
+NEED_PYTHON="2.5"
+inherit python eutils distutils
+
+DESCRIPTION="A GUI for Portage written in Python."
+HOMEPAGE="http://portato.origo.ethz.ch/"
+SRC_URI="http://download.origo.ethz.ch/portato/1045/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="kde +libnotify nls userpriv sqlite"
+LANGS="ca de es_ES pl tr"
+for X in $LANGS; do IUSE="${IUSE} linguas_${X}"; done
+
+RDEPEND="app-portage/portage-utils
+ x11-libs/vte[python]
+ dev-lang/python:2.5[sqlite?,threads]
+ dev-python/pygtksourceview:2
+ >=dev-python/pygtk-2.14.0
+ >=sys-apps/portage-2.1.6
+
+ !userpriv? (
+ dev-python/shm
+ kde? ( || ( kde-base/kdesu kde-base/kdebase ) )
+ !kde? ( x11-libs/gksu ) )
+
+ libnotify? ( dev-python/notify-python )
+ nls? ( virtual/libintl )"
+
+# only needs gettext as build dependency
+# python should be set as DEPEND in the python-eclass
+DEPEND="nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${PN}"
+CONFIG_DIR="etc/${PN}"
+DATA_DIR="usr/share/${PN}"
+LOCALE_DIR="usr/share/locale"
+PLUGIN_DIR="${DATA_DIR}/plugins"
+ICON_DIR="${DATA_DIR}/icons"
+TEMPLATE_DIR="${DATA_DIR}/templates"
+
+src_configure ()
+{
+ local su="\"gksu -D 'Portato'\""
+ use kde && su="\"kdesu -t -d -i '%s' -c\" % APP_ICON"
+
+ sed -i -e "s;^\(VERSION\s*=\s*\).*;\1\"${PV}\";" \
+ -e "s;^\(CONFIG_DIR\s*=\s*\).*;\1\"${ROOT}${CONFIG_DIR}/\";" \
+ -e "s;^\(DATA_DIR\s*=\s*\).*;\1\"${ROOT}${DATA_DIR}/\";" \
+ -e "s;^\(TEMPLATE_DIR\s*=\s*\).*;\1\"${ROOT}${TEMPLATE_DIR}/\";" \
+ -e "s;^\(ICON_DIR\s*=\s*\).*;\1\"${ROOT}${ICON_DIR}/\";" \
+ -e "s;^\(LOCALE_DIR\s*=\s*\).*;\1\"${ROOT}${LOCALE_DIR}/\";" \
+ -e "s;^\(SU_COMMAND\s*=\s*\).*;\1$su;" \
+ "${PN}"/constants.py || die "sed failed"
+
+ if use userpriv; then
+ sed -i -e "s/Exec=.*/Exec=portato --no-fork/" portato.desktop || die "sed failed"
+ fi
+}
+
+src_compile ()
+{
+ if use nls; then
+ ./pocompile.sh -emerge ${LINGUAS} || die "pocompile failed"
+ fi
+
+ distutils_src_compile
+}
+
+src_install ()
+{
+ dodir ${DATA_DIR} || die
+
+ distutils_src_install
+
+ newbin portato.py portato || die
+ dodoc doc/*
+
+ # config
+ insinto ${CONFIG_DIR}
+ doins etc/* || die
+
+ # plugins
+ insinto ${PLUGIN_DIR}
+
+ # desktop
+ doicon icons/portato-icon.png || die
+ domenu portato.desktop || die
+
+ # nls
+ use nls && domo i18n/mo/*
+}
+
+pkg_postinst ()
+{
+ distutils_pkg_postinst
+ python_mod_optimize "/${PLUGIN_DIR}"
+}
+
+pkg_postrm ()
+{
+ distutils_pkg_postrm
+ python_mod_cleanup "/${PLUGIN_DIR}"
+
+ # try to remove the DATA_DIR, because it may still reside there, as it was tried
+ # to remove it before plugin stuff was purged
+ rmdir "${ROOT}"${DATA_DIR} 2> /dev/null
+}