summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-01-04 16:48:14 +0000
committerMichał Górny <mgorny@gentoo.org>2012-01-04 16:48:14 +0000
commitf36e9e43308f8110c779935831bb929b38dd1fe7 (patch)
treede7e69d1c71d4e8042c3d730ad351c5e0afe9981 /app-portage
parentMarking strace-4.6 ppc for bug 391655 (diff)
downloadgentoo-2-f36e9e43308f8110c779935831bb929b38dd1fe7.tar.gz
gentoo-2-f36e9e43308f8110c779935831bb929b38dd1fe7.tar.bz2
gentoo-2-f36e9e43308f8110c779935831bb929b38dd1fe7.zip
Version bump. The new version uses a private D-Bus session bus instead of relying on the system one.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/pms-test-suite/ChangeLog11
-rw-r--r--app-portage/pms-test-suite/metadata.xml2
-rw-r--r--app-portage/pms-test-suite/pms-test-suite-0.2.ebuild62
3 files changed, 72 insertions, 3 deletions
diff --git a/app-portage/pms-test-suite/ChangeLog b/app-portage/pms-test-suite/ChangeLog
index f6434bfd9cba..ada829972e09 100644
--- a/app-portage/pms-test-suite/ChangeLog
+++ b/app-portage/pms-test-suite/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/pms-test-suite
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/pms-test-suite/ChangeLog,v 1.7 2011/10/23 22:15:08 tetromino Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pms-test-suite/ChangeLog,v 1.8 2012/01/04 16:48:14 mgorny Exp $
+
+*pms-test-suite-0.2 (04 Jan 2012)
+
+ 04 Jan 2012; Michał Górny <mgorny@gentoo.org> +pms-test-suite-0.2.ebuild,
+ metadata.xml:
+ Version bump. The new version uses a private D-Bus session bus instead of
+ relying on the system one.
23 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
pms-test-suite-0.1.ebuild:
diff --git a/app-portage/pms-test-suite/metadata.xml b/app-portage/pms-test-suite/metadata.xml
index f77c818b7a00..f9ee48a1657f 100644
--- a/app-portage/pms-test-suite/metadata.xml
+++ b/app-portage/pms-test-suite/metadata.xml
@@ -10,6 +10,6 @@
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
- <bugs-to>http://bugs.gentoo.org/enter_bug.cgi?product=Gentoo%20Linux&amp;component=Applications&amp;short_desc=app-portage/pms-test-suite:%20</bugs-to>
+ <bugs-to>https://github.com/mgorny/pms-test-suite/issues/</bugs-to>
</upstream>
</pkgmetadata>
diff --git a/app-portage/pms-test-suite/pms-test-suite-0.2.ebuild b/app-portage/pms-test-suite/pms-test-suite-0.2.ebuild
new file mode 100644
index 000000000000..b39cfd3ec5c0
--- /dev/null
+++ b/app-portage/pms-test-suite/pms-test-suite-0.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pms-test-suite/pms-test-suite-0.2.ebuild,v 1.1 2012/01/04 16:48:14 mgorny Exp $
+
+EAPI=4
+
+PYTHON_DEPEND='2:2.6'
+# Python ABIs are not supported by pkgcore
+#SUPPORT_PYTHON_ABIS=1
+# Python3 is not supported by dbus & gobject
+RESTRICT_PYTHON_ABIS='2.4 2.5 3.*'
+DISTUTILS_SRC_TEST=setup.py
+
+inherit base distutils
+
+DESCRIPTION="A test suite for Package Manager PMS compliance"
+HOMEPAGE="http://www.gentoo.org/proj/en/qa/pms/pms-test-suite.xml"
+SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=app-portage/gentoopm-0.1.5
+ dev-python/dbus-python
+ dev-python/pygobject:2"
+DEPEND="doc? ( dev-python/epydoc )
+ test? ( >=sys-apps/portage-2.1.10.3
+ sys-apps/pkgcore
+ >=sys-apps/paludis-0.64.2[python-bindings] )"
+
+# broken atm
+RESTRICT=test
+
+PYTHON_MODNAME=pmstestsuite
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ base_src_prepare
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ "$(PYTHON)" setup.py "${_DISTUTILS_GLOBAL_OPTIONS[@]}" doc || die
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r doc/*
+ fi
+}