summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2008-05-02 04:34:56 +0000
committerPaul Varner <fuzzyray@gentoo.org>2008-05-02 04:34:56 +0000
commitd67f6684818cabae4ab9173c660827139ca221df (patch)
tree83f61c6b4f4d08a4060e81293070f7c65776963e /app-portage
parentAdd fix from upstream. (diff)
downloadgentoo-2-d67f6684818cabae4ab9173c660827139ca221df.tar.gz
gentoo-2-d67f6684818cabae4ab9173c660827139ca221df.tar.bz2
gentoo-2-d67f6684818cabae4ab9173c660827139ca221df.zip
Fix pocompile.sh to use /bin/bash. Add die statement in case it fails.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/porthole/ChangeLog8
-rw-r--r--app-portage/porthole/files/porthole-0.6.0_rc2-pocompile.patch9
-rw-r--r--app-portage/porthole/porthole-0.6.0_rc2.ebuild13
3 files changed, 26 insertions, 4 deletions
diff --git a/app-portage/porthole/ChangeLog b/app-portage/porthole/ChangeLog
index 7b12a75a0b95..fb9833390f5c 100644
--- a/app-portage/porthole/ChangeLog
+++ b/app-portage/porthole/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/porthole
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/ChangeLog,v 1.30 2008/05/01 20:19:41 fuzzyray Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/ChangeLog,v 1.31 2008/05/02 04:34:55 fuzzyray Exp $
+
+ 02 May 2008; Paul Varner <fuzzyray@gentoo.org>
+ +files/porthole-0.6.0_rc2-pocompile.patch, porthole-0.6.0_rc2.ebuild:
+ Add die statement to pocompile.sh, in case it fails. Added patch to change
+ the shebang line from /bin/sh to /bin/bash for pocompile.sh, since it was
+ not a POSIX compliant shell script.
*porthole-0.6.0_rc2 (01 May 2008)
diff --git a/app-portage/porthole/files/porthole-0.6.0_rc2-pocompile.patch b/app-portage/porthole/files/porthole-0.6.0_rc2-pocompile.patch
new file mode 100644
index 000000000000..954a68110fa2
--- /dev/null
+++ b/app-portage/porthole/files/porthole-0.6.0_rc2-pocompile.patch
@@ -0,0 +1,9 @@
+diff -u -r porthole-0.6.0_rc2.orig/scripts/pocompile.sh porthole-0.6.0_rc2/scripts/pocompile.sh
+--- porthole-0.6.0_rc2.orig/scripts/pocompile.sh 2008-04-20 16:11:47.000000000 -0500
++++ porthole-0.6.0_rc2/scripts/pocompile.sh 2008-05-01 23:15:50.000000000 -0500
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/bin/bash
+ # Helper script to compile all .po files in the i18n directroy into .mo files.
+ # Requires sys-devel/gettext.
+ #
diff --git a/app-portage/porthole/porthole-0.6.0_rc2.ebuild b/app-portage/porthole/porthole-0.6.0_rc2.ebuild
index 743a3d4804fd..770b27cc1a41 100644
--- a/app-portage/porthole/porthole-0.6.0_rc2.ebuild
+++ b/app-portage/porthole/porthole-0.6.0_rc2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/porthole-0.6.0_rc2.ebuild,v 1.1 2008/05/01 20:19:41 fuzzyray Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/porthole/porthole-0.6.0_rc2.ebuild,v 1.2 2008/05/02 04:34:55 fuzzyray Exp $
-inherit distutils
+inherit eutils distutils
DESCRIPTION="A GTK+-based frontend to Portage"
HOMEPAGE="http://porthole.sourceforge.net"
@@ -23,6 +23,13 @@ RDEPEND=">=dev-lang/python-2.3
DEPEND="${RDEPEND}
nls? ( >=sys-devel/gettext-0.14 )"
+src_unpack() {
+ # Change shebang line to /bin/bash since pocompile.sh is not a posix script
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PF}-pocompile.patch
+}
+
src_install() {
distutils_src_install
chmod -R a+rX "${D}"/usr/share/porthole
@@ -34,7 +41,7 @@ src_install() {
# Compile localizations if necessary
if use nls ; then
cd "${D}"/usr/share/porthole
- ./pocompile.sh
+ ./pocompile.sh || die "pocompile.sh failed"
fi
}