summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2010-04-08 22:34:30 +0000
committerPaul Varner <fuzzyray@gentoo.org>2010-04-08 22:34:30 +0000
commitcba0faa81cbb5da2b40199fbf02548e526ac8ab1 (patch)
tree9eb4e1e61b0b8d2872bbbb43ce79294fc46f97ed /app-portage
parentinitial commit - ebuild and patch submitted by Locke 'Wizzleby' Shinseiko via... (diff)
downloadgentoo-2-cba0faa81cbb5da2b40199fbf02548e526ac8ab1.tar.gz
gentoo-2-cba0faa81cbb5da2b40199fbf02548e526ac8ab1.tar.bz2
gentoo-2-cba0faa81cbb5da2b40199fbf02548e526ac8ab1.zip
Revision bump to fix regression in eclean where metadata.dtd gets removed (Bug 313901).
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoolkit/ChangeLog9
-rw-r--r--app-portage/gentoolkit/files/eclean.313901.patch40
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.3.0_rc10-r1.ebuild67
3 files changed, 115 insertions, 1 deletions
diff --git a/app-portage/gentoolkit/ChangeLog b/app-portage/gentoolkit/ChangeLog
index caad6a600434..95fdbed689e8 100644
--- a/app-portage/gentoolkit/ChangeLog
+++ b/app-portage/gentoolkit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/gentoolkit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.187 2010/04/05 21:04:18 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.188 2010/04/08 22:34:30 fuzzyray Exp $
+
+*gentoolkit-0.3.0_rc10-r1 (08 Apr 2010)
+
+ 08 Apr 2010; Paul Varner <fuzzyray@gentoo.org>
+ +gentoolkit-0.3.0_rc10-r1.ebuild, +files/eclean.313901.patch:
+ Revision bump to fix regression in eclean where metadata.dtd gets removed
+ (Bug 313901).
*gentoolkit-0.3.0_rc10 (05 Apr 2010)
diff --git a/app-portage/gentoolkit/files/eclean.313901.patch b/app-portage/gentoolkit/files/eclean.313901.patch
new file mode 100644
index 000000000000..2f83bc85e3a8
--- /dev/null
+++ b/app-portage/gentoolkit/files/eclean.313901.patch
@@ -0,0 +1,40 @@
+Index: pym/gentoolkit/eclean/exclude.py
+===================================================================
+--- pym/gentoolkit/eclean/exclude.py (revision 766)
++++ pym/gentoolkit/eclean/exclude.py (working copy)
+@@ -223,6 +223,7 @@
+ pkgname = cp.split('/')[1]
+ p.add(pkgname)
+ if 'packages' in exclude:
++ for cp in exclude['packages']:
+ pkgname = cp.split('/')[1]
+ p.add(pkgname)
+ if 'anti-packages' in exclude:
+Index: pym/gentoolkit/eclean/cli.py
+===================================================================
+--- pym/gentoolkit/eclean/cli.py (revision 766)
++++ pym/gentoolkit/eclean/cli.py (working copy)
+@@ -463,6 +463,11 @@
+ if options['verbose']:
+ options['verbose-output'] = output.einfo
+ # parse the exclusion file
++ if not 'exclude-file' in options:
++ # set it to the default exclude file if it exists
++ exclude_file = "/etc/%s/%s.exclude" % (__productname__ , action)
++ if os.path.isfile(exclude_file):
++ options['exclude-file'] = exclude_file
+ if 'exclude-file' in options:
+ try:
+ exclude = parseExcludeFile(options['exclude-file'],
+@@ -475,10 +480,7 @@
+ "See format of this file in `man %s`" % __productname__), file=sys.stderr)
+ sys.exit(1)
+ else:
+- exclude_file = "/etc/%s/%s.exclude" % (__productname__ , action)
+- if os.path.isfile(exclude_file):
+- options['exclude-file'] = exclude_file
+- exclude={}
++ exclude = {}
+ # security check for non-pretend mode
+ if not options['pretend'] and portage.secpass == 0:
+ print( pp.error(
diff --git a/app-portage/gentoolkit/gentoolkit-0.3.0_rc10-r1.ebuild b/app-portage/gentoolkit/gentoolkit-0.3.0_rc10-r1.ebuild
new file mode 100644
index 000000000000..7ec67be3c9ed
--- /dev/null
+++ b/app-portage/gentoolkit/gentoolkit-0.3.0_rc10-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/gentoolkit-0.3.0_rc10-r1.ebuild,v 1.1 2010/04/08 22:34:30 fuzzyray Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_DISABLE_VERSIONING_OF_PYTHON_SCRIPTS="1"
+RESTRICT_PYTHON_ABIS="2.[45]"
+
+inherit distutils python eutils
+
+DESCRIPTION="Collection of administration scripts for Gentoo"
+HOMEPAGE="http://www.gentoo.org/proj/en/portage/tools/index.xml"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# Drop ~sparc-fbsd ~x86-fbsd due to app-misc/realpath dependency
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DEPEND="sys-apps/portage
+ >=dev-lang/python-2.6[xml]
+ !!>=dev-lang/python-2.6[-xml]"
+RDEPEND="${DEPEND}
+ app-misc/realpath
+ sys-apps/gawk
+ sys-apps/grep"
+
+src_prepare() {
+ epatch "${FILESDIR}/eclean.313901.patch"
+}
+
+distutils_src_compile_pre_hook() {
+ echo VERSION="${PVR}" "$(PYTHON)" setup.py set_version
+ VERSION="${PVR}" "$(PYTHON)" setup.py set_version
+}
+
+src_install() {
+ python_convert_shebangs -r "" build-*/scripts-*
+ distutils_src_install
+
+ # Create cache directory for revdep-rebuild
+ dodir /var/cache/revdep-rebuild
+ keepdir /var/cache/revdep-rebuild
+ fowners root:root /var/cache/revdep-rebuild
+ fperms 0700 /var/cache/revdep-rebuild
+
+ # Can distutils handle this?
+ dosym eclean /usr/bin/eclean-dist
+ dosym eclean /usr/bin/eclean-pkg
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ # Make sure that our ownership and permissions stuck
+ chown root:root "${ROOT}/var/cache/revdep-rebuild"
+ chmod 0700 "${ROOT}/var/cache/revdep-rebuild"
+
+ einfo
+ einfo "For further information on gentoolkit, please read the gentoolkit"
+ einfo "guide: http://www.gentoo.org/doc/en/gentoolkit.xml"
+ einfo
+ einfo "Another alternative to equery is app-portage/portage-utils"
+}