summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2011-12-19 20:51:38 +0000
committerPaul Varner <fuzzyray@gentoo.org>2011-12-19 20:51:38 +0000
commitbd37e7f3b492221ad208f84d66cd40465a1a678d (patch)
tree33e0a128cbb0ceb6f429d20b3a3420b82b39d707 /app-portage
parentStable for AMD64, wrt bug #395289 (diff)
downloadgentoo-2-bd37e7f3b492221ad208f84d66cd40465a1a678d.tar.gz
gentoo-2-bd37e7f3b492221ad208f84d66cd40465a1a678d.tar.bz2
gentoo-2-bd37e7f3b492221ad208f84d66cd40465a1a678d.zip
Fix setup.py to work with EPREFIX changes in Portage.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/esearch/ChangeLog9
-rw-r--r--app-portage/esearch/esearch-1.0-r2.ebuild (renamed from app-portage/esearch/esearch-1.0-r1.ebuild)5
-rw-r--r--app-portage/esearch/esearch-1.0.ebuild54
-rw-r--r--app-portage/esearch/files/1.0-fix-portage-eprefix-compatibility.patch38
4 files changed, 49 insertions, 57 deletions
diff --git a/app-portage/esearch/ChangeLog b/app-portage/esearch/ChangeLog
index 9abf9aebeb64..b6476ef5449d 100644
--- a/app-portage/esearch/ChangeLog
+++ b/app-portage/esearch/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/esearch
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/esearch/ChangeLog,v 1.75 2011/12/16 22:09:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/esearch/ChangeLog,v 1.76 2011/12/19 20:51:38 fuzzyray Exp $
+
+*esearch-1.0-r2 (19 Dec 2011)
+
+ 19 Dec 2011; Paul Varner <fuzzyray@gentoo.org>
+ +files/1.0-fix-portage-eprefix-compatibility.patch, -esearch-1.0.ebuild,
+ -esearch-1.0-r1.ebuild, +esearch-1.0-r2.ebuild:
+ Fix setup.py to work with EPREFIX changes in Portage.
16 Dec 2011; Agostino Sarubbo <ago@gentoo.org> esearch-0.7.2-r2.ebuild:
Stable for AMD64, wrt bug #394999
diff --git a/app-portage/esearch/esearch-1.0-r1.ebuild b/app-portage/esearch/esearch-1.0-r2.ebuild
index 4bd018d522cd..d966975e7a05 100644
--- a/app-portage/esearch/esearch-1.0-r1.ebuild
+++ b/app-portage/esearch/esearch-1.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/esearch/esearch-1.0-r1.ebuild,v 1.1 2011/12/12 18:44:28 fuzzyray Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/esearch/esearch-1.0-r2.ebuild,v 1.1 2011/12/19 20:51:38 fuzzyray Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
@@ -23,7 +23,8 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
DEPEND="sys-apps/portage"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}"/${PV}-fix-EPREFIX-capability.patch )
+PATCHES=("${FILESDIR}"/${PV}-fix-EPREFIX-capability.patch
+ "${FILESDIR}"/${PV}-fix-portage-eprefix-compatibility.patch )
distutils_src_compile_pre_hook() {
echo VERSION="${PVR}" "$(PYTHON)" setup.py set_version
diff --git a/app-portage/esearch/esearch-1.0.ebuild b/app-portage/esearch/esearch-1.0.ebuild
deleted file mode 100644
index 9fc7100afe11..000000000000
--- a/app-portage/esearch/esearch-1.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/esearch/esearch-1.0.ebuild,v 1.1 2011/11/30 21:03:33 fuzzyray Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.[45]"
-PYTHON_USE_WITH="readline"
-PYTHON_NONVERSIONED_EXECUTABLES=(".*")
-
-inherit distutils python
-
-DESCRIPTION="Replacement for 'emerge --search' with search-index"
-HOMEPAGE="http://david-peter.de/esearch.html"
-SRC_URI="mirror://github/fuzzyray/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="linguas_fr linguas_it"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
-
-DEPEND="sys-apps/portage"
-RDEPEND="${DEPEND}"
-
-distutils_src_compile_pre_hook() {
- echo VERSION="${PVR}" "$(PYTHON)" setup.py set_version
- VERSION="${PVR}" "$(PYTHON)" setup.py set_version \
- || die "setup.py set_version failed"
-}
-
-src_compile() {
- distutils_src_compile
-}
-
-src_install() {
- python_convert_shebangs -r "" build-*/scripts-*
- distutils_src_install
- dodoc eupdatedb.cron || die "dodoc failed"
-
- # Remove unused man pages according to the linguas flags
- if ! use linguas_fr ; then
- rm -rf "${ED}"/usr/share/man/fr
- fi
-
- if ! use linguas_it ; then
- rm -rf "${ED}"/usr/share/man/it
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- ewarn "Because file locations have changed, please run 'hash -r' in your active shells."
-}
diff --git a/app-portage/esearch/files/1.0-fix-portage-eprefix-compatibility.patch b/app-portage/esearch/files/1.0-fix-portage-eprefix-compatibility.patch
new file mode 100644
index 000000000000..a4f9b1ba06ff
--- /dev/null
+++ b/app-portage/esearch/files/1.0-fix-portage-eprefix-compatibility.patch
@@ -0,0 +1,38 @@
+From a160eedd0b176cfa3da755762a8e40a38b753114 Mon Sep 17 00:00:00 2001
+From: Paul Varner <fuzzyray@gentoo.org>
+Date: Mon, 19 Dec 2011 13:09:42 -0600
+Subject: [PATCH] Fix setup.py to work with EPREFIX changes in Portage.
+
+---
+ setup.py | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 2990e33..b24cd8f 100755
+--- a/setup.py
++++ b/setup.py
+@@ -22,7 +22,7 @@ cwd = os.getcwd()
+ try:
+ from portage.const import EPREFIX
+ except ImportError:
+- EPREFIX='/'
++ EPREFIX=''
+
+ # Python files that need `__version__ = ""` subbed, relative to this dir:
+ python_scripts = [os.path.join(cwd, path) for path in (
+@@ -80,9 +80,9 @@ core.setup(
+ packages=packages,
+ scripts=(glob('bin/*')),
+ data_files=(
+- (os.path.join(EPREFIX, 'usr/share/man/man1'), glob('man/en/*')),
+- (os.path.join(EPREFIX, 'usr/share/man/fr/man1'), glob('man/fr/*')),
+- (os.path.join(EPREFIX, 'usr/share/man/it/man1'), glob('man/it/*')),
++ (os.path.join(os.sep, EPREFIX.lstrip(os.sep), 'usr/share/man/man1'), glob('man/en/*')),
++ (os.path.join(os.sep, EPREFIX.lstrip(os.sep), 'usr/share/man/fr/man1'), glob('man/fr/*')),
++ (os.path.join(os.sep, EPREFIX.lstrip(os.sep), 'usr/share/man/it/man1'), glob('man/it/*')),
+ ),
+ cmdclass={
+ 'set_version': set_version,
+--
+1.7.8
+