summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2011-11-30 21:03:33 +0000
committerPaul Varner <fuzzyray@gentoo.org>2011-11-30 21:03:33 +0000
commitb49077881143399cb149150b666a8e1234745aa3 (patch)
tree074ed35ce9d3c28ca5f1aa981237a2bb060bd29a /app-portage
parentGDM3 looks for .desktop files for the list of possible sessions, whereas GDM2... (diff)
downloadgentoo-2-b49077881143399cb149150b666a8e1234745aa3.tar.gz
gentoo-2-b49077881143399cb149150b666a8e1234745aa3.tar.bz2
gentoo-2-b49077881143399cb149150b666a8e1234745aa3.zip
Version bump to 1.0. Upstream package converted to use distutils and python
packaging. This version also works with Python 3. (Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/esearch/ChangeLog8
-rw-r--r--app-portage/esearch/esearch-1.0.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/app-portage/esearch/ChangeLog b/app-portage/esearch/ChangeLog
index e5ba2c6ce73b..10c596103e6e 100644
--- a/app-portage/esearch/ChangeLog
+++ b/app-portage/esearch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/esearch
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/esearch/ChangeLog,v 1.72 2011/11/24 20:36:42 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/esearch/ChangeLog,v 1.73 2011/11/30 21:03:32 fuzzyray Exp $
+
+*esearch-1.0 (30 Nov 2011)
+
+ 30 Nov 2011; Paul Varner <fuzzyray@gentoo.org> +esearch-1.0.ebuild:
+ Version bump to 1.0. Upstream package converted to use distutils and python
+ packaging. This version also works with Python 3.
24 Nov 2011; Zac Medico <zmedico@gentoo.org> esearch-0.7.2-r2.ebuild:
Use relative symlinks, and ED insead of D.
diff --git a/app-portage/esearch/esearch-1.0.ebuild b/app-portage/esearch/esearch-1.0.ebuild
new file mode 100644
index 000000000000..9fc7100afe11
--- /dev/null
+++ b/app-portage/esearch/esearch-1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/esearch/esearch-1.0.ebuild,v 1.1 2011/11/30 21:03:33 fuzzyray Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45]"
+PYTHON_USE_WITH="readline"
+PYTHON_NONVERSIONED_EXECUTABLES=(".*")
+
+inherit distutils python
+
+DESCRIPTION="Replacement for 'emerge --search' with search-index"
+HOMEPAGE="http://david-peter.de/esearch.html"
+SRC_URI="mirror://github/fuzzyray/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="linguas_fr linguas_it"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+
+DEPEND="sys-apps/portage"
+RDEPEND="${DEPEND}"
+
+distutils_src_compile_pre_hook() {
+ echo VERSION="${PVR}" "$(PYTHON)" setup.py set_version
+ VERSION="${PVR}" "$(PYTHON)" setup.py set_version \
+ || die "setup.py set_version failed"
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ python_convert_shebangs -r "" build-*/scripts-*
+ distutils_src_install
+ dodoc eupdatedb.cron || die "dodoc failed"
+
+ # Remove unused man pages according to the linguas flags
+ if ! use linguas_fr ; then
+ rm -rf "${ED}"/usr/share/man/fr
+ fi
+
+ if ! use linguas_it ; then
+ rm -rf "${ED}"/usr/share/man/it
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ ewarn "Because file locations have changed, please run 'hash -r' in your active shells."
+}