summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2011-07-28 02:55:53 +0000
committerPaul Varner <fuzzyray@gentoo.org>2011-07-28 02:55:53 +0000
commitb36bf3019feae4d4bbe27851c8c30aaca9a84d1c (patch)
tree492e370531a133740aee6caa1f9b4267524842ec /app-portage
parentBump to EAPI 3 and fix for prefix. (diff)
downloadgentoo-2-b36bf3019feae4d4bbe27851c8c30aaca9a84d1c.tar.gz
gentoo-2-b36bf3019feae4d4bbe27851c8c30aaca9a84d1c.tar.bz2
gentoo-2-b36bf3019feae4d4bbe27851c8c30aaca9a84d1c.zip
Revison bump to fix missing parenthises in euse. Bug 376393
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoolkit/ChangeLog8
-rw-r--r--app-portage/gentoolkit/files/0.3.0.4-euse.patch21
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.3.0.4-r1.ebuild81
3 files changed, 109 insertions, 1 deletions
diff --git a/app-portage/gentoolkit/ChangeLog b/app-portage/gentoolkit/ChangeLog
index 37331dc7c98f..f8e8bccbe259 100644
--- a/app-portage/gentoolkit/ChangeLog
+++ b/app-portage/gentoolkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/gentoolkit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.227 2011/07/18 21:58:26 fuzzyray Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.228 2011/07/28 02:55:53 fuzzyray Exp $
+
+*gentoolkit-0.3.0.4-r1 (28 Jul 2011)
+
+ 28 Jul 2011; Paul Varner <fuzzyray@gentoo.org> +files/0.3.0.4-euse.patch,
+ +gentoolkit-0.3.0.4-r1.ebuild:
+ Revison bump to fix missing parenthises in euse. Bug 376393
18 Jul 2011; Paul Varner <fuzzyray@gentoo.org>
-gentoolkit-0.3.0_rc10-r1.ebuild, -gentoolkit-0.3.0_rc11-r3.ebuild,
diff --git a/app-portage/gentoolkit/files/0.3.0.4-euse.patch b/app-portage/gentoolkit/files/0.3.0.4-euse.patch
new file mode 100644
index 000000000000..17dc804c8fed
--- /dev/null
+++ b/app-portage/gentoolkit/files/0.3.0.4-euse.patch
@@ -0,0 +1,21 @@
+From: Paul Varner <fuzzyray@gentoo.org>
+Date: Wed, 27 Jul 2011 19:01:34 +0000 (-0500)
+Subject: Fix missing parenthises in euse. Bug 376393
+X-Git-Url: http://git.overlays.gentoo.org/gitweb/?p=proj%2Fgentoolkit.git;a=commitdiff_plain;h=9ad547e5f33fce1dfb378809252d871265a82c58;hp=af81292035e8d3559b11ab16fc54ccd921cb3587
+
+Fix missing parenthises in euse. Bug 376393
+---
+
+diff --git a/bin/euse b/bin/euse
+index 65fb119..be47cc9 100755
+--- a/bin/euse
++++ b/bin/euse
+@@ -508,7 +508,7 @@ get_flagstatus_helper_pkg() {
+ atoms=($(
+ echo "${atoms[@]}" | python -c "
+ from __future__ import print_function;import portage.dep as dep, sys
+-print(' '.join(dep.match_to_list('$5-$6',sys.stdin.read().split()))"))
++print(' '.join(dep.match_to_list('$5-$6',sys.stdin.read().split())))"))
+ fi
+ flags=$(for atom in ${atoms[@]}; do
+ [[ -z $atom ]] && continue
diff --git a/app-portage/gentoolkit/gentoolkit-0.3.0.4-r1.ebuild b/app-portage/gentoolkit/gentoolkit-0.3.0.4-r1.ebuild
new file mode 100644
index 000000000000..7f5c8c57337b
--- /dev/null
+++ b/app-portage/gentoolkit/gentoolkit-0.3.0.4-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/gentoolkit-0.3.0.4-r1.ebuild,v 1.1 2011/07/28 02:55:53 fuzzyray Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45]"
+PYTHON_USE_WITH="xml"
+PYTHON_NONVERSIONED_EXECUTABLES=(".*")
+
+inherit distutils python eutils
+
+DESCRIPTION="Collection of administration scripts for Gentoo"
+HOMEPAGE="http://www.gentoo.org/proj/en/portage/tools/index.xml"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# Drop "~m68k ~s390 ~sh ~sparc-fbsd ~x86-fbsd" due to dev-python/argparse dependency
+# Note: argparse is provided in python 2.7 and 3.2 (Bug 346005)
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x64-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="sys-apps/portage"
+RDEPEND="${DEPEND}
+ !<=app-portage/gentoolkit-dev-0.2.7
+ dev-python/argparse
+ || ( app-misc/realpath sys-freebsd/freebsd-bin )
+ sys-apps/gawk
+ sys-apps/grep"
+
+distutils_src_compile_pre_hook() {
+ echo VERSION="${PVR}" "$(PYTHON)" setup.py set_version
+ VERSION="${PVR}" "$(PYTHON)" setup.py set_version \
+ || die "setup.py set_version failed"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-euse.patch"
+}
+
+src_install() {
+ python_convert_shebangs -r "" build-*/scripts-*
+ distutils_src_install
+
+ # Create cache directory for revdep-rebuild
+ dodir /var/cache/revdep-rebuild
+ keepdir /var/cache/revdep-rebuild
+ use prefix || fowners root:root /var/cache/revdep-rebuild
+ fperms 0700 /var/cache/revdep-rebuild
+
+ # remove on Gentoo Prefix platforms where it's broken anyway
+ if use prefix; then
+ elog "The revdep-rebuild command is removed, the preserve-libs"
+ elog "feature of portage will handle issues."
+ rm "${ED}"/usr/bin/revdep-rebuild
+ rm "${ED}"/usr/share/man/man1/revdep-rebuild.1
+ rm -rf "${ED}"/etc/revdep-rebuild
+ rm -rf "${ED}"/var
+ fi
+
+ # Can distutils handle this?
+ dosym eclean /usr/bin/eclean-dist
+ dosym eclean /usr/bin/eclean-pkg
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ einfo
+ einfo "For further information on gentoolkit, please read the gentoolkit"
+ einfo "guide: http://www.gentoo.org/doc/en/gentoolkit.xml"
+ einfo
+ einfo "Another alternative to equery is app-portage/portage-utils"
+ ewarn
+ ewarn "glsa-check since gentoolkit 0.3 has modified some output,"
+ ewarn "options and default behavior. The list of injected GLSAs"
+ ewarn "has moved to /var/lib/portage/glsa_injected, please"
+ ewarn "run 'glsa-check -p affected' before copying the existing checkfile."
+}