summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2010-03-16 17:04:56 +0000
committerDaniel Pielmeier <billie@gentoo.org>2010-03-16 17:04:56 +0000
commitacab53b82499b0b5d415f9b34664246552c467a5 (patch)
treef14aaac0a666befc771d0c00d249b11a8243d050 /app-portage
parentmake mycmakeargs an array (diff)
downloadgentoo-2-acab53b82499b0b5d415f9b34664246552c467a5.tar.gz
gentoo-2-acab53b82499b0b5d415f9b34664246552c467a5.tar.bz2
gentoo-2-acab53b82499b0b5d415f9b34664246552c467a5.zip
Revision bump to make use of the new python eclass functions.
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/pfl/ChangeLog7
-rw-r--r--app-portage/pfl/pfl-1.8.1-r1.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/app-portage/pfl/ChangeLog b/app-portage/pfl/ChangeLog
index 155223864594..fd993d4de77b 100644
--- a/app-portage/pfl/ChangeLog
+++ b/app-portage/pfl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/pfl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/ChangeLog,v 1.3 2010/01/21 17:22:15 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/ChangeLog,v 1.4 2010/03/16 17:04:56 billie Exp $
+
+*pfl-1.8.1-r1 (16 Mar 2010)
+
+ 16 Mar 2010; Daniel Pielmeier <billie@gentoo.org> +pfl-1.8.1-r1.ebuild:
+ Revision bump to make use of the new python eclass functions.
21 Jan 2010; Christian Faulhammer <fauli@gentoo.org> pfl-1.8.1.ebuild:
stable x86, bug 301660
diff --git a/app-portage/pfl/pfl-1.8.1-r1.ebuild b/app-portage/pfl/pfl-1.8.1-r1.ebuild
new file mode 100644
index 000000000000..2efdbf5177aa
--- /dev/null
+++ b/app-portage/pfl/pfl-1.8.1-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/pfl-1.8.1-r1.ebuild,v 1.1 2010/03/16 17:04:56 billie Exp $
+
+PYTHON_DEPEND=2
+
+inherit python multilib
+
+DESCRIPTION="PFL is an online searchable file/package database for Gentoo"
+HOMEPAGE="http://www.portagefilelist.de/index.php/Special:PFLQuery2"
+SRC_URI="http://files.portagefilelist.de/${P}
+ http://files.portagefilelist.de/e-file"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="network-cron"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ net-misc/curl
+ sys-apps/portage"
+
+RESTRICT="mirror"
+
+src_unpack() {
+ cp "${DISTDIR}/${P}" "${WORKDIR}/${PN}.py"
+ cp "${DISTDIR}/e-file" "${WORKDIR}/e-file"
+}
+
+src_install() {
+ if use network-cron ; then
+ cat >> "${T}/${PN}" <<- EOF
+ #!/bin/sh
+ exec nice $(PYTHON) -O $(python_get_sitedir)/${PN}/${PN}.py >/dev/null
+ EOF
+
+ exeinto /etc/cron.weekly
+ doexe "${T}/${PN}" || die "install ${PN} cron file failed"
+ fi
+
+ exeinto $(python_get_sitedir)/${PN}
+ doexe ${PN}.py || die "install ${PN}.py failed"
+
+ dobin e-file || die "install e-file failed"
+
+ dodir /var/lib/${PN} || die "directory creation failed"
+ fowners 0:portage /var/lib/${PN}
+ fperms 0775 /var/lib/${PN}
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/${PN}
+
+ if [[ ! -e "${ROOT%/}/var/lib/${PN}/lastrun" ]]; then
+ echo -n 0 > "${ROOT%/}/var/lib/${PN}/lastrun"
+ chown -R 0:portage "${ROOT%/}/var/lib/${PN}"
+ chmod -R 775 "${ROOT%/}/var/lib/${PN}"
+ fi
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}