summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-08-02 09:01:16 +0000
committerSebastian Pipping <sping@gentoo.org>2011-08-02 09:01:16 +0000
commit99e4ff080b69c7526a8dc6c3e6a42ff6473861b4 (patch)
tree041113e1822d7aa2aab8930ff0f34b93aa392f74 /app-portage
parentAdd mfs CGI server init script. drop old. (diff)
downloadgentoo-2-99e4ff080b69c7526a8dc6c3e6a42ff6473861b4.tar.gz
gentoo-2-99e4ff080b69c7526a8dc6c3e6a42ff6473861b4.tar.bz2
gentoo-2-99e4ff080b69c7526a8dc6c3e6a42ff6473861b4.zip
app-portage/eix: Bump to 0.22.10
(Portage version: 2.1.10.9/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog8
-rw-r--r--app-portage/eix/eix-0.22.10.ebuild38
-rw-r--r--app-portage/eix/metadata.xml1
3 files changed, 45 insertions, 2 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index 1a3c563520a1..13384536a2ce 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.367 2011/07/05 14:30:15 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.368 2011/08/02 09:01:16 sping Exp $
+
+*eix-0.22.10 (02 Aug 2011)
+
+ 02 Aug 2011; Sebastian Pipping <sping@gentoo.org> +eix-0.22.10.ebuild,
+ metadata.xml:
+ Bump to 0.22.10, remove use flag "deprecated" from metadata.xml
*eix-0.22.9 (05 Jul 2011)
diff --git a/app-portage/eix/eix-0.22.10.ebuild b/app-portage/eix/eix-0.22.10.ebuild
new file mode 100644
index 000000000000..4b5570181749
--- /dev/null
+++ b/app-portage/eix/eix-0.22.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.22.10.ebuild,v 1.1 2011/08/02 09:01:16 sping Exp $
+
+EAPI="4"
+
+inherit multilib
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
+HOMEPAGE="http://eix.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="bzip2 debug doc hardened nls optimization strong-optimization sqlite tools zsh-completion"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )
+ bzip2? ( app-arch/bzip2 )
+ zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf $(use_with bzip2) $(use_with sqlite) $(use_with doc extra-doc) \
+ $(use_with zsh-completion) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
+ $(use_enable hardened security) $(use_enable optimization) \
+ $(use_enable strong-optimization) $(use_enable debug debugging) \
+ $(use_with prefix always-accept-keywords) \
+ --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
+ --with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+}
diff --git a/app-portage/eix/metadata.xml b/app-portage/eix/metadata.xml
index 408fcb30a3be..162893a2257d 100644
--- a/app-portage/eix/metadata.xml
+++ b/app-portage/eix/metadata.xml
@@ -15,7 +15,6 @@
<use>
<flag name="bzip2">Support for parsing of environment.bz2 to guess repository name of packages installed with ancient portage versions (requires <pkg>app-arch/bzip2</pkg>). This flag is safe to disable for portage users that have re-merged all packages since 2007. This flag will be phased out.</flag>
<flag name="debug">Build with CXXFLAGS/LDFLAGS for debugging support; not recommended for normal use.</flag>
- <flag name="deprecated">Installs wrapper scripts for all the previous executable names that will soon be going away. Enabled by default in 0.17.0, optional in 0.18.0, removed in next major release.</flag>
<flag name="doc">Create description of the eix cache file additionally in html format</flag>
<flag name="hardened">Add CXXFLAGS/LDFLAGS enhancing security at the cost of a slight speed loss. If a hardened gcc is used, these flags should not make a difference.</flag>
<flag name="nls">Support foreign language messages (experimental; currently only de)</flag>