summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-03-28 14:11:30 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-03-28 14:11:30 +0000
commit96813ad553eaafb0f5b66d6b4e2c7d6b86604ab2 (patch)
tree5fb02756206b28479c8aff225569a4aefb2321c3 /app-portage
parentDie during src_compile if make fails. (diff)
downloadgentoo-2-96813ad553eaafb0f5b66d6b4e2c7d6b86604ab2.tar.gz
gentoo-2-96813ad553eaafb0f5b66d6b4e2c7d6b86604ab2.tar.bz2
gentoo-2-96813ad553eaafb0f5b66d6b4e2c7d6b86604ab2.zip
Version bump - new 'installedmarked format' feature
(Portage version: 2.1.6.10/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog7
-rw-r--r--app-portage/eix/eix-0.15.6.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index 15caffa35ffb..958ee273249a 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.277 2009/03/27 18:58:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.278 2009/03/28 14:11:30 darkside Exp $
+
+*eix-0.15.6 (28 Mar 2009)
+
+ 28 Mar 2009; Jeremy Olexa <darkside@gentoo.org> +eix-0.15.6.ebuild:
+ Version bump - new 'installedmarked format' feature
27 Mar 2009; Raúl Porcel <armin76@gentoo.org> eix-0.15.2.ebuild,
eix-0.15.5.ebuild:
diff --git a/app-portage/eix/eix-0.15.6.ebuild b/app-portage/eix/eix-0.15.6.ebuild
new file mode 100644
index 000000000000..eeb43a8e4281
--- /dev/null
+++ b/app-portage/eix/eix-0.15.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.15.6.ebuild,v 1.1 2009/03/28 14:11:30 darkside Exp $
+
+inherit multilib
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext.
+overlays, version changes, and more"
+HOMEPAGE="http://eix.sourceforge.net"
+SRC_URI="mirror://sourceforge/eix/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="doc sqlite"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ app-arch/bzip2"
+DEPEND="${RDEPEND}
+ app-arch/lzma-utils
+ doc? ( dev-python/docutils )"
+
+src_compile() {
+ econf --with-bzip2 $(use_with sqlite) $(use_with doc rst) \
+ --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
+ --with-portage-rootpath="${ROOTPATH}"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog doc/format.txt
+ use doc && dodoc doc/format.html
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "Security Warning:"
+ ewarn
+ ewarn "Since >=eix-0.12.0, eix uses by default OVERLAY_CACHE_METHOD=\"parse|ebuild*\""
+ ewarn "This is rather reliable, but ebuilds may be executed by user \"portage\". Set"
+ ewarn "OVERLAY_CACHE_METHOD=parse in /etc/eixrc if you do not trust the ebuilds."
+ if test -d /var/log && ! test -x /var/log || test -e /var/log/eix-sync.log
+ then
+ einfo
+ einfo "eix-sync no longer supports redirection to /var/log/eix-sync.log"
+ einfo "You can remove that file."
+ fi
+}