summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-05-22 18:13:24 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-05-22 18:13:24 +0000
commit8595d5fb607eea580c29ebbbd79ae961363f1fa5 (patch)
treec4dc68c076f25f7a533a5fe4b7a7250c97398c26 /app-portage
parentmake PATCHES a bash array (diff)
downloadgentoo-2-8595d5fb607eea580c29ebbbd79ae961363f1fa5.tar.gz
gentoo-2-8595d5fb607eea580c29ebbbd79ae961363f1fa5.tar.bz2
gentoo-2-8595d5fb607eea580c29ebbbd79ae961363f1fa5.zip
Fix glibc-2.10 build, bug 270492. ++ to Martin Väth <vaeth@mathematik.uni-wuerzburg.de> for the patch.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog7
-rw-r--r--app-portage/eix/eix-0.16.0.ebuild10
-rw-r--r--app-portage/eix/files/eix-0.16.0-glibc-2.10.patch31
3 files changed, 45 insertions, 3 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index 22a5f03a38f5..42e99db16a29 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.282 2009/05/08 04:27:10 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.283 2009/05/22 18:13:24 loki_val Exp $
+
+ 22 May 2009; Peter Alfredsen <loki_val@gentoo.org> eix-0.16.0.ebuild,
+ +files/eix-0.16.0-glibc-2.10.patch:
+ Fix glibc-2.10 build, bug 270492. ++ to Martin Väth
+ <vaeth@mathematik.uni-wuerzburg.de> for the patch.
08 May 2009; Jeremy Olexa <darkside@gentoo.org> -eix-0.15.5.ebuild,
-eix-0.15.6.ebuild:
diff --git a/app-portage/eix/eix-0.16.0.ebuild b/app-portage/eix/eix-0.16.0.ebuild
index 94a4aca6ebe9..e5624ccd0c7a 100644
--- a/app-portage/eix/eix-0.16.0.ebuild
+++ b/app-portage/eix/eix-0.16.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.16.0.ebuild,v 1.1 2009/05/08 04:24:40 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.16.0.ebuild,v 1.2 2009/05/22 18:13:24 loki_val Exp $
-inherit multilib
+inherit multilib eutils
DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext.
overlays, version changes, and more"
@@ -22,6 +22,12 @@ DEPEND="${RDEPEND}
doc? ( dev-python/docutils )
nls? ( sys-devel/gettext )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.16.0-glibc-2.10.patch"
+}
+
src_compile() {
econf --with-bzip2 $(use_with sqlite) $(use_with doc rst) \
$(use_enable nls) $(use_enable tools separate-tools) \
diff --git a/app-portage/eix/files/eix-0.16.0-glibc-2.10.patch b/app-portage/eix/files/eix-0.16.0-glibc-2.10.patch
new file mode 100644
index 000000000000..24d6c7e2fbc6
--- /dev/null
+++ b/app-portage/eix/files/eix-0.16.0-glibc-2.10.patch
@@ -0,0 +1,31 @@
+--- src/eixTk/ptr_list.h
++++ src/eixTk/ptr_list.h
+@@ -47,7 +47,7 @@
+ /// A list that only stores pointers to type.
+ template<typename type>
+ class ptr_list
+- : virtual public std::list<type*>
++ : public std::list<type*>
+ {
+ public:
+ using std::list<type*>::begin;
+--- src/output/formatstring.cc
++++ src/output/formatstring.cc
+@@ -278,7 +278,7 @@
+ FormatParser::ParserState
+ FormatParser::state_COLOR()
+ {
+- char *q = strchr(band_position, ')');
++ const char *q = strchr(band_position, ')');
+ if(q == NULL) {
+ last_error = _("'(' without closing ')'");
+ return ERROR;
+@@ -299,7 +299,7 @@
+ FormatParser::ParserState
+ FormatParser::state_PROPERTY()
+ {
+- char *q = strchr(band_position, '>');
++ const char *q = strchr(band_position, '>');
+ if(q == NULL) {
+ last_error = _("'<' without closing '>'");
+ return ERROR;