summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2010-09-27 23:08:33 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2010-09-27 23:08:33 +0000
commit734cb275cd431eb71ae548abec64c4cf67818413 (patch)
treeceebdabb2a97bacdd4453c012b28d127deb3ead1 /app-portage
parentAdd ~mips (diff)
downloadgentoo-2-734cb275cd431eb71ae548abec64c4cf67818413.tar.gz
gentoo-2-734cb275cd431eb71ae548abec64c4cf67818413.tar.bz2
gentoo-2-734cb275cd431eb71ae548abec64c4cf67818413.zip
[app-portage/g-octave] Initial commit, moved from the science overlay.
(Portage version: 2.2_rc86/cvs/Linux i686)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/g-octave/ChangeLog10
-rw-r--r--app-portage/g-octave/g-octave-0.4.ebuild84
-rw-r--r--app-portage/g-octave/metadata.xml18
3 files changed, 112 insertions, 0 deletions
diff --git a/app-portage/g-octave/ChangeLog b/app-portage/g-octave/ChangeLog
new file mode 100644
index 000000000000..219fd3325e87
--- /dev/null
+++ b/app-portage/g-octave/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-portage/g-octave
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/g-octave/ChangeLog,v 1.1 2010/09/27 23:08:33 rafaelmartins Exp $
+
+*g-octave-0.4 (27 Sep 2010)
+
+ 27 Sep 2010; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +g-octave-0.4.ebuild, +metadata.xml:
+ Initial commit, moved from the science overlay. (bug #299039)
+
diff --git a/app-portage/g-octave/g-octave-0.4.ebuild b/app-portage/g-octave/g-octave-0.4.ebuild
new file mode 100644
index 000000000000..9906e191fbe7
--- /dev/null
+++ b/app-portage/g-octave/g-octave-0.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/g-octave/g-octave-0.4.ebuild,v 1.1 2010/09/27 23:08:33 rafaelmartins Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="*:2.6"
+
+DB_COMMIT="cd6b664df376d50455efc19ad23a1463484f81f7"
+DB_COMMIT_ID="cd6b664"
+DB_DIR="rafaelmartins-${PN}-db-${DB_COMMIT_ID}"
+
+inherit distutils
+
+DESCRIPTION="A tool that generates and installs ebuilds for Octave-Forge"
+HOMEPAGE="http://www.g-octave.org/"
+
+SRC_URI="http://www.g-octave.org/releases/${P}.tar.gz
+ http://github.com/rafaelmartins/${PN}-db/tarball/${DB_COMMIT} -> ${PF}-db.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc test"
+
+DEPEND="doc? ( >=dev-python/sphinx-1.0 )"
+RDEPEND="sys-apps/portage"
+
+PYTHON_MODNAME="g_octave"
+
+src_prepare() {
+ distutils_src_prepare
+ sed -i -e 's/^has_fetch.*$/has_fetch = False/' scripts/g-octave \
+ || die 'failed to patch the g-octave main script'
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ emake -C docs html
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dohtml ${PN}.html || die 'dohtml failed.'
+ doman ${PN}.1 || die 'doman failed.'
+ if use doc; then
+ mv docs/_build/{html,sphinx} || die 'mv failed.'
+ dohtml -r docs/_build/sphinx || die 'dohtml failed.'
+ fi
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" \
+ scripts/run_tests.py || die 'test failed.'
+ }
+ python_execute_function testing
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ elog
+ elog 'To be able to use g-octave with the shipped package database, please'
+ elog 'edit your configuration file, clean your db directory and run:'
+ elog " emerge --config =${PF}"
+ elog
+ elog "If you are upgrading from =${PN}-0.3, please read this:"
+ elog 'http://doc.g-octave.org/0.4/upgrading/#from-0-3-to-0-4'
+ elog
+ elog 'Please install the package manager that you want to use before run g-octave'
+ elog
+}
+
+pkg_config() {
+ local db="$(g-octave --config db)"
+ mkdir -p "${db}"
+ einfo "Extracting g-octave database files to: ${db}"
+ tar -xzf "${DISTDIR}/${PF}-db.tar.gz" -C "${db}" || die 'tar failed.'
+ rm -rf "${db}"/{patches,octave-forge,info.json,timestamp}
+ mv -f "${db}/${DB_DIR}"/* ${db} || die 'mv failed.'
+ rm -rf "${db}/${DB_DIR}"
+}
diff --git a/app-portage/g-octave/metadata.xml b/app-portage/g-octave/metadata.xml
new file mode 100644
index 000000000000..29b2ab9188b1
--- /dev/null
+++ b/app-portage/g-octave/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <longdescription lang="en">
+ g-octave is a tool that generates and installs ebuilds for Octave-Forge
+ packages "on-the-fly" to Gentoo Linux, using Portage. It's capable to
+ generate ebuilds and Manifest files for the packages, and to install
+ them using an autogenerated overlay (named g-octave). g-octave can also
+ handle patches to the packages automatically. The command line interface
+ tries to be very similar to the interface of the emerge tool.
+ </longdescription>
+</pkgmetadata>
+