summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-15 12:38:24 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-15 12:38:24 +0000
commit72d683558d327fdbc2d183aec8666ac07af5008b (patch)
treece4ef1df5c74065fc03e125808e2d23779f8f6e3 /app-portage
parentImport the live ebuild. (diff)
downloadgentoo-2-72d683558d327fdbc2d183aec8666ac07af5008b.tar.gz
gentoo-2-72d683558d327fdbc2d183aec8666ac07af5008b.tar.bz2
gentoo-2-72d683558d327fdbc2d183aec8666ac07af5008b.zip
Import the live ebuild.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/smart-live-rebuild/ChangeLog7
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-portage/smart-live-rebuild/ChangeLog b/app-portage/smart-live-rebuild/ChangeLog
index 92fd29aeb903..f6800030f68a 100644
--- a/app-portage/smart-live-rebuild/ChangeLog
+++ b/app-portage/smart-live-rebuild/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/smart-live-rebuild
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/ChangeLog,v 1.44 2012/12/12 18:29:27 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/ChangeLog,v 1.45 2012/12/15 12:38:24 mgorny Exp $
+
+*smart-live-rebuild-9999 (15 Dec 2012)
+
+ 15 Dec 2012; Michał Górny <mgorny@gentoo.org> +smart-live-rebuild-9999.ebuild:
+ Import the live ebuild.
12 Dec 2012; Agostino Sarubbo <ago@gentoo.org> smart-live-rebuild-1.3.ebuild:
Stable for amd64, wrt bug #446406
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild
new file mode 100644
index 000000000000..435a629a39ea
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild,v 1.1 2012/12/15 12:38:24 mgorny Exp $
+
+EAPI=4
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2} )
+
+inherit distutils-r1
+
+#if LIVE
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+inherit git-2
+#endif
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://bitbucket.org/mgorny/smart-live-rebuild/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+python_test() {
+ "${PYTHON}" setup.py test || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example ${PN}.conf
+}