summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2010-09-12 17:54:33 +0000
committerMike Pagano <mpagano@gentoo.org>2010-09-12 17:54:33 +0000
commit685994fd6085ddcfc7819d13a31f409ee9c7ce68 (patch)
tree9343644f0f1d49c13300c4c7d3551efad959226d /app-portage
parentAdd missing DEPEND line (diff)
downloadgentoo-2-685994fd6085ddcfc7819d13a31f409ee9c7ce68.tar.gz
gentoo-2-685994fd6085ddcfc7819d13a31f409ee9c7ce68.tar.bz2
gentoo-2-685994fd6085ddcfc7819d13a31f409ee9c7ce68.zip
Add support for package.accept_keywords to the 1.5 branch
(Portage version: 2.2_rc80/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/portpeek/ChangeLog7
-rw-r--r--app-portage/portpeek/portpeek-1.5.9.3.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/app-portage/portpeek/ChangeLog b/app-portage/portpeek/ChangeLog
index 9d683e2837a3..92028fb1f067 100644
--- a/app-portage/portpeek/ChangeLog
+++ b/app-portage/portpeek/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/portpeek
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/portpeek/ChangeLog,v 1.88 2010/09/09 23:42:26 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portpeek/ChangeLog,v 1.89 2010/09/12 17:54:33 mpagano Exp $
+
+*portpeek-1.5.9.3 (12 Sep 2010)
+
+ 12 Sep 2010; Michael Pagano <mpagano@gentoo.org> +portpeek-1.5.9.3.ebuild:
+ Add support for package.accept_keywords to the 1.5 branch
*portpeek-1.9.48 (09 Sep 2010)
diff --git a/app-portage/portpeek/portpeek-1.5.9.3.ebuild b/app-portage/portpeek/portpeek-1.5.9.3.ebuild
new file mode 100644
index 000000000000..19b89873ed0f
--- /dev/null
+++ b/app-portage/portpeek/portpeek-1.5.9.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portpeek/portpeek-1.5.9.3.ebuild,v 1.1 2010/09/12 17:54:33 mpagano Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
+HOMEPAGE="http://www.mpagano.com/blog/?page_id=3"
+SRC_URI="http://www.mpagano.com/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!>app-portage/gentoolkit-0.2.4.6.1-r1
+ dev-lang/python:2.6"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs 2 portpeek
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed"
+ doman *.[0-9]
+}