summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2005-01-04 17:08:44 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2005-01-04 17:08:44 +0000
commit56926b960c40fb558be1abee8307dc8a79cda518 (patch)
treed22eb4f8ae568239d856812df56398029c50dbfb /app-portage
parentold (Manifest recommit) (diff)
downloadgentoo-2-56926b960c40fb558be1abee8307dc8a79cda518.tar.gz
gentoo-2-56926b960c40fb558be1abee8307dc8a79cda518.tar.bz2
gentoo-2-56926b960c40fb558be1abee8307dc8a79cda518.zip
cpufreq support - coordination with pciids.sf.net
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/basc/ChangeLog9
-rw-r--r--app-portage/basc/Manifest6
-rw-r--r--app-portage/basc/basc-1.5.4.ebuild87
-rw-r--r--app-portage/basc/files/digest-basc-1.5.41
4 files changed, 100 insertions, 3 deletions
diff --git a/app-portage/basc/ChangeLog b/app-portage/basc/ChangeLog
index edb69b3a8963..925699527c39 100644
--- a/app-portage/basc/ChangeLog
+++ b/app-portage/basc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/basc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/ChangeLog,v 1.14 2005/01/01 15:51:04 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/ChangeLog,v 1.15 2005/01/04 17:08:44 pvdabeel Exp $
+
+ 04 Jan 2005; Pieter Van den Abeele <pvdabeel@gentoo.org> basc-1.5.3.ebuild:
+ Added new fallback-detection for windowmanager, which searches
+ for the used desktopmanager and parses its configuration
+ Fixed cpu-frequency-detection if frequency-scaling is activated
+ Improved PCI detection (server side conversion)
+ Preparing coordination efforts with pciids.sourceforge.net
31 Dec 2004; Mike Doty <kingtaco@gentoo.org> basc-1.5.2.ebuild:
stable on amd64 bug #76123
diff --git a/app-portage/basc/Manifest b/app-portage/basc/Manifest
index fee27ae679dc..32a300b2daa4 100644
--- a/app-portage/basc/Manifest
+++ b/app-portage/basc/Manifest
@@ -1,6 +1,8 @@
-MD5 b9a117c039c5714611b7e4f34e7e34d0 ChangeLog 1895
-MD5 36441a3af28aa17a592a5c409239a278 metadata.xml 616
+MD5 b6dd204f3c5a8ab07d1ba5e5da37cd0f ChangeLog 2276
MD5 3c8e1225812577632847153488b201d7 basc-1.5.2.ebuild 2269
MD5 98f1fd168142a0154882d295792bdff0 basc-1.5.3.ebuild 2295
+MD5 36441a3af28aa17a592a5c409239a278 metadata.xml 616
+MD5 80eef32b41f528de55b1de9655e75be6 basc-1.5.4.ebuild 2155
MD5 74753ac6d1c6ab7f0dbf6c43d17045b4 files/digest-basc-1.5.3 61
MD5 fad108ecff3fcfbf2987a555420c92cc files/digest-basc-1.5.2 61
+MD5 0d0e5ae721dc3402d7b52269750aa9b7 files/digest-basc-1.5.4 61
diff --git a/app-portage/basc/basc-1.5.4.ebuild b/app-portage/basc/basc-1.5.4.ebuild
new file mode 100644
index 000000000000..2ce5e1c2d83b
--- /dev/null
+++ b/app-portage/basc/basc-1.5.4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/basc-1.5.4.ebuild,v 1.1 2005/01/04 17:08:44 pvdabeel Exp $
+
+# ebuild contributed by Alexander Mieland and Daniel Herzog
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Buildtime And Statistics Client for http://www.gentoo-stats.org"
+HOMEPAGE="http://www.gentoo-stats.org"
+SRC_URI="http://www.gentoo-stats.org/download/${P}.tar.gz"
+
+KEYWORDS="x86 sparc mips ~hppa ppc amd64 ~ppc64"
+SLOT="0"
+LICENSE="GPL-2"
+
+IUSE=""
+
+RDEPEND="app-portage/gentoolkit
+ dev-lang/perl
+ dev-perl/DateManip
+ sys-devel/gcc
+ sys-apps/sed
+ sys-apps/grep
+ app-arch/gzip
+ sys-apps/diffutils
+ >=net-misc/wget-1.9-r1
+ >=sys-apps/uhinv-0.4"
+
+pkg_setup() {
+ enewgroup stats
+ enewuser stats -1 /bin/false /tmp stats
+}
+
+src_compile() {
+ sed -i "s:/usr/local:/usr:g" client/basc client/hgenlop
+ useq x86 && $(tc-getCC) ${CFLAGS} -o client/smt-detect client/smt-detect.c >/dev/null 2>&1
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe client/basc client/hgenlop client/urandom.sh
+
+ useq x86 && doexe client/smt-detect
+
+ dodoc README ChangeLog TEAM
+ dodir /etc/basc
+
+ cp /var/log/emerge* ${D}/etc/basc
+
+ fowners root:stats /etc/basc
+ fperms ug+w /etc/basc
+}
+
+pkg_postinst() {
+
+
+ draw_line
+ einfo
+ einfo "The Gentoo Buildtime and Statistics client can be started by"
+ einfo "typing:"
+ einfo ""
+ einfo " \"basc\""
+ einfo ""
+ einfo "Note:"
+ einfo ""
+ einfo "You have to be in the stats group to use the client!"
+ einfo "A user can be added to the stats group by executing:"
+ einfo ""
+ einfo " \"usermod -G \$(groups <ME> | sed -e 's/ /,/g'),stats <ME>\""
+ einfo ""
+ einfo "Replace <ME> with your username on the system."
+ einfo "After a login, you are ready to use the client."
+ einfo ""
+ einfo "If you want to automatically launch the client every 24h,"
+ einfo "you must set up a cronjob for the stats user or a user in"
+ einfo "the stats group."
+ einfo ""
+ einfo "For example:"
+ einfo ""
+ einfo " \"0 0 * * * /usr/bin/basc -q -y >/dev/null 2>&1\""
+ einfo ""
+ einfo "will start the client every day at 00:00am"
+ einfo
+ draw_line
+ ebeep
+}
diff --git a/app-portage/basc/files/digest-basc-1.5.4 b/app-portage/basc/files/digest-basc-1.5.4
new file mode 100644
index 000000000000..b050dab3d6c0
--- /dev/null
+++ b/app-portage/basc/files/digest-basc-1.5.4
@@ -0,0 +1 @@
+MD5 08d1a9b87232575253d9f8f8a4f8586d basc-1.5.4.tar.gz 19129