summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-10-11 04:15:53 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-10-11 04:15:53 +0000
commit5635108cd58c1e31d5b6acb02de7c8424e20a8be (patch)
treee76c3772309646b615b9c1f81301580c44278210 /app-portage
parentVersion bump for bug #327101. Update to EAPI=3 and use src_prepare instead of... (diff)
downloadgentoo-2-5635108cd58c1e31d5b6acb02de7c8424e20a8be.tar.gz
gentoo-2-5635108cd58c1e31d5b6acb02de7c8424e20a8be.tar.bz2
gentoo-2-5635108cd58c1e31d5b6acb02de7c8424e20a8be.zip
Version bump to add repo deps support, bug 340098
(Portage version: 2.1.9.12/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog7
-rw-r--r--app-portage/eix/eix-0.22.3.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index c27571f08cdd..507e33e84447 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.346 2010/10/03 15:04:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.347 2010/10/11 04:15:53 darkside Exp $
+
+*eix-0.22.3 (11 Oct 2010)
+
+ 11 Oct 2010; Jeremy Olexa <darkside@gentoo.org> +eix-0.22.3.ebuild:
+ Version bump to add repo deps support, bug 340098
03 Oct 2010; Raúl Porcel <armin76@gentoo.org> eix-0.20.5.ebuild:
ia64/m68k/s390/sh/sparc stable wrt #323703
diff --git a/app-portage/eix/eix-0.22.3.ebuild b/app-portage/eix/eix-0.22.3.ebuild
new file mode 100644
index 000000000000..6c3085961528
--- /dev/null
+++ b/app-portage/eix/eix-0.22.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.22.3.ebuild,v 1.1 2010/10/11 04:15:53 darkside Exp $
+
+EAPI=3
+
+inherit multilib
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
+HOMEPAGE="http://eix.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="+bzip2 debug doc hardened nls optimization strong-optimization sqlite tools"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ doc? ( dev-python/docutils )
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf $(use_with bzip2) $(use_with sqlite) $(use_with doc rst) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
+ $(use_enable hardened security) $(use_enable optimization) \
+ $(use_enable strong-optimization) $(use_enable debug debugging) \
+ --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
+ --with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ prepalldocs
+}