summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2011-10-19 17:46:21 +0000
committerDaniel Pielmeier <billie@gentoo.org>2011-10-19 17:46:21 +0000
commit4d4a455ac7dbcf83a2aee86833f4a6e963c7a330 (patch)
treec27411effd4e1c2c4d3e1d74790fd477ca7928fb /app-portage
parentDepend on correct slot of pygobject. (diff)
downloadgentoo-2-4d4a455ac7dbcf83a2aee86833f4a6e963c7a330.tar.gz
gentoo-2-4d4a455ac7dbcf83a2aee86833f4a6e963c7a330.tar.bz2
gentoo-2-4d4a455ac7dbcf83a2aee86833f4a6e963c7a330.zip
Version bump. Fixes bug #381399 and #381403. Thanks to Michał Górny for the reports.
(Portage version: 2.1.10.29/cvs/Linux i686)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/pfl/ChangeLog8
-rw-r--r--app-portage/pfl/pfl-2.3.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/app-portage/pfl/ChangeLog b/app-portage/pfl/ChangeLog
index 2176c8108aa7..22f22460c900 100644
--- a/app-portage/pfl/ChangeLog
+++ b/app-portage/pfl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/pfl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/ChangeLog,v 1.32 2011/07/26 17:11:09 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/ChangeLog,v 1.33 2011/10/19 17:46:21 billie Exp $
+
+*pfl-2.3 (19 Oct 2011)
+
+ 19 Oct 2011; Daniel Pielmeier <billie@gentoo.org> +pfl-2.3.ebuild:
+ Version bump. Fixes bug #381399 and #381403. Thanks to Michał Górny for the
+ reports.
26 Jul 2011; Daniel Pielmeier <billie@gentoo.org> -pfl-2.1.ebuild:
Remove old.
diff --git a/app-portage/pfl/pfl-2.3.ebuild b/app-portage/pfl/pfl-2.3.ebuild
new file mode 100644
index 000000000000..b2827a88fb42
--- /dev/null
+++ b/app-portage/pfl/pfl-2.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pfl/pfl-2.3.ebuild,v 1.1 2011/10/19 17:46:21 billie Exp $
+
+EAPI=4
+
+PYTHON_DEPEND=2
+PYTHON_USE_WITH=xml
+
+inherit python
+
+MY_PV=20110906
+
+DESCRIPTION="PFL is an online searchable file/package database for Gentoo"
+HOMEPAGE="http://www.portagefilelist.de/index.php/Special:PFLQuery2"
+SRC_URI="http://files.portagefilelist.de/${P}
+ http://files.portagefilelist.de/e-file-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE="+network-cron"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ net-misc/curl
+ sys-apps/portage"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_unpack() {
+ cp "${DISTDIR}/${P}" "${WORKDIR}/${PN}.py" || die
+ cp "${DISTDIR}/e-file-${MY_PV}" "${WORKDIR}/e-file" || die
+}
+
+src_install() {
+ local cmd="$(PYTHON) -O $(python_get_sitedir)/${PN}/${PN}.py"
+
+ exeinto $(python_get_sitedir)/${PN}
+ doexe ${PN}.py
+
+ dobin e-file
+
+ dodir /var/lib/${PN}
+
+ # create wrapper script to run pfl manually
+ cat > "${T}/${PN}" <<- EOF
+ #!/bin/sh
+ ${cmd}
+ EOF
+ dosbin "${T}/${PN}"
+
+ if use network-cron ; then
+ # modify the wrapper script to be usable as cron job
+ sed -i -e "s|${cmd}|exec nice ${cmd} >/dev/null|g" "${T}/${PN}" || die
+ exeinto /etc/cron.weekly
+ doexe "${T}/${PN}"
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+
+ if [[ ! -e "${ROOT%/}/var/lib/${PN}/pfl.info" ]]; then
+ touch "${ROOT%/}/var/lib/${PN}/pfl.info"
+ chown -R 0:portage "${ROOT%/}/var/lib/${PN}"
+ chmod 775 "${ROOT%/}/var/lib/${PN}"
+ fi
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}