summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-04-30 22:19:39 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-04-30 22:19:39 +0000
commit3ec5f56a890da6b6bfba377bf201ef58d3b999fb (patch)
treed2394364b8beed7bcc56cd1c0d8c947fa50243da /app-portage
parentLicense change to LGPL. (diff)
downloadgentoo-2-3ec5f56a890da6b6bfba377bf201ef58d3b999fb.tar.gz
gentoo-2-3ec5f56a890da6b6bfba377bf201ef58d3b999fb.tar.bz2
gentoo-2-3ec5f56a890da6b6bfba377bf201ef58d3b999fb.zip
g-cpan is on its own kids
(Portage version: 2.0.51.20-r4)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/g-cpan/ChangeLog19
-rw-r--r--app-portage/g-cpan/Manifest4
-rw-r--r--app-portage/g-cpan/files/digest-g-cpan-0.121
-rw-r--r--app-portage/g-cpan/g-cpan-0.12.ebuild38
-rw-r--r--app-portage/g-cpan/metadata.xml14
5 files changed, 76 insertions, 0 deletions
diff --git a/app-portage/g-cpan/ChangeLog b/app-portage/g-cpan/ChangeLog
new file mode 100644
index 000000000000..98616917256f
--- /dev/null
+++ b/app-portage/g-cpan/ChangeLog
@@ -0,0 +1,19 @@
+# ChangeLog for app-portage/g-cpan
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/g-cpan/ChangeLog,v 1.1 2005/04/30 22:19:39 mcummings Exp $
+
+*g-cpan-0.12 (30 Apr 2005)
+
+ 30 Apr 2005; Michael Cummings <mcummings@gentoo.org> +metadata.xml,
+ +g-cpan-0.12.ebuild:
+ Initial import. Previously this package has lived inside the portage
+ tarball, but with a growing need to be able to push out changes quickly, we
+ can no longer afford for it to be tied to the development schedule of
+ portage (that and the portage devs don't like being asked hourly when the
+ next release of portage is going out just because I have a change in
+ g-cpan). Since until this point g-cpan has gone out with portage, which
+ is keyworded for absolutely everything, I've imported the keywords for
+ Digest::MD5, which for the time being we will make a dep. For those interested
+ in helping with g-cpan, send email to perl@gentoo.org or mcummings@gentoo.org.
+ I'd like to get rid of the dep on a configured CPAN :)
+
diff --git a/app-portage/g-cpan/Manifest b/app-portage/g-cpan/Manifest
new file mode 100644
index 000000000000..a465629939c7
--- /dev/null
+++ b/app-portage/g-cpan/Manifest
@@ -0,0 +1,4 @@
+MD5 4f4beaddde578514d5109fcc442f1837 g-cpan-0.12.ebuild 936
+MD5 1700933eaee6584200f19dcb29306ba5 metadata.xml 420
+MD5 8c724bb9b32b39d7c094e2b70888d683 ChangeLog 620
+MD5 bdf27604ec34f22b22d6351dd576caaa files/digest-g-cpan-0.12 61
diff --git a/app-portage/g-cpan/files/digest-g-cpan-0.12 b/app-portage/g-cpan/files/digest-g-cpan-0.12
new file mode 100644
index 000000000000..c3f502c06745
--- /dev/null
+++ b/app-portage/g-cpan/files/digest-g-cpan-0.12
@@ -0,0 +1 @@
+MD5 fdb7340ac016494eb03a0c791dfd2453 g-cpan-0.12.tar.gz 6325
diff --git a/app-portage/g-cpan/g-cpan-0.12.ebuild b/app-portage/g-cpan/g-cpan-0.12.ebuild
new file mode 100644
index 000000000000..a29d71522f22
--- /dev/null
+++ b/app-portage/g-cpan/g-cpan-0.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/g-cpan/g-cpan-0.12.ebuild,v 1.1 2005/04/30 22:19:39 mcummings Exp $
+
+DESCRIPTION="g-cpan: generate and install CPAN modules using portage"
+HOMEPAGE="http://dev.gentoo.org/~mcummings/"
+SRC_URI="mirorr://gentoo/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 s390 ppc64"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ dev-perl/Digest-MD5"
+
+pkg_setup() {
+ if hasq collision-protect $FEATURES; then
+ ewarn "This ebuild will fail with collision-protect in place."
+ ewarn "This ebuild is replacing a package that was previously"
+ ewarn "bundled with portage directly. Please disable "
+ ewarn "collision-protect for the installation of this package."
+ die
+ fi
+}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_install() {
+ dodir /usr/bin
+ cp ${S}/bin/g-cpan.pl ${D}/usr/bin/
+ dodir /usr/share/man/man1
+ cp ${S}/man/g-cpan.pl.1 ${D}/usr/share/man/man1/
+ dodoc Changes
+ dosym /usr/bin/g-cpan.pl /usr/bin/g-cpan
+}
diff --git a/app-portage/g-cpan/metadata.xml b/app-portage/g-cpan/metadata.xml
new file mode 100644
index 000000000000..d1309548bce4
--- /dev/null
+++ b/app-portage/g-cpan/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>mcummings@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <maintainer>
+ <email>perl@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <longdescription></longdescription>
+</pkgmetadata>