summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2004-12-22 19:03:47 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2004-12-22 19:03:47 +0000
commit3db4814ffdeb65a1e997c931a2c81dea3c00af94 (patch)
tree4afb5b55360ff9278c44828a8eb2c07a11c90af3 /app-portage
parent2.2 developmental release. Hardmask. (Manifest recommit) (diff)
downloadgentoo-2-3db4814ffdeb65a1e997c931a2c81dea3c00af94.tar.gz
gentoo-2-3db4814ffdeb65a1e997c931a2c81dea3c00af94.tar.bz2
gentoo-2-3db4814ffdeb65a1e997c931a2c81dea3c00af94.zip
Initial import
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/basc/ChangeLog9
-rw-r--r--app-portage/basc/Manifest3
-rw-r--r--app-portage/basc/basc-1.3.9.ebuild77
-rw-r--r--app-portage/basc/files/digest-basc-1.3.91
4 files changed, 90 insertions, 0 deletions
diff --git a/app-portage/basc/ChangeLog b/app-portage/basc/ChangeLog
new file mode 100644
index 000000000000..210eb6ed5664
--- /dev/null
+++ b/app-portage/basc/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-apps/uhinv
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/ChangeLog,v 1.1 2004/12/22 19:03:47 pvdabeel Exp $
+
+* basc-1.3.9 (22 Dec 2004)
+
+ 22 Dec 2004; Pieter Van den Abeele <pvdabeel@gentoo.org> basc-1.3.9.ebuild :
+
+ Initial import. Buildtime And Statistics Client for http://www.gentoo-stats.org
diff --git a/app-portage/basc/Manifest b/app-portage/basc/Manifest
new file mode 100644
index 000000000000..92e4fc542389
--- /dev/null
+++ b/app-portage/basc/Manifest
@@ -0,0 +1,3 @@
+MD5 f2560a8ae895842e72b3383f02f88b4f ChangeLog 393
+MD5 f4a2ba867d3a340d72a8b88ed96ea96b basc-1.3.9.ebuild 3722
+MD5 e2d5a46d807b9a6fc2aba48df22d2971 files/digest-basc-1.3.9 61
diff --git a/app-portage/basc/basc-1.3.9.ebuild b/app-portage/basc/basc-1.3.9.ebuild
new file mode 100644
index 000000000000..fc17a15b1559
--- /dev/null
+++ b/app-portage/basc/basc-1.3.9.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/basc-1.3.9.ebuild,v 1.1 2004/12/22 19:03:47 pvdabeel Exp $
+
+# ebuild contributed by Alexander Mieland and Daniel Herzog
+
+inherit eutils gcc
+
+DESCRIPTION="Buildtime And Statistics Client for http://www.gentoo-stats.org"
+HOMEPAGE="http://www.gentoo-stats.org"
+SRC_URI="http://www.gentoo-stats.org/download/${P}.tar.gz"
+
+KEYWORDS="~x86 ~sparc ~mips ~hppa ppc ~amd64"
+SLOT="0"
+LICENSE="GPL-2"
+
+IUSE=""
+
+RDEPEND="app-portage/gentoolkit
+ dev-lang/perl
+ dev-perl/DateManip
+ net-misc/wget
+ sys-devel/gcc
+ sys-apps/sed
+ sys-apps/grep
+ app-arch/gzip
+ >=sys-apps/uhinv-0.4"
+
+pkg_setup() {
+ enewgroup stats
+ enewuser stats -1 /bin/false /tmp stats
+}
+
+src_compile() {
+ sed -i "s:/usr/local:/usr:g" client/basc
+ sed -i "s:/usr/local:/usr:g" client/hgenlop
+ $(gcc-getCC) ${CFLAGS} -o client/smt-detect client/smt-detect.c
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe client/basc client/hgenlop client/smt-detect
+ dodoc README ChangeLog TEAM
+ dodir /etc/basc
+ touch ${D}/etc/basc/basc.conf
+
+ fowners root:stats /etc/basc
+ fperms og+w /etc/basc
+
+ fowners root:stats /etc/basc/basc.conf
+ fperms og+w /etc/basc/basc.conf
+}
+
+pkg_postinst() {
+ local GU=`/usr/bin/hgenlop -nt gcc`
+ echo "GU=\"${GU}\"" >> /etc/basc/basc.conf
+
+ draw_line
+ einfo
+ einfo "The Gentoo Buildtime and Statistics client can be started by"
+ einfo "typing:"
+ einfo ""
+ einfo " \"basc -u\"."
+ einfo ""
+ einfo "If you want to automatically launch the client every 24h,"
+ einfo "you must set up a cronjob for the stats user or a user in"
+ einfo "the stats group."
+ einfo ""
+ einfo "For example:"
+ einfo ""
+ einfo " \"0 0 * * * /usr/bin/basc -q >/dev/null 2>&1\""
+ einfo ""
+ einfo "will start the client every day at 00:00am"
+ einfo
+ draw_line
+ ebeep
+}
diff --git a/app-portage/basc/files/digest-basc-1.3.9 b/app-portage/basc/files/digest-basc-1.3.9
new file mode 100644
index 000000000000..286bff54db1e
--- /dev/null
+++ b/app-portage/basc/files/digest-basc-1.3.9
@@ -0,0 +1 @@
+MD5 94d1cb6286e9d30073d72f0517b46b0d basc-1.3.9.tar.gz 13775