summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2011-07-05 14:30:15 +0000
committerJeremy Olexa <darkside@gentoo.org>2011-07-05 14:30:15 +0000
commit3a8197b4fef4c74ffa6087a216a8d840fb8c5134 (patch)
treed6829ed4ff177bfb9ec5b9aafeca7392c771a630 /app-portage
parentapp-crypt/johntheripper: Version bump wrt bug 374123. Move to EAPI 4. Add req... (diff)
downloadgentoo-2-3a8197b4fef4c74ffa6087a216a8d840fb8c5134.tar.gz
gentoo-2-3a8197b4fef4c74ffa6087a216a8d840fb8c5134.tar.bz2
gentoo-2-3a8197b4fef4c74ffa6087a216a8d840fb8c5134.zip
Version bump from upstream, multiple bug fixes
(Portage version: 2.1.9.50/cvs/Linux i686)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog7
-rw-r--r--app-portage/eix/eix-0.22.9.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index 0392fab4da12..1a3c563520a1 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.366 2011/03/21 14:48:50 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.367 2011/07/05 14:30:15 darkside Exp $
+
+*eix-0.22.9 (05 Jul 2011)
+
+ 05 Jul 2011; Jeremy Olexa <darkside@gentoo.org> +eix-0.22.9.ebuild:
+ Version bump from upstream, multiple bug fixes
21 Mar 2011; Jeremy Olexa <darkside@gentoo.org> eix-0.22.8.ebuild:
Add prefix bit, bug 353562
diff --git a/app-portage/eix/eix-0.22.9.ebuild b/app-portage/eix/eix-0.22.9.ebuild
new file mode 100644
index 000000000000..87a12802d7b1
--- /dev/null
+++ b/app-portage/eix/eix-0.22.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.22.9.ebuild,v 1.1 2011/07/05 14:30:15 darkside Exp $
+
+EAPI="4"
+
+inherit multilib
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
+HOMEPAGE="http://eix.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="bzip2 debug doc hardened nls optimization strong-optimization sqlite tools zsh-completion"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )
+ bzip2? ( app-arch/bzip2 )
+ zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf $(use_with bzip2) $(use_with sqlite) $(use_with doc extra-doc) \
+ $(use_with zsh-completion) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
+ $(use_enable hardened security) $(use_enable optimization) \
+ $(use_enable strong-optimization) $(use_enable debug debugging) \
+ $(use_with prefix always-accept-keywords) \
+ --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
+ --with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+}