summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2013-03-26 15:56:46 +0000
committerPaul Varner <fuzzyray@gentoo.org>2013-03-26 15:56:46 +0000
commit26f517a5c97bd82b587f6a246c0793f802182bb5 (patch)
treef4860ab9372da74c5ca94bf13bf6cdd04c28fbb0 /app-portage
parentStable for x86, wrt bug #457468 (diff)
downloadgentoo-2-26f517a5c97bd82b587f6a246c0793f802182bb5.tar.gz
gentoo-2-26f517a5c97bd82b587f6a246c0793f802182bb5.tar.bz2
gentoo-2-26f517a5c97bd82b587f6a246c0793f802182bb5.zip
Version bump for first release candidate version.
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key 0x4D269A1B)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/ufed/ChangeLog9
-rw-r--r--app-portage/ufed/ufed-0.90_rc1.ebuild37
2 files changed, 45 insertions, 1 deletions
diff --git a/app-portage/ufed/ChangeLog b/app-portage/ufed/ChangeLog
index 20dd81e602db..295fe92fe52f 100644
--- a/app-portage/ufed/ChangeLog
+++ b/app-portage/ufed/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/ufed
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ChangeLog,v 1.96 2013/03/26 15:47:56 fuzzyray Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ChangeLog,v 1.97 2013/03/26 15:56:45 fuzzyray Exp $
+
+*ufed-0.90_rc1 (26 Mar 2013)
+
+ 26 Mar 2013; Paul Varner <fuzzyray@gentoo.org> +ufed-0.90_rc1.ebuild:
+ Version bump for first release candidate version. See
+ http://git.overlays.gentoo.org/gitweb/?p=proj/ufed.git;a=summary for
+ detailed changes in this release.
26 Mar 2013; Paul Varner <fuzzyray@gentoo.org> -ufed-0.40-r6.ebuild,
-ufed-0.40-r10.ebuild, -ufed-0.40-r11.ebuild, -ufed-0.40.1.ebuild,
diff --git a/app-portage/ufed/ufed-0.90_rc1.ebuild b/app-portage/ufed/ufed-0.90_rc1.ebuild
new file mode 100644
index 000000000000..97cd7e7560b5
--- /dev/null
+++ b/app-portage/ufed/ufed-0.90_rc1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ufed-0.90_rc1.ebuild,v 1.1 2013/03/26 15:56:46 fuzzyray Exp $
+
+EAPI=5
+
+inherit base eutils multilib autotools
+
+DESCRIPTION="Gentoo Linux USE flags editor"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~fuzzyray/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+
+# Populate the patches array for patches applied for -rX releases
+# It is an array of patch file names of the form:
+# "${FILESDIR}"/${P}-make.globals-path.patch
+PATCHES=()
+
+src_prepare() {
+ base_src_prepare
+ # Change the version number to reflect the ebuild version
+ sed -i "s:,\[git\],:,\[${PVR}\],:" configure.ac
+ eautoreconf
+}
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}"/usr/$(get_libdir)/ufed
+}