summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-03-22 14:12:08 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-03-22 14:12:08 +0000
commit217bffc08af367f4cb459fd691c31b16d6042f61 (patch)
tree8f5b5bdfae073360f1a2af57218b319b1ee02a56 /app-portage
parentNew 1.1 release candidate, slotted to install alongside existing rails (diff)
downloadgentoo-2-217bffc08af367f4cb459fd691c31b16d6042f61.tar.gz
gentoo-2-217bffc08af367f4cb459fd691c31b16d6042f61.tar.bz2
gentoo-2-217bffc08af367f4cb459fd691c31b16d6042f61.zip
Add patch for bug 127184
(Portage version: 2.1_pre6-r4)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog6
-rw-r--r--app-portage/eix/eix-0.5.5.ebuild10
-rw-r--r--app-portage/eix/files/eix-bug127184.patch12
3 files changed, 26 insertions, 2 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index 9c9faeabe198..288e63acc313 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.74 2006/03/22 11:10:11 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.75 2006/03/22 14:12:07 genstef Exp $
+
+ 22 Mar 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/eix-bug127184.patch, eix-0.5.5.ebuild:
+ Add patch for bug 127184
*eix-0.5.5 (22 Mar 2006)
diff --git a/app-portage/eix/eix-0.5.5.ebuild b/app-portage/eix/eix-0.5.5.ebuild
index cf98c01cebcc..8ce733afbda1 100644
--- a/app-portage/eix/eix-0.5.5.ebuild
+++ b/app-portage/eix/eix-0.5.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.5.5.ebuild,v 1.1 2006/03/22 11:10:11 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.5.5.ebuild,v 1.2 2006/03/22 14:12:08 genstef Exp $
+
+inherit eutils
DESCRIPTION="Small utility for searching ebuilds with indexing for fast results"
HOMEPAGE="http://dev.croup.de/proj/eix"
@@ -13,6 +15,12 @@ IUSE=""
DEPEND="sys-apps/portage"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/eix-bug127184.patch
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"
}
diff --git a/app-portage/eix/files/eix-bug127184.patch b/app-portage/eix/files/eix-bug127184.patch
new file mode 100644
index 000000000000..ee4f92e91b6b
--- /dev/null
+++ b/app-portage/eix/files/eix-bug127184.patch
@@ -0,0 +1,12 @@
+Index: src/eixTk/regexp.h
+===================================================================
+--- src/eixTk/regexp.h (revision 125)
++++ src/eixTk/regexp.h (working copy)
+@@ -28,6 +28,7 @@
+ #ifndef __REGEXCLASS_H__
+ #define __REGEXCLASS_H__
+
++#include <sys/types.h>
+ #include <regex.h>
+ #include <string>
+