summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2005-03-12 16:40:56 +0000
committerBenedikt Boehm <hollow@gentoo.org>2005-03-12 16:40:56 +0000
commit1c944a67220c413100034d8486d44110fcb9252b (patch)
treeb4549e0fd0e61644292ccea025dd6bcecc891b3a /app-portage
parentBump to -mm3. (diff)
downloadgentoo-2-1c944a67220c413100034d8486d44110fcb9252b.tar.gz
gentoo-2-1c944a67220c413100034d8486d44110fcb9252b.tar.bz2
gentoo-2-1c944a67220c413100034d8486d44110fcb9252b.zip
compile fix
(Portage version: 2.0.51.16)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog8
-rw-r--r--app-portage/eix/Manifest15
-rw-r--r--app-portage/eix/eix-0.2.2_alpha-r1.ebuild37
-rw-r--r--app-portage/eix/files/0.2.2_alpha-compile-fix.patch13
-rw-r--r--app-portage/eix/files/digest-eix-0.2.2_alpha-r11
5 files changed, 62 insertions, 12 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index 58801c6bd7fe..00e1c2f80db9 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.15 2005/03/10 22:19:16 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.16 2005/03/12 16:40:56 hollow Exp $
+
+*eix-0.2.2_alpha-r1 (12 Mar 2005)
+
+ 12 Mar 2005; Benedikt Boehm <hollow@gentoo.org>
+ +files/0.2.2_alpha-compile-fix.patch, +eix-0.2.2_alpha-r1.ebuild:
+ compile fix, fixes 84976
*eix-0.2.2_alpha (10 Mar 2005)
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 3c6a9437fe7f..68bf19bc9d65 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,7 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 1f890d394eab86be18f76c69aef6dcd2 ChangeLog 1993
+MD5 4b2cef41e3e09bf3bbd53e7cbeeba082 ChangeLog 2174
MD5 f9174308ba5481ddcf2bcdccfbbc78fc eix-0.1.2.ebuild 906
MD5 899859c820908cdddfde8b785d28ce13 eix-0.1.3.ebuild 906
MD5 5b05bad1e4a1351770d39b0db3ad61eb eix-0.1.4.ebuild 929
@@ -10,6 +7,7 @@ MD5 74c5aadf8e3e9d642a20e64d1afefec8 metadata.xml 239
MD5 a8c64cfe5c04761b53a5358a32c26aa7 eix-0.2.0.ebuild 929
MD5 fbaa0060b92b7884732bf7288439a685 eix-0.2.0-r1.ebuild 1012
MD5 e6293fba5adde620a8f4a2c9ffdb5772 eix-0.2.1.ebuild 935
+MD5 10b205ea492f26cb39a12342c17e5905 eix-0.2.2_alpha-r1.ebuild 992
MD5 9e0fa1748f0123a55d7bfa69bdc6e01c eix-0.2.2_alpha.ebuild 942
MD5 1799d094d8f713c906ebbca17a1fceba files/0.2.0_alpha-bugfixes.patch 10004
MD5 737be5ef3edeea51c32776dce337f074 files/0.2.0-bugfixes.patch 1582
@@ -21,10 +19,5 @@ MD5 21e9cd46c94e214aa188c426fa3f1970 files/digest-eix-0.2.0 62
MD5 60e6685c015f26383866ec5a58a54a25 files/digest-eix-0.2.0_alpha 68
MD5 943e6938455bf034be166ecbe03c88aa files/digest-eix-0.2.1 62
MD5 160675099b50865703f766992a5b8b12 files/digest-eix-0.2.2_alpha 68
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCMMgFmPFBzbX68WERAho+AJwKnb5Pay26X/ro8cdESb8B58u5oQCffOVC
-Ih4NgNJmzE8KiPdB2Rwq+7g=
-=8NWs
------END PGP SIGNATURE-----
+MD5 a6063e431d7febe651364efbe0aaba81 files/0.2.2_alpha-compile-fix.patch 530
+MD5 160675099b50865703f766992a5b8b12 files/digest-eix-0.2.2_alpha-r1 68
diff --git a/app-portage/eix/eix-0.2.2_alpha-r1.ebuild b/app-portage/eix/eix-0.2.2_alpha-r1.ebuild
new file mode 100644
index 000000000000..7501de15ba5f
--- /dev/null
+++ b/app-portage/eix/eix-0.2.2_alpha-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.2.2_alpha-r1.ebuild,v 1.1 2005/03/12 16:40:56 hollow Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Small utility for searching ebuilds with indexing for fast results"
+HOMEPAGE="http://sourceforge.net/projects/eix"
+SRC_URI="mirror://sourceforge/eix/${PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~alpha ~ia64 ~ppc ~sparc"
+
+DEPEND="sys-devel/gcc
+ virtual/libc"
+RDEPEND="sys-apps/portage
+ virtual/libc"
+
+src_compile() {
+ epatch ${FILESDIR}/0.2.2_alpha-compile-fix.patch
+ aclocal
+ libtoolize --force --copy
+ autoconf
+
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+}
+
+pkg_postinst() {
+ einfo "Please run '/usr/bin/eix -u' to setup the portage search database."
+ einfo "The database file will be located at /var/cache/eix"
+}
diff --git a/app-portage/eix/files/0.2.2_alpha-compile-fix.patch b/app-portage/eix/files/0.2.2_alpha-compile-fix.patch
new file mode 100644
index 000000000000..6c2c57db5f8c
--- /dev/null
+++ b/app-portage/eix/files/0.2.2_alpha-compile-fix.patch
@@ -0,0 +1,13 @@
+--- eix-0.2.2_alpha/src/main.cc 2005-03-09 17:38:45.000000000 +0100
++++ eix-0.2.2_alpha1/src/main.cc 2005-03-11 15:03:46.000000000 +0100
+@@ -255,8 +255,8 @@
+ }
+ // init portagedb only if we want to update
+ portage_db.dbBuild(&db_query);
+- int count = portage_db.dbSave();
+- printf("Database updated successfully. It contains %i packages.\n", count);
++ cout << "Database updated successfully. It contains "
++ << portage_db.dbSave() << " packages." << endl;
+
+ /* Correct permissions. */
+ uid_t u;
diff --git a/app-portage/eix/files/digest-eix-0.2.2_alpha-r1 b/app-portage/eix/files/digest-eix-0.2.2_alpha-r1
new file mode 100644
index 000000000000..94452baf33a1
--- /dev/null
+++ b/app-portage/eix/files/digest-eix-0.2.2_alpha-r1
@@ -0,0 +1 @@
+MD5 d595fb3b14fc120df9efd101d59c192b eix-0.2.2_alpha.tar.bz2 228452