summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2010-03-11 16:29:12 +0000
committerMark Loeser <halcy0n@gentoo.org>2010-03-11 16:29:12 +0000
commit173b0673b5b779cc2b725fa45b55c236fcbfc2f9 (patch)
treeaa4b17568cc4bc96aeee9a9a7d3016c29ab6561f /app-portage
parentMask perl 5.10 on fbsd 7.2 as it requires ssp which is broken (diff)
downloadgentoo-2-173b0673b5b779cc2b725fa45b55c236fcbfc2f9.tar.gz
gentoo-2-173b0673b5b779cc2b725fa45b55c236fcbfc2f9.tar.bz2
gentoo-2-173b0673b5b779cc2b725fa45b55c236fcbfc2f9.zip
Add back as the stable version of app-admin/puppet depends upon it
(Portage version: 2.2_rc65/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog5
-rw-r--r--app-portage/eix/eix-0.17.0.ebuild68
-rw-r--r--app-portage/eix/metadata.xml1
3 files changed, 73 insertions, 1 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index a417fb8346ac..0600be58e0a1 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.327 2010/03/09 20:49:07 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.328 2010/03/11 16:29:12 halcy0n Exp $
+
+ 11 Mar 2010; Mark Loeser <halcy0n@gentoo.org> +eix-0.17.0.ebuild:
+ Add back as the stable version of app-admin/puppet depends upon it
*eix-0.20.2 (09 Mar 2010)
diff --git a/app-portage/eix/eix-0.17.0.ebuild b/app-portage/eix/eix-0.17.0.ebuild
new file mode 100644
index 000000000000..a808741be60a
--- /dev/null
+++ b/app-portage/eix/eix-0.17.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.17.0.ebuild,v 1.13 2010/03/11 16:29:12 halcy0n Exp $
+
+EAPI="1"
+
+inherit multilib
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext.
+overlays, version changes, and more"
+HOMEPAGE="http://eix.sourceforge.net"
+SRC_URI="mirror://sourceforge/eix/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="+deprecated doc nls sqlite tools"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )
+ app-arch/bzip2"
+DEPEND="${RDEPEND}
+ || ( app-arch/xz-utils app-arch/lzma-utils )
+ doc? ( dev-python/docutils )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf --with-bzip2 $(use_with sqlite) $(use_with doc rst) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
+ --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
+ --with-portage-rootpath="${ROOTPATH}" \
+ $(use_enable deprecated obsolete-reminder)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog doc/format.txt
+ use doc && dodoc doc/format.html
+}
+
+pkg_postinst() {
+ elog "Ask your overlay maintainers to provide metadata or consider to run"
+ elog " egencache --repo=foo --update"
+ elog "after updates (e.g. in /etc/eix-sync)."
+ elog "This will speed up portage and update-eix (when the new default cache method"
+ elog "\"...#metadata-flat\" is used and file dates are correct) for those overlays."
+ elog "If metadata is provided but file dates are mangled during overlay updates,"
+ elog "you may switch to cache method \"metadata-flat\" instead for that overlay:"
+ elog "This is even faster, but works only if metadata is actually up-to-date."
+ ewarn
+ ewarn "Security Warning:"
+ ewarn
+ ewarn "Since >=eix-0.12.0, eix uses by default OVERLAY_CACHE_METHOD=\"parse|ebuild*\""
+ ewarn "(since >=eix-0.16.1 with automagic \"#metadata-flat\")."
+ ewarn "This is rather reliable, but ebuilds may be executed by user \"portage\". Set"
+ ewarn "OVERLAY_CACHE_METHOD=parse in /etc/eixrc if you do not trust the ebuilds."
+ if use deprecated; then
+ elog "ATTENTION: The old eix executable names will be going away in 6"
+ elog "months or the next major release, whichever is first. Update"
+ elog "your scripts"
+ else
+ elog "ATTENTION: The eix executable names have changed. Update your"
+ elog "scripts, if needed. This message will go away soon."
+ fi
+
+}
diff --git a/app-portage/eix/metadata.xml b/app-portage/eix/metadata.xml
index aa099f4a85a1..d4b6e9db4c22 100644
--- a/app-portage/eix/metadata.xml
+++ b/app-portage/eix/metadata.xml
@@ -15,6 +15,7 @@
<use>
<flag name="bzip2">Support for parsing of environment.bz2 to guess repository name of packages installed with ancient portage versions (requires <pkg>app-arch/bzip2</pkg>). This flag is safe to disable for portage users that have re-merged all packages since 2007. This flag will be phased out.</flag>
<flag name="debug">Build with CXXFLAGS/LDFLAGS for debugging support. Only makes sense in combination with FEATURES=nostrip.</flag>
+ <flag name="deprecated">Installs wrapper scripts for all the previous executable names that will soon be going away. Enabled by default in 0.17.0, optional in 0.18.0, removed in next major release.</flag>
<flag name="doc">Create description of the eix cache file additionally in html format</flag>
<flag name="hardened">Add CXXFLAGS/LDFLAGS enhancing security at the cost of a slight speed loss. If a hardened gcc is used, these flags should not make a difference.</flag>
<flag name="nls">Support foreign language messages (experimental; currently only de)</flag>