summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2012-04-11 21:41:28 +0000
committerPaul Varner <fuzzyray@gentoo.org>2012-04-11 21:41:28 +0000
commit10f2b9293d0fefbc8cf53761a6e357e97c339d1e (patch)
treea7839a23a9c51b8b2cff5e72ec7127819d3fe282 /app-portage
parentCalligra 2.4 released (diff)
downloadgentoo-2-10f2b9293d0fefbc8cf53761a6e357e97c339d1e.tar.gz
gentoo-2-10f2b9293d0fefbc8cf53761a6e357e97c339d1e.tar.bz2
gentoo-2-10f2b9293d0fefbc8cf53761a6e357e97c339d1e.zip
Version bump to re-add support for prefix enviroments.
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoolkit/ChangeLog7
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.3.0.6.ebuild89
2 files changed, 95 insertions, 1 deletions
diff --git a/app-portage/gentoolkit/ChangeLog b/app-portage/gentoolkit/ChangeLog
index 10118cd8118b..789772a019c9 100644
--- a/app-portage/gentoolkit/ChangeLog
+++ b/app-portage/gentoolkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/gentoolkit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.255 2012/04/11 20:14:05 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.256 2012/04/11 21:41:28 fuzzyray Exp $
+
+*gentoolkit-0.3.0.6 (11 Apr 2012)
+
+ 11 Apr 2012; Paul Varner <fuzzyray@gentoo.org> +gentoolkit-0.3.0.6.ebuild:
+ Version bump to re-add support for prefix enviroments.
11 Apr 2012; Jeff Horelick <jdhore@gentoo.org> gentoolkit-0.3.0.5.ebuild:
marked x86 per bug 411479
diff --git a/app-portage/gentoolkit/gentoolkit-0.3.0.6.ebuild b/app-portage/gentoolkit/gentoolkit-0.3.0.6.ebuild
new file mode 100644
index 000000000000..7bc6f20b8f2e
--- /dev/null
+++ b/app-portage/gentoolkit/gentoolkit-0.3.0.6.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/gentoolkit-0.3.0.6.ebuild,v 1.1 2012/04/11 21:41:28 fuzzyray Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45]"
+PYTHON_USE_WITH="xml"
+PYTHON_NONVERSIONED_EXECUTABLES=(".*")
+
+inherit distutils python eutils
+
+DESCRIPTION="Collection of administration scripts for Gentoo"
+HOMEPAGE="http://www.gentoo.org/proj/en/portage/tools/index.xml"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x64-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Note: argparse is provided in python 2.7 and 3.2 (Bug 346005)
+# Note: dev-lang/python dependencies are so emerge will print a blocker if any
+# installed slot of python is not built with +xml. This is used since
+# PYTHON_USE_WITH just dies in the middle of the emerge. See bug 399331.
+DEPEND="sys-apps/portage"
+RDEPEND="${DEPEND}
+ >=dev-lang/python-2.6[xml]
+ !>=dev-lang/python-2.6[-xml]
+ !<=app-portage/gentoolkit-dev-0.2.7
+ dev-python/argparse
+ || ( >=sys-apps/coreutils-8.15 app-misc/realpath sys-freebsd/freebsd-bin )
+ sys-apps/gawk
+ sys-apps/grep"
+
+distutils_src_compile_pre_hook() {
+ echo VERSION="${PVR}" "$(PYTHON)" setup.py set_version
+ VERSION="${PVR}" "$(PYTHON)" setup.py set_version \
+ || die "setup.py set_version failed"
+}
+
+src_install() {
+ python_convert_shebangs -r "" build-*/scripts-*
+ distutils_src_install
+
+ # Rename the python versions of revdep-rebuild, since we are not ready
+ # to switch to the python version yet. Link /usr/bin/revdep-rebuild to
+ # revdep-rebuild.sh. Leaving the python version available for potential
+ # testing by a wider audience.
+ mv "${ED}"/usr/bin/revdep-rebuild "${ED}"/usr/bin/revdep-rebuild.py
+ dosym revdep-rebuild.sh /usr/bin/revdep-rebuild
+
+ # Create cache directory for revdep-rebuild
+ dodir /var/cache/revdep-rebuild
+ keepdir /var/cache/revdep-rebuild
+ use prefix || fowners root:root /var/cache/revdep-rebuild
+ fperms 0700 /var/cache/revdep-rebuild
+
+ # remove on Gentoo Prefix platforms where it's broken anyway
+ if use prefix; then
+ elog "The revdep-rebuild command is removed, the preserve-libs"
+ elog "feature of portage will handle issues."
+ rm "${ED}"/usr/bin/revdep-rebuild
+ rm "${ED}"/usr/bin/revdep-rebuild.py
+ rm "${ED}"/usr/share/man/man1/revdep-rebuild.1
+ rm -rf "${ED}"/etc/revdep-rebuild
+ rm -rf "${ED}"/var
+ fi
+
+ # Can distutils handle this?
+ dosym eclean /usr/bin/eclean-dist
+ dosym eclean /usr/bin/eclean-pkg
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ einfo
+ einfo "For further information on gentoolkit, please read the gentoolkit"
+ einfo "guide: http://www.gentoo.org/doc/en/gentoolkit.xml"
+ einfo
+ einfo "Another alternative to equery is app-portage/portage-utils"
+ ewarn
+ ewarn "glsa-check since gentoolkit 0.3 has modified some output,"
+ ewarn "options and default behavior. The list of injected GLSAs"
+ ewarn "has moved to /var/lib/portage/glsa_injected, please"
+ ewarn "run 'glsa-check -p affected' before copying the existing checkfile."
+}