summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2009-12-08 04:53:44 +0000
committerChristian Ruppert <idl0r@gentoo.org>2009-12-08 04:53:44 +0000
commit0c9c196d7c1317af7968aff12d27087b83a5326e (patch)
treee7701a655dcbc597d9655f5fc71e9e63333ed4c5 /app-portage
parentStable for HPPA (bug #295028). (diff)
downloadgentoo-2-0c9c196d7c1317af7968aff12d27087b83a5326e.tar.gz
gentoo-2-0c9c196d7c1317af7968aff12d27087b83a5326e.tar.bz2
gentoo-2-0c9c196d7c1317af7968aff12d27087b83a5326e.zip
Version bump to 2.1.0.
(Portage version: 2.2_rc56/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/mirrorselect/ChangeLog8
-rw-r--r--app-portage/mirrorselect/mirrorselect-2.1.0.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/app-portage/mirrorselect/ChangeLog b/app-portage/mirrorselect/ChangeLog
index a1fc29b62198..7bd1fdee7c11 100644
--- a/app-portage/mirrorselect/ChangeLog
+++ b/app-portage/mirrorselect/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/mirrorselect
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/mirrorselect/ChangeLog,v 1.87 2009/10/26 19:40:21 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/mirrorselect/ChangeLog,v 1.88 2009/12/08 04:53:44 idl0r Exp $
+
+*mirrorselect-2.1.0 (08 Dec 2009)
+
+ 08 Dec 2009; Christian Ruppert <idl0r@gentoo.org>
+ +mirrorselect-2.1.0.ebuild:
+ Version bump to 2.1.0.
26 Oct 2009; Christian Ruppert <idl0r@gentoo.org>
-mirrorselect-0.89.ebuild, -mirrorselect-1.1.7.ebuild,
diff --git a/app-portage/mirrorselect/mirrorselect-2.1.0.ebuild b/app-portage/mirrorselect/mirrorselect-2.1.0.ebuild
new file mode 100644
index 000000000000..f23e3547f51d
--- /dev/null
+++ b/app-portage/mirrorselect/mirrorselect-2.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/mirrorselect/mirrorselect-2.1.0.ebuild,v 1.1 2009/12/08 04:53:44 idl0r Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit python
+
+DESCRIPTION="Tool to help select distfiles mirrors for Gentoo"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-lang/python[xml]
+ dev-util/dialog
+ net-analyzer/netselect"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_install() {
+ newsbin main.py ${PN} || die
+
+ installation() {
+ insinto $(python_get_sitedir)
+ doins -r ${PN}/
+ }
+ python_execute_function installation
+
+ doman ${PN}.8 || die
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}