summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-08-31 09:13:52 +0000
committerMichał Górny <mgorny@gentoo.org>2012-08-31 09:13:52 +0000
commit0b2e9d4336281808f7d3c1f0cf2f6a33cf3046e1 (patch)
treedd19f0a9c3fb4f8b69a99f455f8bbc4a0fc2ba1e /app-portage
parentSync to the live ebuild (URIs), drop old. (diff)
downloadgentoo-2-0b2e9d4336281808f7d3c1f0cf2f6a33cf3046e1.tar.gz
gentoo-2-0b2e9d4336281808f7d3c1f0cf2f6a33cf3046e1.tar.bz2
gentoo-2-0b2e9d4336281808f7d3c1f0cf2f6a33cf3046e1.zip
Sync to the live ebuild.
(Portage version: 2.2.0_alpha120_p33/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/flaggie/ChangeLog9
-rw-r--r--app-portage/flaggie/flaggie-0.2-r1.ebuild (renamed from app-portage/flaggie/flaggie-0.1.4.ebuild)30
-rw-r--r--app-portage/flaggie/flaggie-0.2.ebuild6
-rw-r--r--app-portage/flaggie/metadata.xml2
4 files changed, 23 insertions, 24 deletions
diff --git a/app-portage/flaggie/ChangeLog b/app-portage/flaggie/ChangeLog
index 6bc89bb7f18e..c9a1b6999d5e 100644
--- a/app-portage/flaggie/ChangeLog
+++ b/app-portage/flaggie/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/flaggie
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/ChangeLog,v 1.31 2012/08/07 20:18:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/ChangeLog,v 1.32 2012/08/31 09:13:52 mgorny Exp $
+
+*flaggie-0.2-r1 (31 Aug 2012)
+
+ 31 Aug 2012; Michał Górny <mgorny@gentoo.org> +flaggie-0.2-r1.ebuild,
+ -flaggie-0.1.4.ebuild, flaggie-0.2.ebuild, metadata.xml:
+ Sync to the live ebuild.
07 Aug 2012; Alexis Ballier <aballier@gentoo.org> flaggie-0.2.ebuild:
keyword ~amd64-fbsd
@@ -151,4 +157,3 @@
07 Nov 2010; Michał Górny <mgorny@gentoo.org> +flaggie-0.0.1.ebuild,
+metadata.xml:
Introducing flaggie, a new CLI package.* file mangler.
-
diff --git a/app-portage/flaggie/flaggie-0.1.4.ebuild b/app-portage/flaggie/flaggie-0.2-r1.ebuild
index 07d1cfd5c2c1..54d950228631 100644
--- a/app-portage/flaggie/flaggie-0.1.4.ebuild
+++ b/app-portage/flaggie/flaggie-0.2-r1.ebuild
@@ -1,39 +1,33 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/flaggie-0.1.4.ebuild,v 1.6 2011/12/09 03:11:15 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/flaggie-0.2-r1.ebuild,v 1.1 2012/08/31 09:13:52 mgorny Exp $
-EAPI=3
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+EAPI=4
+PYTHON_COMPAT='python2_6 python2_7 python3_1 python3_2'
-inherit base bash-completion-r1 distutils
+inherit base bash-completion-r1 python-distutils-ng
DESCRIPTION="A smart CLI mangler for package.* files"
-HOMEPAGE="https://github.com/mgorny/flaggie/"
-SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
+HOMEPAGE="https://bitbucket.org/mgorny/flaggie/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm x86 ~x86-fbsd"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE=""
RDEPEND=">=sys-apps/portage-2.1.8.3"
-src_prepare() {
+python_prepare_all() {
base_src_prepare
- distutils_src_prepare
}
-src_install() {
- distutils_src_install
-
- newbashcomp contrib/bash-completion/${PN}.bash-completion ${PN} || die
+python_install_all() {
+ dodoc README
+ newbashcomp contrib/bash-completion/${PN}.bash-completion ${PN}
}
pkg_postinst() {
- distutils_pkg_postinst
-
ewarn "Please denote that flaggie creates backups of your package.* files"
ewarn "before performing each change through appending a single '~'."
ewarn "If you'd like to keep your own backup of them, please use another"
diff --git a/app-portage/flaggie/flaggie-0.2.ebuild b/app-portage/flaggie/flaggie-0.2.ebuild
index d442f5ec6f1b..3d64687f544f 100644
--- a/app-portage/flaggie/flaggie-0.2.ebuild
+++ b/app-portage/flaggie/flaggie-0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/flaggie-0.2.ebuild,v 1.6 2012/08/07 20:18:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/flaggie-0.2.ebuild,v 1.7 2012/08/31 09:13:52 mgorny Exp $
EAPI=4
PYTHON_DEPEND="2:2.6"
@@ -10,8 +10,8 @@ RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
inherit base bash-completion-r1 distutils
DESCRIPTION="A smart CLI mangler for package.* files"
-HOMEPAGE="https://github.com/mgorny/flaggie/"
-SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
+HOMEPAGE="https://bitbucket.org/mgorny/flaggie/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
diff --git a/app-portage/flaggie/metadata.xml b/app-portage/flaggie/metadata.xml
index 60239498d1e6..4b86c32186f1 100644
--- a/app-portage/flaggie/metadata.xml
+++ b/app-portage/flaggie/metadata.xml
@@ -10,6 +10,6 @@
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
- <bugs-to>https://github.com/mgorny/flaggie/issues/</bugs-to>
+ <bugs-to>https://bitbucket.org/mgorny/flaggie/issues/</bugs-to>
</upstream>
</pkgmetadata>