summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2012-11-19 00:01:48 +0000
committerBrian Dolbec <dolsen@gentoo.org>2012-11-19 00:01:48 +0000
commit0b0884b7593a55d16cc73372aed3c17a11b526dd (patch)
tree99fdd9f83f299684b36ed54d9f5c0fb3ab01b894 /app-portage
parentRemove overriding CFLAGS completely, bug 442644. (diff)
downloadgentoo-2-0b0884b7593a55d16cc73372aed3c17a11b526dd.tar.gz
gentoo-2-0b0884b7593a55d16cc73372aed3c17a11b526dd.tar.bz2
gentoo-2-0b0884b7593a55d16cc73372aed3c17a11b526dd.zip
New pkg pyGPG, ebuild by me
(Portage version: 2.2.0_alpha142_p10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/pyGPG/ChangeLog10
-rw-r--r--app-portage/pyGPG/Manifest3
-rw-r--r--app-portage/pyGPG/metadata.xml13
-rw-r--r--app-portage/pyGPG/pyGPG-9999.ebuild45
4 files changed, 71 insertions, 0 deletions
diff --git a/app-portage/pyGPG/ChangeLog b/app-portage/pyGPG/ChangeLog
new file mode 100644
index 000000000000..a012800e78e2
--- /dev/null
+++ b/app-portage/pyGPG/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-portage/pyGPG
+# Copyright 2012-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pyGPG/ChangeLog,v 1.1 2012/11/19 00:01:48 dolsen Exp $
+
+*pyGPG-9999 (18 Nov 2012)
+
+ 18 Nov 2012; Brian Dolbec <dolsen@gentoo.org> +pyGPG-9999.ebuild,
+ +metadata.xml:
+ Initial ebuild for pyGPG, written by me.
+
diff --git a/app-portage/pyGPG/Manifest b/app-portage/pyGPG/Manifest
new file mode 100644
index 000000000000..08d39c9eee4d
--- /dev/null
+++ b/app-portage/pyGPG/Manifest
@@ -0,0 +1,3 @@
+EBUILD pyGPG-9999.ebuild 935 SHA256 63ba6cda9b460a320d0a0ebd93a3b762fc8bdb78790a34991ce15b01ddddb705 SHA512 8bfbe2fbbb96bbe00cf852225ba4da513975791384dcdbb3a7d5609ec6aadc16c5b853e24ff73cc5a5fea0271dc442d8b0b55e286611b2d0ab80bce26730aea0 WHIRLPOOL c6af83c2c0943d401a5b3388f9d18814f8e308287306e106f4eb551e4b39256aa89b7e944fb20c51c70151b5c62d47eecf508526615d0171c7d2f57ddf1c7bb0
+MISC ChangeLog 274 SHA256 9cd151122ee006a2b77c40e57019f02f94ff0492722164214367b0c531cd6324 SHA512 127d03a7d2b3ff394cc870fb43b1980fb9fb17a0b882a64fb23e13f20860610965c3c0034f5fe7b83ee2176c96843853c6a97470ee6629ee364db6cc465b36bc WHIRLPOOL 0a08bf598bcde96fea9cf251bab66dc0034d432d5bad11153dba73384e457c6e813e847ec67daac4f10f33838c6c955596913840ef56db3752743f471836a945
+MISC metadata.xml 481 SHA256 09020a8c3bd6bfdaa05d879c318e83d5740c5d873f2b4c8c9988023d5ed7a61b SHA512 f8876a25bb319e145d8c3c13aa99cfa1698fd00b2f28d231cbd35821a00f7133c4a8ef90afcc973d65813a70aaf2e91ce9231a2d63e9f45b3fb1510f0b19bf5a WHIRLPOOL 4fc1c5a25baa43463273b921eaaaa92cdf65e6381bf32f1e694284236fc308142dcb624f81804ea6258dcf3d0fb94b0d54481c3e9e42a3d110c3564171ce9b3d
diff --git a/app-portage/pyGPG/metadata.xml b/app-portage/pyGPG/metadata.xml
new file mode 100644
index 000000000000..af0db5622635
--- /dev/null
+++ b/app-portage/pyGPG/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tools-portage</herd>
+ <maintainer>
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
+ </maintainer>
+ <longdescription>A python interface library for wrapping gnupg's gpg command.
+ It also connects to gpg's status-fd output and makes all the status data
+ available as subclassed namedtuple instances.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-portage/pyGPG/pyGPG-9999.ebuild b/app-portage/pyGPG/pyGPG-9999.ebuild
new file mode 100644
index 000000000000..1df02afc5a70
--- /dev/null
+++ b/app-portage/pyGPG/pyGPG-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/pyGPG/pyGPG-9999.ebuild,v 1.1 2012/11/19 00:01:48 dolsen Exp $
+
+EAPI="4"
+
+PYTHON_COMPAT=(python{2_5,2_6,2_7})
+
+EGIT_MASTER="pyGPG"
+EGIT_BRANCH="master"
+
+inherit distutils-r1 python-r1 git-2
+
+EGIT_REPO_URI="git://github.com/dol-sen/pyGPG.git"
+
+DESCRIPTION="A python interface wrapper for gnupg's gpg command"
+HOMEPAGE="https://github.com/dol-sen/pyGPG"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+KEYWORDS=""
+
+DEPEND =""
+RDEPEND="${DEPEND}
+ >=app-crypt/gnupg-2.0.0
+ "
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/pyGPG/issues"
+ einfo "I am also on IRC @ #porthole of the freenode network"
+ einfo
+}