summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2010-05-11 21:43:20 +0000
committerChristian Ruppert <idl0r@gentoo.org>2010-05-11 21:43:20 +0000
commit059cefaa5ddb42711aac0aba32942e255fcc6169 (patch)
tree74e76860ebde32848a964cfcb09c69d26d024987 /app-portage
parentstable ppc64, bug 317141 (diff)
downloadgentoo-2-059cefaa5ddb42711aac0aba32942e255fcc6169.tar.gz
gentoo-2-059cefaa5ddb42711aac0aba32942e255fcc6169.tar.bz2
gentoo-2-059cefaa5ddb42711aac0aba32942e255fcc6169.zip
Version bump to 0.14.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/portato/ChangeLog8
-rw-r--r--app-portage/portato/metadata.xml25
-rw-r--r--app-portage/portato/portato-0.14.ebuild141
3 files changed, 161 insertions, 13 deletions
diff --git a/app-portage/portato/ChangeLog b/app-portage/portato/ChangeLog
index 6db7f1f31e58..2c00fbaea211 100644
--- a/app-portage/portato/ChangeLog
+++ b/app-portage/portato/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/portato
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/portato/ChangeLog,v 1.25 2010/04/13 14:02:48 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portato/ChangeLog,v 1.26 2010/05/11 21:43:20 idl0r Exp $
+
+*portato-0.14 (11 May 2010)
+
+ 11 May 2010; Christian Ruppert <idl0r@gentoo.org> +portato-0.14.ebuild,
+ metadata.xml:
+ Version bump to 0.14.
*portato-0.13.1-r1 (13 Apr 2010)
diff --git a/app-portage/portato/metadata.xml b/app-portage/portato/metadata.xml
index 8932070e8937..8f203a761ae5 100644
--- a/app-portage/portato/metadata.xml
+++ b/app-portage/portato/metadata.xml
@@ -1,16 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>tools-portage</herd>
-<maintainer>
- <email>jokey@gentoo.org</email>
- <name>Markus Ullmann</name>
-</maintainer>
-<maintainer>
- <email>gentoo@necoro.eu</email>
- <name>René Neumann</name>
-</maintainer>
-<use>
- <flag name='userpriv'>Allow emerge processes as normal user</flag>
-</use>
+ <herd>tools-portage</herd>
+ <maintainer>
+ <email>jokey@gentoo.org</email>
+ <name>Markus Ullmann</name>
+ </maintainer>
+ <maintainer>
+ <email>gentoo@necoro.eu</email>
+ <name>René Neumann</name>
+ </maintainer>
+ <use>
+ <flag name="eix">Enable eix support</flag>
+ <flag name="userpriv">Allow emerge processes as normal user</flag>
+ </use>
</pkgmetadata>
diff --git a/app-portage/portato/portato-0.14.ebuild b/app-portage/portato/portato-0.14.ebuild
new file mode 100644
index 000000000000..be556ca3b0c4
--- /dev/null
+++ b/app-portage/portato/portato-0.14.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/portato/portato-0.14.ebuild,v 1.1 2010/05/11 21:43:20 idl0r Exp $
+
+EAPI="2"
+
+inherit python eutils distutils
+
+DESCRIPTION="A GUI for Portage written in Python"
+HOMEPAGE="http://necoro.eu/portato"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+eix kde libnotify nls +sqlite userpriv"
+LANGS="ca de es fr it pl pt_BR tr"
+for X in $LANGS; do IUSE="${IUSE} linguas_${X}"; done
+
+COMMON_DEPEND="|| (
+ dev-lang/python:2.7[sqlite?,threads]
+ dev-lang/python:2.6[sqlite?,threads] )"
+
+RDEPEND="$COMMON_DEPEND
+ app-portage/portage-utils
+ x11-libs/vte[python]
+ >=dev-python/pygtk-2.14.0
+ dev-python/pygtksourceview:2
+ >=sys-apps/portage-2.1.7.17
+
+ kde? ( kde-base/kdesu )
+ !kde? ( || ( x11-misc/ktsuss x11-libs/gksu ) )
+ libnotify? ( dev-python/notify-python )
+ nls? ( virtual/libintl )
+ eix? ( >=app-portage/eix-0.15.4 )"
+
+DEPEND="$COMMON_DEPEND
+ nls? ( sys-devel/gettext )"
+
+# filled later on
+PLUGIN_DIR=""
+
+pkg_setup()
+{
+ python_set_active_version 2
+
+ if use eix && ! use sqlite; then
+ ewarn "You have enabled 'eix' but not 'sqlite'!"
+ ewarn "eix-support depends on sqlite, so it will be disabled as well."
+ fi
+}
+
+src_configure ()
+{
+ # set this before changing ROOT_DIR
+ # else it would include $ROOT -- which would be plusungood
+ PLUGIN_DIR=$(./portato.py --plugin-dir)
+
+ sed -i -e "s;^\(ROOT_DIR\s*=\s*\).*;\1\"${ROOT}\";" portato/constants.py || die "sed failed"
+
+ if use userpriv; then
+ sed -i -e "s/Exec=.*/Exec=portato --no-fork/" portato.desktop || die "sed failed"
+ fi
+
+ # change configured db-type depending on useflags
+ local dbtype="dict"
+
+ if use sqlite; then
+ if use eix; then
+ dbtype="eixsql"
+ else
+ dbtype="sql"
+ fi
+ fi
+
+ sed -i -e "s;^\(type\s*=\s*\).*;\1${dbtype};" etc/portato.cfg || die "sed failed"
+}
+
+src_compile ()
+{
+ if use nls; then
+ ./pocompile.sh -emerge ${LINGUAS} || die "pocompile failed"
+ fi
+
+ if ! use eix || ! use sqlite; then
+ distutils_src_compile --disable-eix
+ else
+ distutils_src_compile
+ fi
+}
+
+src_install ()
+{
+ if ! use eix || ! use sqlite; then
+ distutils_src_install --disable-eix
+ else
+ distutils_src_install
+ fi
+
+ newbin portato.py portato || die "newbin failed"
+ dodoc doc/* || die "dodoc failed"
+
+ # config
+ insinto /etc
+ doins etc/* || die "installing config files failed"
+
+ # desktop
+ doicon icons/portato-icon.png || die "doicon failed"
+ domenu portato.desktop || die "domenu failed"
+
+ # nls
+ if use nls && [ -d i18n/mo ]; then
+ domo i18n/mo/*
+ fi
+
+ # man page
+ doman portato.1
+}
+
+pkg_postinst ()
+{
+ distutils_pkg_postinst
+ python_mod_optimize "${PLUGIN_DIR}"
+
+ if use eix && use sqlite; then
+ einfo
+ elog "If you are using eix-remote there is no guarantee,"
+ elog "that portato will work as expected with the eixsql database."
+ elog "If in doubt, change back to sql."
+ fi
+}
+
+pkg_postrm ()
+{
+ distutils_pkg_postrm
+ python_mod_cleanup "${PLUGIN_DIR}"
+
+ # try to remove the DATA_DIR, as it may still exist
+ # reason: it was tried to remove it before plugin stuff was purged
+ rmdir "${ROOT}"$(dirname ${PLUGIN_DIR}) 2> /dev/null
+} \ No newline at end of file