summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-25 16:28:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-25 16:28:43 +0000
commitefe060f2326231e362afa1e0720562d532442f14 (patch)
tree61e4b3cd122f0945356e1ee64a2efeae8593e630 /app-pda
parentStable for HPPA (bug #350915). (diff)
downloadgentoo-2-efe060f2326231e362afa1e0720562d532442f14.tar.gz
gentoo-2-efe060f2326231e362afa1e0720562d532442f14.tar.bz2
gentoo-2-efe060f2326231e362afa1e0720562d532442f14.zip
Improve prev. commit
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/synce-sync-engine/synce-sync-engine-0.15.1.ebuild19
1 files changed, 17 insertions, 2 deletions
diff --git a/app-pda/synce-sync-engine/synce-sync-engine-0.15.1.ebuild b/app-pda/synce-sync-engine/synce-sync-engine-0.15.1.ebuild
index 51c5da49f75e..f1eb07eff304 100644
--- a/app-pda/synce-sync-engine/synce-sync-engine-0.15.1.ebuild
+++ b/app-pda/synce-sync-engine/synce-sync-engine-0.15.1.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/synce-sync-engine-0.15.1.ebuild,v 1.1 2011/02/25 16:09:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/synce-sync-engine-0.15.1.ebuild,v 1.2 2011/02/25 16:28:43 ssuominen Exp $
+
+# TODO:
+# Figure out synce-opensync-plugin-2x.py and synce-opensync-plugin-3x.py install path when libopensync is unmasked.
EAPI=3
@@ -29,6 +32,18 @@ DEPEND="${RDEPEND}"
PYTHON_MODNAME="plugins SyncEngine"
src_prepare() {
- sed -i -e "s:share/doc/sync-engine:share/doc/${PF}:" setup.py || die
+ sed -i -e 's:share/doc/sync-engine:tmp:' setup.py || die
distutils_src_prepare
}
+
+src_install() {
+ insinto /usr/share/dbus-1/services
+ doins config/org.synce.SyncEngine.service || die
+
+ insinto /usr/share/${PN}
+ doins config/syncengine.conf.xml || die
+
+ distutils_src_install
+
+ rm -rf "${D}"/tmp
+}