summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2007-01-08 16:31:52 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2007-01-08 16:31:52 +0000
commite93c6ed99592a38bc17c48912052c7d6ac1d955a (patch)
tree9adcda926a048d5d6a1b788ff186c48f911942e5 /app-pda
parentremove patches (diff)
downloadgentoo-2-e93c6ed99592a38bc17c48912052c7d6ac1d955a.tar.gz
gentoo-2-e93c6ed99592a38bc17c48912052c7d6ac1d955a.tar.bz2
gentoo-2-e93c6ed99592a38bc17c48912052c7d6ac1d955a.zip
Add pkg_setup() to check whether the USE flags are sane.
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libsyncml/ChangeLog8
-rw-r--r--app-pda/libsyncml/libsyncml-0.4.2-r1.ebuild28
2 files changed, 32 insertions, 4 deletions
diff --git a/app-pda/libsyncml/ChangeLog b/app-pda/libsyncml/ChangeLog
index bc3bc469bb41..d33bc77efdb1 100644
--- a/app-pda/libsyncml/ChangeLog
+++ b/app-pda/libsyncml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/libsyncml
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.2 2006/11/25 10:44:26 peper Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.3 2007/01/08 16:31:52 peper Exp $
+
+ 08 Jan 2007; Piotr Jaroszyński <peper@gentoo.org>
+ libsyncml-0.4.2-r1.ebuild:
+ Add pkg_setup() to check whether the USE flags are sane.
*libsyncml-0.4.2-r1 (25 Nov 2006)
diff --git a/app-pda/libsyncml/libsyncml-0.4.2-r1.ebuild b/app-pda/libsyncml/libsyncml-0.4.2-r1.ebuild
index e330572233fd..0bf6610842bd 100644
--- a/app-pda/libsyncml/libsyncml-0.4.2-r1.ebuild
+++ b/app-pda/libsyncml/libsyncml-0.4.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-0.4.2-r1.ebuild,v 1.1 2006/11/25 10:44:26 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-0.4.2-r1.ebuild,v 1.2 2007/01/08 16:31:52 peper Exp $
inherit eutils
@@ -28,6 +28,30 @@ DEPEND="${RDEPEND}
# Some of the tests are broken
RESTRICT="test"
+pkg_setup() {
+ if ! use obex && ! use http; then
+ eerror "${CATEGORY}/${P} without support for obex nor http is unusable."
+ einfo "Please enable \"obex\" or/and \"http\" USE flags."
+ die "Please enable \"obex\" or/and \"http\" USE flags."
+ fi
+
+ if use bluetooth; then
+ if use obex && ! built_with_use dev-libs/openobex bluetooth; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"bluetooth\""
+ eerror "and \"obex\" USE flags, but dev-libs/openobex was built without"
+ eerror "the \"bluetooth\" USE flag."
+ einfo "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
+ die "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
+ elif ! use obex; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"bluetooth\""
+ eerror "USE flag, but you didn't enable the \"obex\" flag, which is"
+ eerror "needed for bluetooth support."
+ einfo "Please enable \"obex\" USE flag."
+ die "Please enable \"obex\" USE flag."
+ fi
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"