summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-04-27 19:31:46 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-04-27 19:31:46 +0000
commitdc65eebe3a7de583ce6524ae6804e7e250f3120e (patch)
treedab9db8dcdf69bece1e2a3653b4b78f20f9a8153 /app-pda
parentAdd a fix for GCC 4.3 (bug #218727). (diff)
downloadgentoo-2-dc65eebe3a7de583ce6524ae6804e7e250f3120e.tar.gz
gentoo-2-dc65eebe3a7de583ce6524ae6804e7e250f3120e.tar.bz2
gentoo-2-dc65eebe3a7de583ce6524ae6804e7e250f3120e.zip
updated for bug #218711, plus freedesktop update
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/qtopia-desktop-bin/ChangeLog8
-rw-r--r--app-pda/qtopia-desktop-bin/qtopia-desktop-bin-2.2.0.ebuild41
2 files changed, 34 insertions, 15 deletions
diff --git a/app-pda/qtopia-desktop-bin/ChangeLog b/app-pda/qtopia-desktop-bin/ChangeLog
index 667c36e5b83e..68770fdb2d18 100644
--- a/app-pda/qtopia-desktop-bin/ChangeLog
+++ b/app-pda/qtopia-desktop-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/qtopia-desktop-bin
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/qtopia-desktop-bin/ChangeLog,v 1.15 2007/07/22 10:12:43 calchan Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/qtopia-desktop-bin/ChangeLog,v 1.16 2008/04/27 19:31:46 nerdboy Exp $
+
+ 27 Apr 2008; Steve Arnold <nerdboy@gentoo.org>
+ qtopia-desktop-bin-2.2.0.ebuild:
+ updated for bug #218711, plus freedesktop update
22 Jul 2007; Denis Dupeyron <calchan@gentoo.org>
qtopia-desktop-bin-2.2.0.ebuild:
diff --git a/app-pda/qtopia-desktop-bin/qtopia-desktop-bin-2.2.0.ebuild b/app-pda/qtopia-desktop-bin/qtopia-desktop-bin-2.2.0.ebuild
index 0665656e32b1..2968eeaff1cd 100644
--- a/app-pda/qtopia-desktop-bin/qtopia-desktop-bin-2.2.0.ebuild
+++ b/app-pda/qtopia-desktop-bin/qtopia-desktop-bin-2.2.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/qtopia-desktop-bin/qtopia-desktop-bin-2.2.0.ebuild,v 1.5 2007/07/22 10:12:43 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/qtopia-desktop-bin/qtopia-desktop-bin-2.2.0.ebuild,v 1.6 2008/04/27 19:31:46 nerdboy Exp $
-inherit eutils rpm multilib
+inherit eutils fdo-mime rpm multilib
REV="1"
QD="/opt/QtopiaDesktop"
@@ -40,31 +40,41 @@ src_install() {
dodir ${QD}
# Too many subdirs and files for individual ebuild commands
# Isn't there a better way?
- cp -a ${S}/${QD}/qtopiadesktop ${D}${QD}
+ cp -a "${S}/${QD}"/qtopiadesktop "${D}${QD}"
local libdir="lib32"
if has_multilib_profile ; then
libdir=$(get_abi_LIBDIR x86)
fi
+
into ${QD}
- dolib.so ${S}/${QD}/lib/lib*
- rm -f ${S}/${QD}/lib/*.prl
+ dolib.so "${S}/${QD}"/lib/lib*
+ rm -f "${S}/${QD}"/lib/*.prl
exeinto ${QD}/bin
- doexe ${S}/${QD}/bin/*
+ doexe "${S}/${QD}"/bin/*
docinto /usr/share/doc/${P}
- dodoc ${S}/${QD}/LICENSE.US
- dodoc ${S}/${QD}/README.html
- dodoc ${FILESDIR}/usb0.conf
- rm -f ${S}/${QD}/LICENSE*
+ dodoc "${S}/${QD}"/LICENSE.US
+ dodoc "${S}/${QD}"/README.html
+ dodoc "${FILESDIR}"/usb0.conf
+ rm -f "${S}/${QD}"/LICENSE*
+
echo "PATH=${QD}/bin" > 37qtopia-desktop-bin
echo "LDPATH=${QD}/${libdir}" >> 37qtopia-desktop-bin
doenvd 37qtopia-desktop-bin
+
+ make_desktop_entry \
+ /opt/QtopiaDesktop/bin/qtopiadesktop \
+ "Qtopia Desktop ${PV}" \
+ "/opt/QtopiaDesktop/qtopiadesktop/pics/qtopia.png" \
+ "Application;Office;ContactManagement;"
}
pkg_postinst() {
+ fdo-mime_desktop_database_update
+
elog " Finished installing Qtopia Desktop ${PV}-${REV} into ${QD}"
elog
- elog " To start Qtopia Desktop, run:"
- elog " $ qtopiadesktop"
+ elog " To start Qtopia Desktop, use the new desktop menu, or run"
+ elog " qtopiadesktop from a terminal prompt."
elog
elog "See the usb0.conf file for a static network configuration for the"
elog "Zaurus cradle interface (it works with an SL-5x00). Note the old"
@@ -74,3 +84,8 @@ pkg_postinst() {
elog "(such as above) running OZ with kernel 2.4.x."
elog
}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
+