summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-13 13:49:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-13 13:49:28 +0000
commitd6d04e08ca71ade458a4e55130252d198811130f (patch)
tree17ec3b5b1c94480736efaf102340d27528167215 /app-pda
parentx86 stable, bug 327777 (diff)
downloadgentoo-2-d6d04e08ca71ade458a4e55130252d198811130f.tar.gz
gentoo-2-d6d04e08ca71ade458a4e55130252d198811130f.tar.bz2
gentoo-2-d6d04e08ca71ade458a4e55130252d198811130f.zip
Version bump wrt #321427 by Thomas Beierlein. Fix missing pkg-config DEPEND wrt #240390 by Evil Compile Person.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/jpilot-backup/ChangeLog11
-rw-r--r--app-pda/jpilot-backup/jpilot-backup-0.60.ebuild38
2 files changed, 47 insertions, 2 deletions
diff --git a/app-pda/jpilot-backup/ChangeLog b/app-pda/jpilot-backup/ChangeLog
index 4dc2e8c7e9d3..5986f05d392f 100644
--- a/app-pda/jpilot-backup/ChangeLog
+++ b/app-pda/jpilot-backup/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-pda/jpilot-backup
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot-backup/ChangeLog,v 1.14 2008/03/15 21:22:31 dertobi123 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot-backup/ChangeLog,v 1.15 2010/07/13 13:49:28 ssuominen Exp $
+
+*jpilot-backup-0.60 (13 Jul 2010)
+
+ 13 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +jpilot-backup-0.60.ebuild:
+ Version bump wrt #321427 by Thomas Beierlein. Fix missing pkg-config
+ DEPEND wrt #240390 by Evil Compile Person.
15 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
jpilot-backup-0.53.ebuild:
diff --git a/app-pda/jpilot-backup/jpilot-backup-0.60.ebuild b/app-pda/jpilot-backup/jpilot-backup-0.60.ebuild
new file mode 100644
index 000000000000..51fbe36d87ef
--- /dev/null
+++ b/app-pda/jpilot-backup/jpilot-backup-0.60.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot-backup/jpilot-backup-0.60.ebuild,v 1.1 2010/07/13 13:49:28 ssuominen Exp $
+
+EAPI=2
+inherit multilib
+
+DESCRIPTION="Backup plugin for jpilot"
+HOMEPAGE="http://www.jlogday.com/code/jpilot-backup/index.html"
+SRC_URI="http://www.jlogday.com/code/jpilot-backup/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.18.9
+ >=app-pda/pilot-link-0.12.3
+ >=app-pda/jpilot-0.99.9
+ sys-libs/gdbm"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-gtk2
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ libdir="/usr/$(get_libdir)/jpilot/plugins" \
+ install || die
+
+ dodoc ChangeLog CREDITS README* TODO
+
+ find "${D}" -name '*.la' -delete
+}