summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Lauwers <blauwers@gentoo.org>2002-12-17 22:52:39 +0000
committerBart Lauwers <blauwers@gentoo.org>2002-12-17 22:52:39 +0000
commitd0fcf44bd8f87438db38e78a142f5692f47ed099 (patch)
tree761179013a5a7df14c14b28c9c5b7c83778295cc /app-pda
parent*** empty log message *** (diff)
downloadgentoo-2-d0fcf44bd8f87438db38e78a142f5692f47ed099.tar.gz
gentoo-2-d0fcf44bd8f87438db38e78a142f5692f47ed099.tar.bz2
gentoo-2-d0fcf44bd8f87438db38e78a142f5692f47ed099.zip
Initial submission per Bug#9820
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/plptools/ChangeLog9
-rw-r--r--app-pda/plptools/files/digest-plptools-0.111
-rw-r--r--app-pda/plptools/files/plptools-0.11-gentoo.patch12
-rw-r--r--app-pda/plptools/files/psion54
-rw-r--r--app-pda/plptools/files/psion.conf6
-rw-r--r--app-pda/plptools/plptools-0.11.ebuild35
6 files changed, 117 insertions, 0 deletions
diff --git a/app-pda/plptools/ChangeLog b/app-pda/plptools/ChangeLog
new file mode 100644
index 000000000000..705eb9023765
--- /dev/null
+++ b/app-pda/plptools/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-pda/plptools
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+
+*plptools-0.11.ebuild (17 Dec 2002)
+
+ 17 Dec 2002; B.Lauwers <blauwers@gentoo.org> :
+ Initial release. Set of libraries and utilities to communicate with a Psion
+ palmtop over a serial line. Ebuild submitted by Stas Gobunov <left@komus.net>
+
diff --git a/app-pda/plptools/files/digest-plptools-0.11 b/app-pda/plptools/files/digest-plptools-0.11
new file mode 100644
index 000000000000..7b1404878c5e
--- /dev/null
+++ b/app-pda/plptools/files/digest-plptools-0.11
@@ -0,0 +1 @@
+MD5 425f792a3c3598d2b1d4a51cb3ec5960 plptools-0.11.tar.gz 989279
diff --git a/app-pda/plptools/files/plptools-0.11-gentoo.patch b/app-pda/plptools/files/plptools-0.11-gentoo.patch
new file mode 100644
index 000000000000..83277b76e94f
--- /dev/null
+++ b/app-pda/plptools/files/plptools-0.11-gentoo.patch
@@ -0,0 +1,12 @@
+diff -urN plptools-0.11/lib/psitime.h plptools-0.11-new/lib/psitime.h
+--- plptools-0.11/lib/psitime.h 2002-07-14 10:35:33.000000000 +0400
++++ plptools-0.11-new/lib/psitime.h 2002-10-27 12:39:53.000000000 +0300
+@@ -142,7 +142,7 @@
+ * @param _utv A Unix time value for initialization.
+ * @param _utz A Unix timezone for initialization.
+ */
+- PsiTime(struct timeval *_utv, struct timezone *_utz = 0L);
++ PsiTime(struct timeval *_utv, struct timezone *_utz);
+
+ /**
+ * Contructs a new instance. \ No newline at end of file
diff --git a/app-pda/plptools/files/psion b/app-pda/plptools/files/psion
new file mode 100644
index 000000000000..60e4b8bd3f7d
--- /dev/null
+++ b/app-pda/plptools/files/psion
@@ -0,0 +1,54 @@
+#!/sbin/runscript
+
+#NB: Config is in /etc/conf.d/psion
+
+depend() {
+ use logger
+}
+
+start() {
+ ebegin "Starting Psion Services"
+ if test "$START_NCPD" = "yes" ; then
+ ebegin " ncpd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/ncpd \
+ -- ${NCPD_ARGS} 1>&2
+ eend
+ if [ "$?" -eq 0 ]
+ then
+ if test "$START_PLPNFSD" = "yes" ; then
+ ebegin " plpnfsd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/plpnfsd \
+ -- ${PLPNFSD_ARGS} 1>&2
+ eend
+ fi
+ if test "$START_PLPPRINTD" = "yes" ; then
+ ebegin " plpprintd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/plpprintd \
+ -- ${PLPPRINTD_ARGS} 1>&2
+ eend
+ fi
+ fi
+ fi
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Psion Services"
+ if test "$START_PLPPRINTD" = "yes" ; then
+ ebegin " plpprintd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/plpprintd
+ eend
+ fi
+ if test "$START_PLPNFSD" = "yes" ; then
+ ebegin " plpnfsd"
+ echo stop > /mnt/psion/proc/exit
+ eend
+ fi
+ if test "$START_NCPD" = "yes" ; then
+ ebegin " ncpd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ncpd
+ eend
+ fi
+ eend $?
+}
+
diff --git a/app-pda/plptools/files/psion.conf b/app-pda/plptools/files/psion.conf
new file mode 100644
index 000000000000..34d49d9439a7
--- /dev/null
+++ b/app-pda/plptools/files/psion.conf
@@ -0,0 +1,6 @@
+START_NCPD=yes
+NCPD_ARGS=
+START_PLPNFSD=yes
+PLPNFSD_ARGS=
+START_PLPPRINTD=yes
+PLPPRINTD_ARGS=
diff --git a/app-pda/plptools/plptools-0.11.ebuild b/app-pda/plptools/plptools-0.11.ebuild
new file mode 100644
index 000000000000..ee11a75f7be6
--- /dev/null
+++ b/app-pda/plptools/plptools-0.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Libraries and utilities to communicate with a Psion palmtop via serial."
+HOMEPAGE="http://plptools.sourceforge.net"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/plptools/${P}.tar.gz"
+LICENSE="as-is"
+
+SLOT="0"
+KEYWORDS="x86"
+DEPEND="virtual/glibc"
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ patch -p0 < ${FILESDIR}/${P}-gentoo.patch | die "Patch failed!"
+
+ local myconf
+
+ myconf="${myconf} --disable-kde"
+
+ ./configure ${myconf} --prefix=/usr || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc CHANGES README TODO
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/psion.conf psion
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/psion
+}