summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-05-11 21:39:26 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-05-11 21:39:26 +0000
commit7a8841f1e1409fe446e203d7dec704251dc13cb6 (patch)
tree98036604bb82ef1dabf8c47d755337292a6cf7ca /app-pda
parentversion bump wrt #469488 (diff)
downloadgentoo-2-7a8841f1e1409fe446e203d7dec704251dc13cb6.tar.gz
gentoo-2-7a8841f1e1409fe446e203d7dec704251dc13cb6.tar.bz2
gentoo-2-7a8841f1e1409fe446e203d7dec704251dc13cb6.zip
Version bump.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libplist/ChangeLog7
-rw-r--r--app-pda/libplist/libplist-1.10.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/app-pda/libplist/ChangeLog b/app-pda/libplist/ChangeLog
index c5d1f5e64688..d193bbdb20ab 100644
--- a/app-pda/libplist/ChangeLog
+++ b/app-pda/libplist/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/libplist
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libplist/ChangeLog,v 1.31 2013/05/10 07:43:52 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libplist/ChangeLog,v 1.32 2013/05/11 21:39:26 ssuominen Exp $
+
+*libplist-1.10 (11 May 2013)
+
+ 11 May 2013; Samuli Suominen <ssuominen@gentoo.org> +libplist-1.10.ebuild:
+ Version bump.
10 May 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Remove unused flag description from metadata
diff --git a/app-pda/libplist/libplist-1.10.ebuild b/app-pda/libplist/libplist-1.10.ebuild
new file mode 100644
index 000000000000..25d65aed35a3
--- /dev/null
+++ b/app-pda/libplist/libplist-1.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libplist/libplist-1.10.ebuild,v 1.1 2013/05/11 21:39:26 ssuominen Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit cmake-utils python-r1
+
+DESCRIPTION="Support library to deal with Apple Property Lists (Binary & XML)"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+IUSE="python"
+
+RDEPEND="dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/cython-0.14.1-r1[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS NEWS README )
+
+MAKEOPTS+=" -j1" #406365
+
+src_configure() {
+ use python && python_export_best
+
+ # Use cython instead of swig to match behavior of libimobiledevice >= 1.1.2
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=ON
+ $(cmake-utils_use_enable python CYTHON)
+ -DENABLE_SWIG=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd "${CMAKE_BUILD_DIR}"
+
+ local testfile
+ for testfile in "${S}"/test/data/*; do
+ LD_LIBRARY_PATH=src ./test/plist_test "${testfile}" || die
+ done
+}