summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-08-23 10:53:17 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-08-23 10:53:17 +0000
commit5dbc86f6575b262e7ffa5e898674b1ad47b7adc9 (patch)
treeeb1ca9a1507496120a5e621aa80d555be0add273 /app-pda
parentVersion bump #231440 by Pacho Ramos, Robert A., Marcus D. Hanwell, and Paul H... (diff)
downloadgentoo-2-5dbc86f6575b262e7ffa5e898674b1ad47b7adc9.tar.gz
gentoo-2-5dbc86f6575b262e7ffa5e898674b1ad47b7adc9.tar.bz2
gentoo-2-5dbc86f6575b262e7ffa5e898674b1ad47b7adc9.zip
Fix bug #282354, applet did not appear into panel due to missing call to gnome_program_init(). Patch import from upstream bug #584894
(Portage version: 2.2_rc39/cvs/Linux x86_64)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/gnome-pilot/ChangeLog9
-rw-r--r--app-pda/gnome-pilot/files/gnome-pilot-2.0.17-invisible-applet.patch112
-rw-r--r--app-pda/gnome-pilot/gnome-pilot-2.0.17-r1.ebuild67
3 files changed, 187 insertions, 1 deletions
diff --git a/app-pda/gnome-pilot/ChangeLog b/app-pda/gnome-pilot/ChangeLog
index 728ced0bb27e..691521d1159d 100644
--- a/app-pda/gnome-pilot/ChangeLog
+++ b/app-pda/gnome-pilot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-pda/gnome-pilot
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/ChangeLog,v 1.55 2009/06/02 17:13:08 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/ChangeLog,v 1.56 2009/08/23 10:53:17 mrpouet Exp $
+
+*gnome-pilot-2.0.17-r1 (23 Aug 2009)
+
+ 23 Aug 2009; Romain Perier <mrpouet@gentoo.org>
+ +gnome-pilot-2.0.17-r1.ebuild, +files/gnome-pilot-2.0.17-invisible-applet.patch:
+ Fix bug #282354, applet did not appear into panel due to missing call to
+ gnome_program_init(). Patch import from upstream bug #584894.
02 Jun 2009; Raúl Porcel <armin76@gentoo.org> gnome-pilot-2.0.17.ebuild:
sparc stable wrt #266662
diff --git a/app-pda/gnome-pilot/files/gnome-pilot-2.0.17-invisible-applet.patch b/app-pda/gnome-pilot/files/gnome-pilot-2.0.17-invisible-applet.patch
new file mode 100644
index 000000000000..131b67424770
--- /dev/null
+++ b/app-pda/gnome-pilot/files/gnome-pilot-2.0.17-invisible-applet.patch
@@ -0,0 +1,112 @@
+From d1c148903394634a69fb978fc214a18d006c8f7a Mon Sep 17 00:00:00 2001
+From: Matt Davey <mcdavey@mrao.cam.ac.uk>
+Date: Thu, 06 Aug 2009 19:12:56 +0000
+Subject: 2009-08-06 Matt Davey <mcdavey@mrao.cam.ac.uk>
+
+ * applet/pilot.c: Fix for bug #584894. gnome panel-applet code
+ was changed in gnome-2.25 and now it does not call
+ gnome_program_init, which the gnome-pilot applet code assumed
+---
+diff --git a/applet/pilot.c b/applet/pilot.c
+index 9ca8453..0e07585 100644
+--- a/applet/pilot.c
++++ b/applet/pilot.c
+@@ -29,7 +29,7 @@
+ #include <errno.h>
+ #include <gnome.h>
+ #include <glade/glade.h>
+-#include <libgnomeui/gnome-window-icon.h>
++#include <gtk/gtk.h>
+ #include <panel-applet-gconf.h>
+
+ #include <signal.h>
+@@ -59,6 +59,7 @@ typedef struct {
+
+ typedef enum { INITIALISING, PAUSED, CONNECTING_TO_DAEMON, SYNCING, WAITING, NUM_STATES } state;
+
++
+ char *pixmaps[] =
+ {
+ GNOME_ICONDIR "/sync_broken.png",
+@@ -131,6 +132,7 @@ gpilotd_connect_cb (GnomePilotClient *client,
+ {
+ GdkColormap *colormap;
+ gchar *buf;
++ GError *error;
+ PilotApplet *applet = PILOT_APPLET (user_data);
+
+ gtk_tooltips_set_tip (applet->tooltips, GTK_WIDGET(applet->applet),
+@@ -146,8 +148,8 @@ gpilotd_connect_cb (GnomePilotClient *client,
+ if (applet->properties.popups == FALSE) return;
+
+ if (applet->progressDialog == NULL) {
+- gnome_window_icon_set_default_from_file (
+- GNOME_ICONDIR "/sync_icon.png");
++ gtk_window_set_default_icon_from_file (
++ GNOME_ICONDIR "/sync_icon.png", &error);
+ GladeXML *xml = glade_xml_new (applet->glade_file,"ProgressDialog",NULL);
+ applet->progressDialog = glade_xml_get_widget (xml,"ProgressDialog");
+ applet->sync_label = glade_xml_get_widget (xml,"sync_label");
+@@ -427,7 +429,10 @@ handle_client_error (PilotApplet *self)
+
+ static void
+ about_cb(BonoboUIComponent *uic, PilotApplet *pilot, const gchar *verbname)
++
+ {
++ GError *error;
++
+ GtkWidget *about;
+ const gchar *authors[] = {"Vadim Strizhevsky <vadim@optonline.net>",
+ "Eskil Heyn Olsen, <eskil@eskil.dk>",
+@@ -437,8 +442,15 @@ about_cb(BonoboUIComponent *uic, PilotApplet *pilot, const gchar *verbname)
+ "Matt Davey <mcdavey@mrao.cam.ac.uk>",
+ NULL};
+
+- gnome_window_icon_set_default_from_file (
+- GNOME_ICONDIR "/sync_icon.png");
++ gtk_window_set_default_icon_from_file (
++ GNOME_ICONDIR "/sync_icon.png", &error);
++
++
++ if (error)
++ {
++ g_warning ("Can't find icon: " GNOME_ICONDIR "/sync_icon.png" );
++ }
++
+ about = gnome_about_new (_("gnome-pilot applet"),
+ VERSION,
+ _("Copyright 2000-2006 Free Software Foundation, Inc."),
+@@ -493,8 +505,9 @@ properties_cb (BonoboUIComponent *uic, gpointer user_data, const gchar *verbname
+ PilotApplet *self = user_data;
+ GtkWidget *button, *entry, *dialog;
+ GladeXML *xml;
++ GError *error;
+
+- gnome_window_icon_set_default_from_file (GNOME_ICONDIR "/sync_icon.png");
++ gtk_window_set_default_icon_from_file (GNOME_ICONDIR "/sync_icon.png", &error);
+ xml =glade_xml_new (self->glade_file,"PropertiesDialog", NULL);
+ dialog=glade_xml_get_widget (xml,"PropertiesDialog");
+
+@@ -1325,7 +1338,6 @@ static void
+ create_pilot_widgets (GtkWidget *widget, PilotApplet *self)
+ {
+ GtkStyle *style;
+- int i;
+
+ static GtkTargetEntry drop_types [] = {
+ { "text/uri-list", 0, TARGET_URI_LIST },
+@@ -1345,10 +1357,10 @@ create_pilot_widgets (GtkWidget *widget, PilotApplet *self)
+
+ self->curstate = INITIALISING;
+
+- for (i = 0; i < sizeof (pixmaps)/sizeof (pixmaps[0]); i++)
++ /* for (i = 0; i < sizeof (pixmaps)/sizeof (pixmaps[0]); i++)
+ pixmaps[i] = gnome_program_locate_file(
+ NULL, GNOME_FILE_DOMAIN_PIXMAP, pixmaps[i], TRUE, NULL);
+-
++ */
+ self->image = gtk_image_new_from_file (pixmaps[self->curstate]);
+
+ gtk_signal_connect (GTK_OBJECT (widget), "button-press-event",
+--
+cgit v0.8.2
diff --git a/app-pda/gnome-pilot/gnome-pilot-2.0.17-r1.ebuild b/app-pda/gnome-pilot/gnome-pilot-2.0.17-r1.ebuild
new file mode 100644
index 000000000000..3a14ef66c553
--- /dev/null
+++ b/app-pda/gnome-pilot/gnome-pilot-2.0.17-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/gnome-pilot-2.0.17-r1.ebuild,v 1.1 2009/08/23 10:53:17 mrpouet Exp $
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="Gnome Palm Pilot and Palm OS Device Syncing Library"
+HOMEPAGE="http://live.gnome.org/GnomePilot"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="hal"
+
+RDEPEND=">=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0
+ >=gnome-base/libglade-2.0.0
+ >=gnome-base/orbit-2.6.0
+ >=gnome-base/libbonobo-2.0.0
+ >=gnome-base/gnome-panel-2.0
+ >=gnome-base/gconf-2.0
+ dev-libs/libxml2
+ >=app-pda/pilot-link-0.11.7
+ hal? (
+ dev-libs/dbus-glib
+ >=sys-apps/hal-0.5.4
+ )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/gob-2.0.5
+ >=dev-lang/perl-5.6.0
+ dev-util/intltool"
+
+DOCS="AUTHORS COPYING* ChangeLog README NEWS"
+SCROLLKEEPER_UPDATE="0"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-usb
+ --enable-network
+ --enable-pilotlinktest
+ $(use_with hal)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ echo "libgpilotdCM/gnome-pilot-conduit-management.c" >> po/POTFILES.in
+
+ # Fix --as-needed
+ epatch "${FILESDIR}/${PN}-2.0.15-as-needed.patch"
+
+ # Fix bug #282354, applet didn't appear into the panel,
+ # due to missing call to gnome_programm_init().
+ # Patch import from upstream bug #584894.
+ epatch "${FILESDIR}/${P}-invisible-applet.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+pkg_postinst() {
+ if ! built_with_use --missing false app-pda/pilot-link bluetooth; then
+ elog "if you want bluetooth support, please rebuild app-pda/pilot-link"
+ elog "echo 'app-pda/pilot-link bluetooth >> /etc/portage/package.use"
+ fi
+}