summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-04-09 13:45:06 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-04-09 13:45:06 +0000
commit4f996c54e848639570646e72689ea92153ec3f16 (patch)
treed71dbaeaa5baaa1a5c492c696f0e9b88c8cfab50 /app-pda
parentClean up old revision. (diff)
downloadgentoo-2-4f996c54e848639570646e72689ea92153ec3f16.tar.gz
gentoo-2-4f996c54e848639570646e72689ea92153ec3f16.tar.bz2
gentoo-2-4f996c54e848639570646e72689ea92153ec3f16.zip
Fix multiple issues, see ChangeLog and ebuild if intrested
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/coldsync/ChangeLog8
-rw-r--r--app-pda/coldsync/coldsync-3.0_pre4.ebuild63
2 files changed, 48 insertions, 23 deletions
diff --git a/app-pda/coldsync/ChangeLog b/app-pda/coldsync/ChangeLog
index a54bf8426f2e..d97d9e70d77a 100644
--- a/app-pda/coldsync/ChangeLog
+++ b/app-pda/coldsync/ChangeLog
@@ -1,10 +1,10 @@
# ChangeLog for app-pda/coldsync
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/ChangeLog,v 1.12 2011/03/31 06:11:33 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/ChangeLog,v 1.13 2011/04/09 13:45:06 ssuominen Exp $
- 31 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> coldsync-3.0_pre4.ebuild:
- Let people install stable 2.2.5-r1 instead of development 3.0_pre4 and set
- empty KEYWORDS="".
+ 09 Apr 2011; Samuli Suominen <ssuominen@gentoo.org> coldsync-3.0_pre4.ebuild:
+ Synchronize with 2.2.5-r1 ebuild. Install to perl vendor-dir instead of perl
+ site-dir wrt #297204. Export CC and CXX wrt #243694.
31 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> coldsync-2.2.5-r1.ebuild,
+files/coldsync-2.2.5-toolchain.patch:
diff --git a/app-pda/coldsync/coldsync-3.0_pre4.ebuild b/app-pda/coldsync/coldsync-3.0_pre4.ebuild
index 075ac0ea02bc..aa92c0892bdc 100644
--- a/app-pda/coldsync/coldsync-3.0_pre4.ebuild
+++ b/app-pda/coldsync/coldsync-3.0_pre4.ebuild
@@ -1,42 +1,63 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/coldsync-3.0_pre4.ebuild,v 1.5 2011/03/31 06:11:33 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/coldsync-3.0_pre4.ebuild,v 1.6 2011/04/09 13:45:06 ssuominen Exp $
EAPI=2
+inherit flag-o-matic perl-module toolchain-funcs
-MY_PV=${PV/_/-}
+MY_P=${PN}-${PV/_/-}
DESCRIPTION="A command-line tool to synchronize PalmOS PDAs with Unix workstations"
HOMEPAGE="http://www.coldsync.org/"
-SRC_URI="http://www.coldsync.org/download/coldsync-${MY_PV}.tar.gz"
+SRC_URI="http://www.coldsync.org/download/${MY_P}.tar.gz"
LICENSE="Artistic"
SLOT="0"
-# Let people install working 2.2.5-r1 instead of this prerelease, also 243694 and 297204.
-#KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-KEYWORDS=""
-IUSE="nls perl usb caps"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="caps nls perl usb"
-RDEPEND="usb? ( virtual/libusb:0 )
+RDEPEND="caps? ( sys-libs/libcap )
perl? ( dev-lang/perl )
- caps? ( sys-libs/libcap )"
-DEPEND="${RDEPEND}"
+ usb? ( virtual/libusb:0 )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
-S=${WORKDIR}/${PN}-${MY_PV}
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_prepare
+ popd
+ fi
+}
src_configure() {
- local myconf
+ tc-export CC CXX
+ append-cflags -fno-strict-aliasing
+ append-ldflags $(no-as-needed)
- myconf="${myconf} `use_with perl`"
- myconf="${myconf} `use_with nls i18n`"
- myconf="${myconf} `use_with usb libusb`"
- myconf="${myconf} `use_with caps capabilities`"
+ econf \
+ $(use_with nls i18n) \
+ $(use_with caps capabilities) \
+ $(use_with usb libusb) \
+ --without-perl
- econf ${myconf}
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_configure
+ popd
+ fi
}
src_compile() {
emake -j1 || die #279292
+
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_compile
+ popd
+ fi
}
src_install() {
@@ -52,7 +73,11 @@ src_install() {
EXTRA_INFOFILES="" \
install || die
- use perl && rm -f "${D}"/usr/lib/perl5/*/*/perllocal.pod
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_install
+ popd
+ fi
- dodoc AUTHORS ChangeLog HACKING NEWS README TODO
+ dodoc AUTHORS ChangeLog FAQ HACKING NEWS README* TODO
}