summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Lauwers <blauwers@gentoo.org>2003-04-19 01:21:14 +0000
committerBart Lauwers <blauwers@gentoo.org>2003-04-19 01:21:14 +0000
commit2ba997df3aa41485fd86b367678a63a389b87fde (patch)
tree50e74e237ea20959615e26f99cec8b88831d8c6b /app-pda
parentPer BUg #16017 (diff)
downloadgentoo-2-2ba997df3aa41485fd86b367678a63a389b87fde.tar.gz
gentoo-2-2ba997df3aa41485fd86b367678a63a389b87fde.tar.bz2
gentoo-2-2ba997df3aa41485fd86b367678a63a389b87fde.zip
Bugfix per #16017
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/plptools/ChangeLog3
-rw-r--r--app-pda/plptools/files/digest-plptools-0.11-r11
-rw-r--r--app-pda/plptools/plptools-0.11-r1.ebuild36
3 files changed, 40 insertions, 0 deletions
diff --git a/app-pda/plptools/ChangeLog b/app-pda/plptools/ChangeLog
index ff4a39967051..aaf1cf1b2046 100644
--- a/app-pda/plptools/ChangeLog
+++ b/app-pda/plptools/ChangeLog
@@ -3,6 +3,9 @@
*plptools-0.11.ebuild (17 Dec 2002)
+ 10 Apr 2003; B.Lauwers <blauwers@gentoo.org> plptools-0.11-r1.ebuild :
+ Fixed build per BUG 16017
+
17 Dec 2002; B.Lauwers <blauwers@gentoo.org> :
Initial release. Set of libraries and utilities to communicate with a Psion
palmtop over a serial line. Ebuild submitted by Stas Gobunov <left@komus.net>
diff --git a/app-pda/plptools/files/digest-plptools-0.11-r1 b/app-pda/plptools/files/digest-plptools-0.11-r1
new file mode 100644
index 000000000000..7b1404878c5e
--- /dev/null
+++ b/app-pda/plptools/files/digest-plptools-0.11-r1
@@ -0,0 +1 @@
+MD5 425f792a3c3598d2b1d4a51cb3ec5960 plptools-0.11.tar.gz 989279
diff --git a/app-pda/plptools/plptools-0.11-r1.ebuild b/app-pda/plptools/plptools-0.11-r1.ebuild
new file mode 100644
index 000000000000..e405966e4c55
--- /dev/null
+++ b/app-pda/plptools/plptools-0.11-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/plptools/plptools-0.11-r1.ebuild,v 1.1 2003/04/19 01:21:14 blauwers Exp $
+
+DESCRIPTION="Libraries and utilities to communicate with a Psion palmtop via serial."
+HOMEPAGE="http://plptools.sourceforge.net"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/plptools/${P}.tar.gz"
+LICENSE="as-is"
+
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="virtual/glibc"
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ patch -p1 < ${FILESDIR}/${P}-gentoo.patch || die "Patch failed!"
+
+ local myconf
+
+ myconf="${myconf} --disable-kde"
+
+ ./configure ${myconf} --prefix=/usr || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc CHANGES README TODO
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/psion.conf psion
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/psion
+}