summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-22 02:56:05 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-22 02:56:05 +0000
commit115da52e0fa6aa5311998ed301dd721b28505af3 (patch)
treed60fc44aff6aa6868de72e5f0d65901c5912cad7 /app-pda
parentfix HOMEPAGE (Manifest recommit) (diff)
downloadgentoo-2-115da52e0fa6aa5311998ed301dd721b28505af3.tar.gz
gentoo-2-115da52e0fa6aa5311998ed301dd721b28505af3.tar.bz2
gentoo-2-115da52e0fa6aa5311998ed301dd721b28505af3.zip
Fix warnings and Makefile errors. Enable building of gtk viewer and desktop if USE=gtk
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/plucker/ChangeLog9
-rw-r--r--app-pda/plucker/Manifest5
-rw-r--r--app-pda/plucker/files/digest-plucker-1.8-r11
-rw-r--r--app-pda/plucker/files/plucker-1.8-Makefile.in.patch13
-rw-r--r--app-pda/plucker/plucker-1.8-r1.ebuild78
5 files changed, 104 insertions, 2 deletions
diff --git a/app-pda/plucker/ChangeLog b/app-pda/plucker/ChangeLog
index 339cc81e966b..b30e1201a562 100644
--- a/app-pda/plucker/ChangeLog
+++ b/app-pda/plucker/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-pda/plucker
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/plucker/ChangeLog,v 1.1 2004/06/21 01:14:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/plucker/ChangeLog,v 1.2 2004/06/22 02:56:05 agriffis Exp $
+
+*plucker-1.8-r1 (21 Jun 2004)
+
+ 21 Jun 2004; Aron Griffis <agriffis@gentoo.org>
+ +files/plucker-1.8-Makefile.in.patch, +plucker-1.8-r1.ebuild:
+ Fix warnings and Makefile errors. Enable building of gtk viewer and desktop if
+ USE=gtk
*plucker-1.8 (20 Jun 2004)
diff --git a/app-pda/plucker/Manifest b/app-pda/plucker/Manifest
index e300f954dfba..fee0e14d4d9c 100644
--- a/app-pda/plucker/Manifest
+++ b/app-pda/plucker/Manifest
@@ -1,4 +1,7 @@
+MD5 b0be4d01d4ae80f6829874584dc0566f plucker-1.8-r1.ebuild 2439
MD5 fba410197083ed7bd75ba22b6e099b57 ChangeLog 390
-MD5 659d1c5630abf66b0130dcd4d1a62e1f metadata.xml 220
MD5 43391bd96ba994d05428898d80ee8221 plucker-1.8.ebuild 1521
+MD5 659d1c5630abf66b0130dcd4d1a62e1f metadata.xml 220
+MD5 eceb19a50345feaf7555797e86a0ccff files/plucker-1.8-Makefile.in.patch 471
MD5 2a325fec96dd6188d796b0fbf85b3bfb files/digest-plucker-1.8 69
+MD5 2a325fec96dd6188d796b0fbf85b3bfb files/digest-plucker-1.8-r1 69
diff --git a/app-pda/plucker/files/digest-plucker-1.8-r1 b/app-pda/plucker/files/digest-plucker-1.8-r1
new file mode 100644
index 000000000000..742228ae131b
--- /dev/null
+++ b/app-pda/plucker/files/digest-plucker-1.8-r1
@@ -0,0 +1 @@
+MD5 ff4d0890ebdfd1a0f130530b67bafc0b plucker_src-1.8.tar.bz2 3134000
diff --git a/app-pda/plucker/files/plucker-1.8-Makefile.in.patch b/app-pda/plucker/files/plucker-1.8-Makefile.in.patch
new file mode 100644
index 000000000000..c1306a3d955c
--- /dev/null
+++ b/app-pda/plucker/files/plucker-1.8-Makefile.in.patch
@@ -0,0 +1,13 @@
+--- plucker-1.8/Makefile.in.agriffis 2003-10-12 07:02:17.000000000 -0400
++++ plucker-1.8/Makefile.in 2004-06-21 22:30:34.167858106 -0400
+@@ -104,8 +104,8 @@
+ cd $(TOOLS_DIR) ; $(MAKE) install-pluck_comics
+
+ install-plucker-desktop: plucker-desktop
+- @if test "$(BUILD_DESKTOP)" != "no"; then \
+- cd $(DESKTOP_DIR) ; $(MAKE) install \
++ @if test "$(BUILD_DESKTOP)" != "no"; then \
++ cd $(DESKTOP_DIR) ; $(MAKE) install ; \
+ fi
+
+ install-unpluck: unpluck
diff --git a/app-pda/plucker/plucker-1.8-r1.ebuild b/app-pda/plucker/plucker-1.8-r1.ebuild
new file mode 100644
index 000000000000..5eb172983a81
--- /dev/null
+++ b/app-pda/plucker/plucker-1.8-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/plucker/plucker-1.8-r1.ebuild,v 1.1 2004/06/22 02:56:05 agriffis Exp $
+
+IUSE="gtk"
+
+inherit python eutils
+
+DESCRIPTION="Distiller for Plucker -- offline ebook reader for Palm devices"
+HOMEPAGE="http://www.plkr.org/"
+SRC_URI="http://downloads.plkr.org/${PV}/${PN}_src-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND=">=dev-lang/python-1.5.2
+ gtk? ( >=x11-libs/gtk+-2.2 x11-libs/wxGTK )
+ sys-devel/autoconf"
+RDEPEND=">=dev-lang/python-1.5.2
+ gtk? ( >=x11-libs/gtk+-2.2 x11-libs/wxGTK )
+ || (
+ >=media-gfx/imagemagick-5.4.4
+ >=dev-python/Imaging-1.1
+ >=media-libs/netpbm-9.15
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+
+ # Repair broken Makefile.in
+ epatch ${FILESDIR}/plucker-1.8-Makefile.in.patch
+
+ # Repair documentation installation path
+ sed -i "/^DOCSDIR/s/packages/${PF}/" plucker_desktop/Makefile.in || die "sed 1 failed"
+
+ # Fix default path to netpbm files
+ sed -i "s:, 'palm\(.*\.map\):, '/usr/share/netpdb/\1:p" \
+ parser/python/PyPlucker/ImageParser.py || die "sed 2 failed"
+
+ # Fix deprecation warnings for python-2.3
+ sed -i "s:0x\w\w\w\w\w\w\w\w:&L:" \
+ parser/python/PyPlucker/helper/gettext.py || die "sed 3 failed"
+}
+
+src_compile() {
+ # --enable-desktopbuild and --disable-desktopbuild are equivalent for this
+ # package; either one will *disable* the desktopbuild. It is enabled only
+ # if the flags are lacking from the cmdline. (21 Jun 2004 agriffis)
+ econf \
+ $(useq gtk || echo --disable-desktopbuild --disable-gtkviewer) \
+ --disable-palmosbuild \
+ --disable-docbuild \
+ --with-docdir=/usr/share/doc/${PF} \
+ || die "econf failed"
+
+ # breaks when built in parallel
+ emake -j1 || die "emake failed"
+
+ # "make install" will try to access this non-existent file
+ touch TODO
+}
+
+src_install() {
+ dodir /usr/share/doc/${PF}
+ make DESTDIR=${D} install || die
+
+ # Various symlinks normally created by unix/install-plucker.sh
+ python_version
+ dosym /usr/lib/python${PYVER}/site-packages/PyPlucker/Spider.py \
+ /usr/bin/plucker-build
+ dosym /usr/lib/python${PYVER}/site-packages/PyPlucker/Plucker-Docs.py \
+ /usr/bin/plucker-decode
+ dosym /usr/lib/python${PYVER}/site-packages/PyPlucker/Decode.py \
+ /usr/bin/plucker-dump
+
+ # Extra symlink
+ dosym /usr/lib/python${PYVER}/site-packages/PyPlucker/pluck-comics.py /usr/bin/pluck-comics
+}