summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-01-21 00:41:24 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-01-21 00:41:24 +0000
commit8de775d05af30998024f7cd98288f21377613dc9 (patch)
treed167617aa6ad67c04ecc809ebdde17d19069b3fa /app-pda/synce-sync-engine
parentversion bump, bug #254886 (diff)
downloadgentoo-2-8de775d05af30998024f7cd98288f21377613dc9.tar.gz
gentoo-2-8de775d05af30998024f7cd98288f21377613dc9.tar.bz2
gentoo-2-8de775d05af30998024f7cd98288f21377613dc9.zip
version bump, bug #254886
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/synce-sync-engine')
-rw-r--r--app-pda/synce-sync-engine/ChangeLog10
-rw-r--r--app-pda/synce-sync-engine/synce-sync-engine-0.13.ebuild63
2 files changed, 71 insertions, 2 deletions
diff --git a/app-pda/synce-sync-engine/ChangeLog b/app-pda/synce-sync-engine/ChangeLog
index 5d98585efde3..3d938be7fdd6 100644
--- a/app-pda/synce-sync-engine/ChangeLog
+++ b/app-pda/synce-sync-engine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/synce-sync-engine
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/ChangeLog,v 1.2 2008/11/21 00:11:37 mescalinum Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/ChangeLog,v 1.3 2009/01/21 00:41:24 mescalinum Exp $
+
+*synce-sync-engine-0.13 (21 Jan 2009)
+
+ 21 Jan 2009; Federico Ferri <mescalinum@gentoo.org>
+ +synce-sync-engine-0.13.ebuild:
+ version bump, bug #254886
21 Nov 2008; Federico Ferri <mescalinum@gentoo.org>
synce-sync-engine-0.11.1.ebuild, synce-sync-engine-0.12.ebuild:
diff --git a/app-pda/synce-sync-engine/synce-sync-engine-0.13.ebuild b/app-pda/synce-sync-engine/synce-sync-engine-0.13.ebuild
new file mode 100644
index 000000000000..fb8d1220ba31
--- /dev/null
+++ b/app-pda/synce-sync-engine/synce-sync-engine-0.13.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/synce-sync-engine-0.13.ebuild,v 1.1 2009/01/21 00:41:24 mescalinum Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="SynCE - Synchronization engine"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND="dev-python/pygobject
+ >=dev-python/dbus-python-0.83.0
+ >=app-pda/libopensync-plugin-python-0.22
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-python/pyxml
+ ~app-pda/synce-librra-0.12
+ ~app-pda/synce-librtfcomp-1.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+SRC_URI="mirror://sourceforge/synce/sync-engine-${PV}.tar.gz"
+S=${WORKDIR}/sync-engine-${PV}
+
+src_install() {
+ DOCS="CHANGELOG COPYING"
+
+ insinto /usr/share/${PN}/
+ doins config/syncengine.conf.xml
+
+ insinto /usr/share/dbus-1/services/
+ doins config/org.synce.SyncEngine.service
+
+ distutils_src_install
+
+ # TODO - move this to separate ebuilds.
+ if has_version '>=app-pda/libopensync-0.30'; then
+ insinto /usr/lib/opensync-1.0/python-plugins
+ newins plugins/synce-opensync-plugin-3x.py synce-opensync-plugin.py
+ else
+ insinto /usr/lib/opensync/python-plugins
+ newins plugins/synce-opensync-plugin-2x.py synce-opensync-plugin.py
+ fi
+}
+
+pkg_postinst() {
+ elog ""
+ elog "IMPORTANT - If you are upgrading from a version earlier than 19-12-2007"
+ elog "(earlier than 0.11), please delete the contents of your ~/.synce directory"
+ elog "including the partnerships subdirectory, but KEEP config.xml. Then recreate"
+ elog "your partnerships. Please see the CHANGELOG for more info."
+ elog ""
+ elog "config.xml has been renamed to syncengine.conf.xml"
+ elog ""
+
+ elog "A default configuration file has been installed into"
+ elog "/usr/share/${PN}/syncengine.conf.xml The default search path for this file"
+ einfo "is /etc/ then ~/.synce/ You may customise it by copying it to either of"
+ einfo "those locations. Note you will have to manually migrate your old config.xml"
+}