summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-25 16:09:15 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-25 16:09:15 +0000
commit7f96be351feab573ef3d68b6d4f748ee82f54d90 (patch)
tree8d930f97792ef36599d582b74ff4ced49410c474 /app-pda/synce-sync-engine
parentremoved dmenu from RDEPEND, helpers USE, not needed anymore (diff)
downloadgentoo-2-7f96be351feab573ef3d68b6d4f748ee82f54d90.tar.gz
gentoo-2-7f96be351feab573ef3d68b6d4f748ee82f54d90.tar.bz2
gentoo-2-7f96be351feab573ef3d68b6d4f748ee82f54d90.zip
Initial commit.
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/synce-sync-engine')
-rw-r--r--app-pda/synce-sync-engine/ChangeLog10
-rw-r--r--app-pda/synce-sync-engine/metadata.xml9
-rw-r--r--app-pda/synce-sync-engine/synce-sync-engine-0.15.1.ebuild34
3 files changed, 53 insertions, 0 deletions
diff --git a/app-pda/synce-sync-engine/ChangeLog b/app-pda/synce-sync-engine/ChangeLog
new file mode 100644
index 000000000000..4f1420be6f73
--- /dev/null
+++ b/app-pda/synce-sync-engine/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-pda/synce-sync-engine
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/ChangeLog,v 1.9 2011/02/25 16:09:15 ssuominen Exp $
+
+*synce-sync-engine-0.15.1 (25 Feb 2011)
+
+ 25 Feb 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +synce-sync-engine-0.15.1.ebuild:
+ Initial commit.
+
diff --git a/app-pda/synce-sync-engine/metadata.xml b/app-pda/synce-sync-engine/metadata.xml
new file mode 100644
index 000000000000..cd109a873f9d
--- /dev/null
+++ b/app-pda/synce-sync-engine/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>pda</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-pda/synce-sync-engine/synce-sync-engine-0.15.1.ebuild b/app-pda/synce-sync-engine/synce-sync-engine-0.15.1.ebuild
new file mode 100644
index 000000000000..51c5da49f75e
--- /dev/null
+++ b/app-pda/synce-sync-engine/synce-sync-engine-0.15.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/synce-sync-engine-0.15.1.ebuild,v 1.1 2011/02/25 16:09:15 ssuominen Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="A sync engine for SynCE"
+HOMEPAGE="http://www.synce.org/"
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/librapi2[python]
+ dev-libs/libxml2[python]
+ dev-libs/libxslt[python]
+ dev-python/dbus-python
+ dev-python/pygobject"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="plugins SyncEngine"
+
+src_prepare() {
+ sed -i -e "s:share/doc/sync-engine:share/doc/${PF}:" setup.py || die
+ distutils_src_prepare
+}