summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-08-06 12:28:27 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-08-06 12:28:27 +0000
commit6850eac564f0dbf8bdc29b36db445813f64b9e55 (patch)
treeb91dc831b75ab30b6984b13fe42ce4a86c0466ff /app-pda/synce-sync-engine
parentadding synce-0.14 packages (diff)
downloadgentoo-2-6850eac564f0dbf8bdc29b36db445813f64b9e55.tar.gz
gentoo-2-6850eac564f0dbf8bdc29b36db445813f64b9e55.tar.bz2
gentoo-2-6850eac564f0dbf8bdc29b36db445813f64b9e55.zip
adding synce-0.14 packages
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/synce-sync-engine')
-rw-r--r--app-pda/synce-sync-engine/ChangeLog8
-rw-r--r--app-pda/synce-sync-engine/synce-sync-engine-0.14.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/app-pda/synce-sync-engine/ChangeLog b/app-pda/synce-sync-engine/ChangeLog
index 3862e8c2a7a0..6ee09989d02e 100644
--- a/app-pda/synce-sync-engine/ChangeLog
+++ b/app-pda/synce-sync-engine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/synce-sync-engine
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/ChangeLog,v 1.6 2009/08/05 12:50:21 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/ChangeLog,v 1.7 2009/08/06 12:28:27 mescalinum Exp $
+
+*synce-sync-engine-0.14 (06 Aug 2009)
+
+ 06 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
+ +synce-sync-engine-0.14.ebuild:
+ adding synce-0.14 packages
05 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
-synce-sync-engine-0.11.1.ebuild,
diff --git a/app-pda/synce-sync-engine/synce-sync-engine-0.14.ebuild b/app-pda/synce-sync-engine/synce-sync-engine-0.14.ebuild
new file mode 100644
index 000000000000..af2f57ac21e9
--- /dev/null
+++ b/app-pda/synce-sync-engine/synce-sync-engine-0.14.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/synce-sync-engine-0.14.ebuild,v 1.1 2009/08/06 12:28:27 mescalinum Exp $
+
+inherit eutils distutils versionator
+
+DESCRIPTION="SynCE - Synchronization engine"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+synce_PV=$(get_version_component_range 1-2)
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND="dev-python/pygobject
+ >=dev-python/dbus-python-0.83.0
+ >=app-pda/libopensync-plugin-python-0.22
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-python/pyxml
+ =app-pda/synce-librra-${synce_PV}*
+ ~app-pda/synce-librtfcomp-1.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+src_install() {
+ DOCS="CHANGELOG COPYING"
+
+ insinto /usr/share/${PN}/
+ doins config/syncengine.conf.xml
+
+ insinto /usr/share/dbus-1/services/
+ doins config/org.synce.SyncEngine.service
+
+ distutils_src_install
+
+ # TODO - move this to separate ebuilds.
+ if has_version '>=app-pda/libopensync-0.30'; then
+ insinto /usr/lib/opensync-1.0/python-plugins
+ newins plugins/synce-opensync-plugin-3x.py synce-opensync-plugin.py
+ else
+ insinto /usr/lib/opensync/python-plugins
+ newins plugins/synce-opensync-plugin-2x.py synce-opensync-plugin.py
+ fi
+}
+
+pkg_postinst() {
+ elog ""
+ elog "IMPORTANT - If you are upgrading from a version earlier than 19-12-2007"
+ elog "(earlier than 0.11), please delete the contents of your ~/.synce directory"
+ elog "including the partnerships subdirectory, but KEEP config.xml. Then recreate"
+ elog "your partnerships. Please see the CHANGELOG for more info."
+ elog ""
+ elog "config.xml has been renamed to syncengine.conf.xml"
+ elog ""
+
+ elog "A default configuration file has been installed into"
+ elog "/usr/share/${PN}/syncengine.conf.xml The default search path for this file"
+ einfo "is /etc/ then ~/.synce/ You may customise it by copying it to either of"
+ einfo "those locations. Note you will have to manually migrate your old config.xml"
+}