summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2008-12-14 17:02:30 +0000
committerFederico Ferri <mescalinum@gentoo.org>2008-12-14 17:02:30 +0000
commitd7b662eea27494163212b44e25bc0d7fa9698168 (patch)
tree1197c3596492d179d74f44bd350d5d172f0c49a1 /app-pda/synce-kio-rapip
parentamd64/x86 stable, bug #245701 (diff)
downloadgentoo-2-d7b662eea27494163212b44e25bc0d7fa9698168.tar.gz
gentoo-2-d7b662eea27494163212b44e25bc0d7fa9698168.tar.bz2
gentoo-2-d7b662eea27494163212b44e25bc0d7fa9698168.zip
fix qt3 inherit - bug #247804, bug #127280
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-pda/synce-kio-rapip')
-rw-r--r--app-pda/synce-kio-rapip/ChangeLog8
-rw-r--r--app-pda/synce-kio-rapip/synce-kio-rapip-0.10-r1.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/app-pda/synce-kio-rapip/ChangeLog b/app-pda/synce-kio-rapip/ChangeLog
index bfcb41d38b39..03b35faf0ecc 100644
--- a/app-pda/synce-kio-rapip/ChangeLog
+++ b/app-pda/synce-kio-rapip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/synce-kio-rapip
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-kio-rapip/ChangeLog,v 1.1 2008/11/13 00:07:29 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-kio-rapip/ChangeLog,v 1.2 2008/12/14 17:02:30 mescalinum Exp $
+
+*synce-kio-rapip-0.10-r1 (14 Dec 2008)
+
+ 14 Dec 2008; Federico Ferri <mescalinum@gentoo.org>
+ +synce-kio-rapip-0.10-r1.ebuild:
+ fix qt3 inherit - bug #247804, bug #127280
*synce-kio-rapip-0.10 (13 Nov 2008)
diff --git a/app-pda/synce-kio-rapip/synce-kio-rapip-0.10-r1.ebuild b/app-pda/synce-kio-rapip/synce-kio-rapip-0.10-r1.ebuild
new file mode 100644
index 000000000000..0b19cd8b208b
--- /dev/null
+++ b/app-pda/synce-kio-rapip/synce-kio-rapip-0.10-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-kio-rapip/synce-kio-rapip-0.10-r1.ebuild,v 1.1 2008/12/14 17:02:30 mescalinum Exp $
+
+inherit distutils eutils qt3
+
+DESCRIPTION="SynCE - KDE kioslave for the SynCE RAPIP protocol"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+IUSE="arts"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+RDEPEND="~app-pda/synce-libsynce-0.12
+ ~app-pda/synce-librapi2-0.12"
+DEPEND="${RDEPEND}
+ arts? ( kde-base/arts )"
+
+#need-kde 3.2
+
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+S="${WORKDIR}/synce-kio-rapip-${PV}"
+
+src_compile() {
+ econf $(use_with arts) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README ChangeLog # TODO
+}
+
+pkg_postinst() {
+ elog "To use, simply open Konqueror, Dolphin, or any other KIO-enabled file"
+ elog "manager and type in rapip://DEVICENAME/ to the address bar. If you are"
+ elog "not sure about the name of your device, simply go to rapip:/ which"
+ elog "will show the first device it finds."
+}