summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-08-06 12:29:52 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-08-06 12:29:52 +0000
commit4f4d8bef85acf593f8a3fa788be277ce8a0baed1 (patch)
treed9e5f2267810eaae9a075ef39df8f75290316231 /app-pda/synce-hal
parentadding synce-0.14 packages (diff)
downloadgentoo-2-4f4d8bef85acf593f8a3fa788be277ce8a0baed1.tar.gz
gentoo-2-4f4d8bef85acf593f8a3fa788be277ce8a0baed1.tar.bz2
gentoo-2-4f4d8bef85acf593f8a3fa788be277ce8a0baed1.zip
adding synce-0.14 packages
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/synce-hal')
-rw-r--r--app-pda/synce-hal/ChangeLog8
-rw-r--r--app-pda/synce-hal/synce-hal-0.14.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/app-pda/synce-hal/ChangeLog b/app-pda/synce-hal/ChangeLog
index 24a84907f838..32f9497901ea 100644
--- a/app-pda/synce-hal/ChangeLog
+++ b/app-pda/synce-hal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/synce-hal
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-hal/ChangeLog,v 1.8 2009/08/05 12:53:22 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-hal/ChangeLog,v 1.9 2009/08/06 12:29:52 mescalinum Exp $
+
+*synce-hal-0.14 (06 Aug 2009)
+
+ 06 Aug 2009; Federico Ferri <mescalinum@gentoo.org>
+ +synce-hal-0.14.ebuild:
+ adding synce-0.14 packages
05 Aug 2009; Federico Ferri <mescalinum@gentoo.org> -synce-hal-0.1.ebuild,
-synce-hal-0.2.ebuild:
diff --git a/app-pda/synce-hal/synce-hal-0.14.ebuild b/app-pda/synce-hal/synce-hal-0.14.ebuild
new file mode 100644
index 000000000000..e01b9d0e8dc5
--- /dev/null
+++ b/app-pda/synce-hal/synce-hal-0.14.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-hal/synce-hal-0.14.ebuild,v 1.1 2009/08/06 12:29:52 mescalinum Exp $
+
+inherit multilib versionator
+
+DESCRIPTION="SynCE - hal connection manager"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+synce_PV=$(get_version_component_range 1-2)
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="sys-apps/hal
+ >=net-libs/gnet-2.0.0
+ !app-pda/synce-dccm
+ !app-pda/synce-vdccm
+ !app-pda/synce-odccm
+ =app-pda/synce-libsynce-${synce_PV}*
+ =app-pda/synce-librapi2-${synce_PV}*
+ =app-pda/synce-librra-${synce_PV}*"
+RDEPEND="${DEPEND}
+ =app-pda/synce-sync-engine-${synce_PV}*
+ app-pda/synce-serial
+ net-misc/dhcp"
+
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+src_compile() {
+ if has_version '>=sys-apps/hal-0.5.13'; then
+ HAL_ADDON_DIR="/usr/libexec/scripts"
+ else
+ HAL_ADDON_DIR="/usr/$(get_libdir)/hal/scripts"
+ fi
+ econf --with-hal-addon-dir="${HAL_ADDON_DIR}" --localstatedir="/var" || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS README ChangeLog || die
+
+ # fix collision with app-pda/synce-serial, bug 246675
+ rm -f "${D}/usr/libexec/synce-serial-chat"
+}