summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-12-20 23:08:58 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-12-20 23:08:58 +0000
commit9863a3ca3b122966dede2b40928c9cdc23d4442c (patch)
tree3700810ee73865b82ec851401650ee22512bc991 /app-pda/pilot-link
parentAdd link to upstream bug report for the ecj patch. (diff)
downloadgentoo-2-9863a3ca3b122966dede2b40928c9cdc23d4442c.tar.gz
gentoo-2-9863a3ca3b122966dede2b40928c9cdc23d4442c.tar.bz2
gentoo-2-9863a3ca3b122966dede2b40928c9cdc23d4442c.zip
Added an upstream patch to fix 64-bit issues causing problems in some applications using pilot-link (e. g. jpilot, bug 87842). Disabled parallel make for now as it's badly broken (bug 202857).
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'app-pda/pilot-link')
-rw-r--r--app-pda/pilot-link/ChangeLog8
-rw-r--r--app-pda/pilot-link/files/pilot-link-0.12.3-int_types.patch31
-rw-r--r--app-pda/pilot-link/pilot-link-0.12.3.ebuild8
3 files changed, 45 insertions, 2 deletions
diff --git a/app-pda/pilot-link/ChangeLog b/app-pda/pilot-link/ChangeLog
index 470daa989052..8cd36aab8199 100644
--- a/app-pda/pilot-link/ChangeLog
+++ b/app-pda/pilot-link/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/pilot-link
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.31 2007/12/19 21:09:49 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.32 2007/12/20 23:08:58 philantrop Exp $
+
+ 20 Dec 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/pilot-link-0.12.3-int_types.patch, pilot-link-0.12.3.ebuild:
+ Added an upstream patch to fix 64-bit issues causing problems in some
+ applications using pilot-link (e. g. jpilot, bug 87842). Disabled parallel
+ make for now as it's badly broken (bug 202857).
*pilot-link-0.12.3 (19 Dec 2007)
diff --git a/app-pda/pilot-link/files/pilot-link-0.12.3-int_types.patch b/app-pda/pilot-link/files/pilot-link-0.12.3-int_types.patch
new file mode 100644
index 000000000000..872c59e4e946
--- /dev/null
+++ b/app-pda/pilot-link/files/pilot-link-0.12.3-int_types.patch
@@ -0,0 +1,31 @@
+--- pilot-link-0.12.3/include/pi-md5.h 2006-10-17 15:24:07.000000000 +0200
++++ pilot-link/include/pi-md5.h 2007-12-18 04:03:09.000000000 +0100
+@@ -1,5 +1,5 @@
+ /*
+- * $Id: pilot-link-0.12.3-int_types.patch,v 1.1 2007/12/20 23:08:58 philantrop Exp $
++ * $Id: pilot-link-0.12.3-int_types.patch,v 1.1 2007/12/20 23:08:58 philantrop Exp $
+ *
+ * pi-md5.h: Header file for Colin Plumb's MD5 implementation.
+ * Modified by Ian Jackson so as not to use Colin Plumb's
+@@ -13,8 +13,20 @@
+ #ifndef MD5_H
+ #define MD5_H
+
++#include "config.h"
++#if HAVE_INTTYPES_H
++#include <inttypes.h>
++#endif
++#if HAVE_STDINT_H
++#include <stdint.h>
++#endif
++#ifdef HAVE_INTTYPES_H || HAVE_STDINT_H
++#define UINT8 uint8_t
++#define UINT32 uint32_t
++#else
+ #define UINT8 unsigned char
+-#define UINT32 unsigned long
++#define UINT32 unsigned int
++#endif
+
+ struct MD5Context {
+ UINT32 buf[4];
diff --git a/app-pda/pilot-link/pilot-link-0.12.3.ebuild b/app-pda/pilot-link/pilot-link-0.12.3.ebuild
index 0da9c146929b..d3bfdbe863d6 100644
--- a/app-pda/pilot-link/pilot-link-0.12.3.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.12.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3.ebuild,v 1.1 2007/12/19 21:09:49 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3.ebuild,v 1.2 2007/12/20 23:08:58 philantrop Exp $
inherit perl-module java-pkg-opt-2 eutils autotools
@@ -30,6 +30,9 @@ DEPEND="${BOTH_DEPEND}
RDEPEND="${BOTH_DEPEND}
java? ( >=virtual/jre-1.4 )"
+# Unfortunately, parallel compilation is badly broken. cf. bug 202857.
+MAKEOPTS="${MAKEOPTS} -j1"
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -46,6 +49,9 @@ src_unpack() {
# their installation here.
use java && epatch "${FILESDIR}/${P}-java-install.patch"
+ # Upstream patch to fix 64-bit issues.
+ epatch "${FILESDIR}/${P}-int_types.patch"
+
AT_M4DIR="m4" eautoreconf
}