summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-09-27 23:32:06 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-09-27 23:32:06 +0000
commita2451bf5ad2e05a19005613c8bae19cc3ad3992e (patch)
tree2099cee08cefb0e0b4a9e78dc317ebe2d19d1eff /app-pda/libsyncml
parentamd64 stable (diff)
downloadgentoo-2-a2451bf5ad2e05a19005613c8bae19cc3ad3992e.tar.gz
gentoo-2-a2451bf5ad2e05a19005613c8bae19cc3ad3992e.tar.bz2
gentoo-2-a2451bf5ad2e05a19005613c8bae19cc3ad3992e.zip
Change libsoup to 2.4 slot, bug #280906.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/libsyncml')
-rw-r--r--app-pda/libsyncml/ChangeLog8
-rw-r--r--app-pda/libsyncml/libsyncml-0.5.2-r1.ebuild56
-rw-r--r--app-pda/libsyncml/libsyncml-9999.ebuild6
3 files changed, 66 insertions, 4 deletions
diff --git a/app-pda/libsyncml/ChangeLog b/app-pda/libsyncml/ChangeLog
index 1faf0a01d51d..86e407c7789b 100644
--- a/app-pda/libsyncml/ChangeLog
+++ b/app-pda/libsyncml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/libsyncml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.15 2009/09/27 00:25:19 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.16 2009/09/27 23:32:06 eva Exp $
+
+*libsyncml-0.5.2-r1 (27 Sep 2009)
+
+ 27 Sep 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +libsyncml-0.5.2-r1.ebuild, libsyncml-9999.ebuild:
+ Change libsoup to 2.4 slot, bug #280906.
27 Sep 2009; Mart Raudsepp <leio@gentoo.org> -libsyncml-0.4.5.ebuild,
-libsyncml-0.4.6.ebuild, libsyncml-0.4.6-r1.ebuild:
diff --git a/app-pda/libsyncml/libsyncml-0.5.2-r1.ebuild b/app-pda/libsyncml/libsyncml-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..eada88661f2e
--- /dev/null
+++ b/app-pda/libsyncml/libsyncml-0.5.2-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-0.5.2-r1.ebuild,v 1.1 2009/09/27 23:32:06 eva Exp $
+
+EAPI="2"
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Implementation of the SyncML protocol"
+HOMEPAGE="http://libsyncml.opensync.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="bluetooth debug doc http +obex"
+
+RDEPEND=">=dev-libs/glib-2.0
+ >=dev-libs/libwbxml-0.9.2
+ dev-libs/libxml2
+ http? ( net-libs/libsoup:2.4 )
+ obex? ( >=dev-libs/openobex-1.1 )
+ bluetooth? ( net-wireless/bluez
+ >=dev-libs/openobex-1.1[bluetooth] )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+# Some of the tests are broken
+RESTRICT="test"
+
+pkg_setup() {
+ if ! use obex && ! use http; then
+ eerror "${CATEGORY}/${P} without support for obex nor http is unusable."
+ eerror "Please enable \"obex\" or/and \"http\" USE flags."
+ die "Please enable \"obex\" or/and \"http\" USE flags."
+ fi
+
+ if use bluetooth && ! use obex; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"bluetooth\""
+ eerror "USE flag, but you didn't enable the \"obex\" flag, which is"
+ eerror "needed for bluetooth support."
+ eerror "Please enable \"obex\" USE flag."
+ die "Please enable \"obex\" USE flag."
+ fi
+}
+
+src_compile() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable http HTTP)
+ $(cmake-utils_use_enable obex OBEX)
+ $(cmake-utils_use_enable bluetooth BLUETOOTH)
+ $(cmake-utils_use_enable debug TRACE)"
+
+ cmake-utils_src_compile
+}
diff --git a/app-pda/libsyncml/libsyncml-9999.ebuild b/app-pda/libsyncml/libsyncml-9999.ebuild
index 53060873561c..3cf919615d9b 100644
--- a/app-pda/libsyncml/libsyncml-9999.ebuild
+++ b/app-pda/libsyncml/libsyncml-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-9999.ebuild,v 1.4 2008/02/03 23:27:19 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-9999.ebuild,v 1.5 2009/09/27 23:32:06 eva Exp $
EAPI="1"
@@ -20,7 +20,7 @@ IUSE="bluetooth +debug doc http +obex"
RDEPEND=">=dev-libs/glib-2.0
>=dev-libs/libwbxml-0.9.2
dev-libs/libxml2
- http? ( >=net-libs/libsoup-2.2.91:2.2 )
+ http? ( net-libs/libsoup:2.4 )
obex? ( >=dev-libs/openobex-1.1 )
bluetooth? ( net-wireless/bluez-libs )"
DEPEND="${RDEPEND}