summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2006-11-25 10:44:26 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2006-11-25 10:44:26 +0000
commit6a956309edd5066e54bb9c77694acea2fb1e4092 (patch)
tree699f7d9f3ad4117ef9d6ece9be554d5a22ee1cb8 /app-pda/libsyncml
parentAdding app-text/epdfview to tree; based on ebuild available on site. (diff)
downloadgentoo-2-6a956309edd5066e54bb9c77694acea2fb1e4092.tar.gz
gentoo-2-6a956309edd5066e54bb9c77694acea2fb1e4092.tar.bz2
gentoo-2-6a956309edd5066e54bb9c77694acea2fb1e4092.zip
Add a patch to fix some wbxml problems.
(Portage version: 2.1.2_rc2-r1)
Diffstat (limited to 'app-pda/libsyncml')
-rw-r--r--app-pda/libsyncml/ChangeLog8
-rw-r--r--app-pda/libsyncml/files/digest-libsyncml-0.4.2-r13
-rw-r--r--app-pda/libsyncml/files/libsyncml-0.4.2-wbxml.patch22
-rw-r--r--app-pda/libsyncml/libsyncml-0.4.2-r1.ebuild60
4 files changed, 92 insertions, 1 deletions
diff --git a/app-pda/libsyncml/ChangeLog b/app-pda/libsyncml/ChangeLog
index 42fb991fee32..bc3bc469bb41 100644
--- a/app-pda/libsyncml/ChangeLog
+++ b/app-pda/libsyncml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/libsyncml
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.1 2006/11/13 22:02:11 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.2 2006/11/25 10:44:26 peper Exp $
+
+*libsyncml-0.4.2-r1 (25 Nov 2006)
+
+ 25 Nov 2006; Piotr Jaroszyński <peper@gentoo.org>
+ +files/libsyncml-0.4.2-wbxml.patch, +libsyncml-0.4.2-r1.ebuild:
+ Add a patch to fix some wbxml problems.
*libsyncml-0.4.2 (13 Nov 2006)
diff --git a/app-pda/libsyncml/files/digest-libsyncml-0.4.2-r1 b/app-pda/libsyncml/files/digest-libsyncml-0.4.2-r1
new file mode 100644
index 000000000000..095359054d2e
--- /dev/null
+++ b/app-pda/libsyncml/files/digest-libsyncml-0.4.2-r1
@@ -0,0 +1,3 @@
+MD5 66fad49f54e78ce34c1453c62958e037 libsyncml-0.4.2.tar.gz 512702
+RMD160 ca8d7459807160d6e4a0bf98de01136c295cb458 libsyncml-0.4.2.tar.gz 512702
+SHA256 f9d15887ab0c9103f7798940e22f5a864a6aa3de80f9796c1b56f8876d566f1e libsyncml-0.4.2.tar.gz 512702
diff --git a/app-pda/libsyncml/files/libsyncml-0.4.2-wbxml.patch b/app-pda/libsyncml/files/libsyncml-0.4.2-wbxml.patch
new file mode 100644
index 000000000000..225ebefbe9cb
--- /dev/null
+++ b/app-pda/libsyncml/files/libsyncml-0.4.2-wbxml.patch
@@ -0,0 +1,22 @@
+diff -ur libsyncml-0.4.2/libsyncml/parser/sml_xml_assm.c libsyncml/libsyncml/parser/sml_xml_assm.c
+--- libsyncml-0.4.2/libsyncml/parser/sml_xml_assm.c 2006-09-09 16:40:08.000000000 +0200
++++ libsyncml/libsyncml/parser/sml_xml_assm.c 2006-11-24 16:20:14.000000000 +0100
+@@ -1441,14 +1443,17 @@
+ /* Add the syncml start node */
+ switch (assm->session->version) {
+ case SML_VERSION_10:
++ xmlTextWriterWriteRaw(assm->writer, (xmlChar *)"<!DOCTYPE SyncML PUBLIC \"-//SYNCML//DTD SyncML 1.0//EN\" \"http://www.syncml.org/docs/syncml_represent_v10_20001207.dtd\">");
+ if (!_smlXmlAssemblerStartNodeNS(assm, SML_ELEMENT_SYNCML, SML_NAMESPACE_SYNCML10, error))
+ goto error_free_writer;
+ break;
+ case SML_VERSION_11:
++ xmlTextWriterWriteRaw(assm->writer, (xmlChar *)"<!DOCTYPE SyncML PUBLIC \"-//SYNCML//DTD SyncML 1.1//EN\" \"http://www.syncml.org/docs/syncml_represent_v11_20020213.dtd.dtd\">");
+ if (!_smlXmlAssemblerStartNodeNS(assm, SML_ELEMENT_SYNCML, SML_NAMESPACE_SYNCML11, error))
+ goto error_free_writer;
+ break;
+ case SML_VERSION_12:
++ xmlTextWriterWriteRaw(assm->writer, (xmlChar *)"<!DOCTYPE SyncML PUBLIC \"-//SYNCML//DTD SyncML 1.2//EN\" \"http://www.openmobilealliance.org/tech/DTD/OMA-TS-SyncML_RepPro_DTD-V1_2.dtd\">");
+ if (!_smlXmlAssemblerStartNodeNS(assm, SML_ELEMENT_SYNCML, SML_NAMESPACE_SYNCML12, error))
+ goto error_free_writer;
+ break;
+
diff --git a/app-pda/libsyncml/libsyncml-0.4.2-r1.ebuild b/app-pda/libsyncml/libsyncml-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..e330572233fd
--- /dev/null
+++ b/app-pda/libsyncml/libsyncml-0.4.2-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-0.4.2-r1.ebuild,v 1.1 2006/11/25 10:44:26 peper Exp $
+
+inherit eutils
+
+DESCRIPTION="Implementation of the SyncML protocol"
+HOMEPAGE="http://libsyncml.opensync.org/"
+SRC_URI="http://dev.gentooexperimental.org/~peper/distfiles/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="bluetooth debug doc http obex"
+#test
+
+RDEPEND=">=dev-libs/glib-2.0
+ >=dev-libs/libwbxml-0.9.2
+ dev-libs/libxml2
+ http? ( >=net-libs/libsoup-2.2.91 )
+ obex? ( >=dev-libs/openobex-1.1 )
+ bluetooth? ( net-wireless/bluez-libs )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+ #test? ( dev-libs/check )
+
+# Some of the tests are broken
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix some wbxml problems
+ epatch "${FILESDIR}/${P}-wbxml.patch"
+}
+
+src_compile() {
+ econf \
+ $(use_enable bluetooth) \
+ $(use_enable obex) \
+ $(use_enable http) \
+ $(use_enable debug) \
+ $(use_enable debug tracing) \
+ --disable-unit-tests \
+ || die "econf failed"
+ #$(use_enable test unit-tests) \
+
+ emake || die "emake failed"
+
+ use doc && doxygen Doxyfile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+
+ use doc && dohtml docs/html/*
+}